O programu Package Builder

Co je to Package Builder?


Co je to Package Builder?

Package Builder umožňuje vytvářet vlastní instalační balíčky, které je možné spustit bez zásahu uživatele a integrovat do nasazovaného řešení. Jedná se o nástroj, který generuje instalační balíčky ovladačů, které automatizují instalaci ovladačů tiskárny s předem nakonfigurovanými možnostmi připojení a tisku.


Konfigurace instalačního balíčku

Poznámky:

  • V zadaném umístění jsou vygenerovány soubory ve formátech .cab a .exe.
  • Obsah balíčku závisí na tom, jaké vyberete možnosti.
  • Některé z těchto funkcí jsou k dispozici pouze u vybraných modelů tiskáren.

Výběr obsahu balíčku

V části Možnosti obsahu balíčku vyberte jednu nebo více z následujících možností:

  • Zahrnout ovladače tisku nebo faxu

  • Zahrnout ovladače skenování nebo další software

  • Podpora pouze jednoho jazyka

    Poznámka: Ve výchozím nastavení jsou ve vygenerovaném balíčku zahrnuty všechny jazyky, které produkt podporuje. Chcete-li zmenšit velikost balíčku, vyberte možnost Podpora pouze jednoho jazyka, a potom zvolte příslušný jazyk.

Výběr možností balíčku dostupných během instalace

V části Možnosti doby instalace balíčku vyberte jednu z následujících možností:

  • Chcete-li skrýt stav instalace, vyberte možnost Skrytá instalace.

  • Chcete-li zobrazit stav instalace s licenční smlouvou, vyberte možnost Zobrazit stav instalace uživateli, a potom vyberte možnost Zahrnout licenční smlouvu.

    Poznámka: Uživatel musí souhlasit s licenční smlouvou, aby mohl balíček nainstalovat.

  • Chcete-li zobrazit stav instalace a vyzvat uživatele ke zvolení portu, vyberte možnost Zobrazit stav instalace uživateli, a potom vyberte možnost Zobrazit výzvu k výběru portu.

    Poznámka: Uživatel musí vybrat port během instalace vygenerovaného balíčku.


Konfigurace tiskového ovladače

Název tiskárny

Sdílení tiskárny

Identifikace ostatních dostupných ovladačů

Soubor Driver Configuration File

Použití konfiguračních nastavení


Název tiskárny

Ve výchozím nastavení je název tiskárny model vaší tiskárny. Bývá uváděn také jako název objektu tiskárny, který se vytvoří po instalaci. Objekt tiskárny zastupuje skutečnou tiskárnu, které je přiřazena tisková úloha. Zkontrolujte, zda má objekt tiskárny jedinečný název, podle něhož lze tiskárnu správně identifikovat v síti.

Poznámky:

  • Chcete-li nastavit objekt tiskárny jako výchozí tiskárnu, vyberte příkaz Nastavit jako výchozí tiskárnu.
  • Chcete-li nechat tiskárnu, aby rozpoznala název tiskárny během instalace, vyberte možnost Zjistit název tiskárny. Tato možnost nemusí být u některých modelů tiskáren k dispozici.


Sdílení tiskárny

Zaškrtněte políčko Sdílet tiskárnu a zadejte následující informace:

  • Sdílet název – Název, který se zobrazí ostatním uživatelům, když ukáží na sdílenou tiskárnu.

  • Komentáře –Jakékoli další poznámky ke sdílené tiskárně. Tato položka je nepovinná.

  • Umístění – Označuje umístění sdílené tiskárny. Tato položka je nepovinná.

Poznámka: Zkontrolujte, zda je zapnuté sdílení souborů a tisku.


Identifikace ostatních dostupných ovladačů

Z našich webových stránek lze stáhnout univerzální tiskové ovladače (PCL 5, PCL XL, PS a XPS). Kompatibilní ovladače zobrazíte vyhledáním modelu vaší tiskárny.


Soubor Driver Configuration File

V souboru DCF (Driver Configuration File) jsou uložena nastavení tiskárny a další data. Soubory DCF mají příponu .ldc.

Při použití programu Package Builder vyberte soubor DCF obsahující konfigurace, které chcete použít k vytvoření objektu tiskárny. Každá konfigurace v souboru DCF je označena pomocí popisu.

Soubor DCF může obsahovat jednu konfiguraci pro libovolný počet modelů tiskárny a libovolný počet různých ovladačů (emulace PostScript nebo PCL v systému Windows).

Poznámka: Nástroj Driver Configuration Utility vyžaduje služby Microsoft XML Core Services (MSXML) 6. Ty je možné stáhnout z www.microsoft.com.


Použití konfiguračních nastavení

  1. V části Nastavení konfigurace vyberte možnost Použít konfiguraci pro použití nastavení.

    1. Chcete-li použít stávající konfigurační soubor, klepněte na tlačítko Načíst soubor.

    2. Chcete-li vytvořit nový konfigurační soubor, postupujte následovně:

      1. Klepněte na tlačítko Nový.

      2. Vyberte konfigurační data, která chcete vytvořit.

      3. Klepněte na tlačítko Dokončit a uložte nastavení.

        4. Poznámka: Pokud chcete použít stejnou konfiguraci pro všechny následně vytvářené tiskové fronty, vyberte možnost Použít pro všechny budoucí instalace. Jinak bude konfigurace použita pouze pro tento objekt tiskárny.

  2. Klepněte na tlačítko OK.


Konfigurace připojení tiskárny

Výběr tiskárny ze zjištěného portu

Připojení tiskárny pomocí kabelu USB

Přidání síťové tiskárny

Popis typů portů

Ruční spuštění nástroje Status Messenger

Specifikace portu pomocí příkazového řádku

Co je to název portu?

Proč není moje tiskárna v seznamu?


Výběr tiskárny ze zjištěného portu

  1. Pokud budete chtít navázat připojení tiskárny přes zjištěný port, zjistěte si následující informace:

    Informace o tiskárně

    Popis

    Úplný název domény (v části TCP/IP)

    Zahrnuje název tiskárny a sítě, ke které je tiskárna připojena. Jedná se také o název tiskárny.

    Adresa IP (v části TCP/IP)

    Jedinečné číslo používané tiskárnou k vyhledávání a komunikaci s ostatními zařízeními v síti.

    UAA (MAC) (v části Standardní síťová karta)

    Jedinečné hardwarové identifikační číslo, kterým se tiskárna odlišuje od ostatních zařízení v síti.

    Automatická konfigurace IP sítě (v části TCP/IP)

    Označuje, že tiskárna podporuje metodu zeroconf neboli zero configuration networking (automatickou konfiguraci IP sítě).

    Poznámka: Pokud nemáte požadované informace, vytiskněte si stránku s nastavením sítě. Další informace naleznete v Uživatelské příručce.

  2. Vyberte svou tiskárnu v seznamu a klepněte na tlačítko Pokračovat.

  3. Pokud tiskárna není v seznamu obsažena, zkuste jeden nebo více z následujících postupů:

    • Aktualizujte seznam tiskáren.

    • Klepněte na tlačítko Upravit hledání a přidejte tiskárnu ručně pomocí rozšířených nastavení sítě.

    • Klepněte na tlačítko Konfigurace bezdrátového připojení a přidejte tiskárnu připojenou k bezdrátové síti.

    • Klepněte na tlačítko Zadat port a přidejte tiskárnu ručně pomocí portů.

    • Zkontrolujte, zda aplikace jiných dodavatelů neblokují tiskárnu.

    • Zkontrolujte, zda počítač není připojen k síti VPN (Virtual Private Network).

    • Zkontrolujte, zda jsou počítač i tiskárna připojeny ke stejné síti.

    • Zkontrolujte, zda má tiskárna přiřazenu platnou, jedinečnou adresu IP.


Připojení tiskárny pomocí kabelu USB

Pokud jste zvolili možnost Připojit pomocí kabelu USB, operační systém vytvoří objekt tiskárny implicitně. Název objektu tiskárny by se měl shodovat s názvem vytvořeným operačním systémem.

Poznámky:

  • K dokončení instalace a vytvoření objektu tiskárny musí uživatel připojit kabel USB.
  • Po připojení tiskárny pomocí portu USB musí uživatel ručně spustit nástroj Status Messenger.


Přidání síťové tiskárny

Pomocí dialogového okna Přidat síťovou tiskárnu můžete vyhledat tiskárny podle názvu, adresy IP nebo podsítě. Najděte svou tiskárnu a potom ji ručně přidejte do seznamu dostupných síťových tiskáren.

Poznámka: Zjistěte si název a adresu IP tiskárny, a podsíť, do které patří. Tyto informace naleznete na stránce nastavení sítě (vytiskněte si ji). Další informace naleznete v Uživatelské příručce.

Pomocí názvu a adresy IP tiskárny

Zadejte název nebo adresu IP tiskárny a klepněte na tlačítko OK.

Pomocí adresy podsítě

Pokud jsou tiskárna a tiskový server umístěny v jiné síti (takzvaná podsíť), najdete dostupné tiskárny zadáním podsítě, ve které je daná tiskárna umístěna.

  • Chcete-li přidat adresu podsítě, zadejte do příslušného pole adresu podsítě a klepněte na tlačítko Přidat > OK.

    Poznámka: Můžete také vyhledat více adres podsítí.

  • Chcete-li adresu podsítě odebrat, zvýrazněte adresu podsítě v seznamu nalezených podsítí a klepněte na tlačítko Odebrat.


Popis typů portů

Poznámka: Některé porty mohou být k dispozici pouze u vybraných modelů tiskáren.
Typy portů | Popis
Externí tiskový server | Jedná se o externí zařízení, které umožňuje přístup k síti prostřednictvím portů sítě Ethernet.
LPR (Line Printer Remote) | Tento protokol se používá pro odesílání tiskových úloh do vzdálené tiskárny.
Tiskový server | Jde o počítač nebo zařízení připojené k jedné nebo více tiskárnám a ke klientským počítačům v síti. Může přijímat tiskové úlohy z počítačů a odesílat je do příslušných tiskáren.
Standardní TCP/IP (Transmission Control Protocol/Internet Protocol) | Tento protokol definuje pravidla, která musí počítače dodržovat při vzájemné komunikaci prostřednictvím Internetu.
UNC (Universal Naming Convention) | Jedná se o standard, definující identifikaci serverů, tiskáren a dalších prostředků v síti bez mapování síťové jednotky. Každému sdílenému prostředku přidělí jedinečnou adresu. Operační systémy podporující typ UNC tak mohou úplně specifikovat adresář na souborovém serveru.


Ruční spuštění nástroje Status Messenger

Poznámka: Zkontrolujte, zda je tiskárna připojena k počítači pomocí kabelu USB.

V systému Windows 8

Do pole Hledat napište příkaz status messenger a přejděte na:

Seznam aplikací > Status Messenger

V systému Windows 7 nebo nižším

  1. Klepněte na tlačítko [image] nebo Start.

  2. Klepněte na položku Všechny programy nebo Programy a vyberte v seznamu složku s programy tiskárny.

  3. Klepněte na položku Domovská stránka tiskárny > Status Messenger.

Otevře se nástroj Status Messenger.

Poznámky:

  • Status Messenger je k dispozici pouze tehdy, jestliže jste ho zahrnuli během konfigurace balíčku.
  • Pokud nezvolíte možnost spustit nástroj Status Messenger ručně po vytvoření objektu tiskárny, Status Messenger se automaticky spustí po restartování počítače.


Specifikace portu pomocí příkazového řádku

Můžete uvést název a adresu portu v příkazovém řádku během instalace, když zvolíte možnost Specify the port at install time through the command line.

Parametr | Hodnota | Ukázka
/port: | Název portu | /port:nazev_portu
/address: | Název sítě nebo IP adresa tiskárny | /address:123.123.123.123 /address:nazev_site

Ukázka příkazového řádku: LexmarkPkgInstall.exe /port:nazev_portu /address:123.123.123.123

Poznámky:

  • LexmarkPkgInstall.exe vrátí po úspěšné instalaci hodnotu 0.
  • Aby bylo možné úspěšně spustit instalaci, zadejte parametry portu a adresy.
  • Zadaný název a adresa portu se použijí pro všechny tiskové objekty v balíčku, které mají být během instalace specifikovány. Objektům tiskárny, kterým jsou během vytvoření balíčku přiřazeny porty, zůstane port vybraný během vytváření balíčku.
  • Parametry příkazového řádku pro název a adresu portu se zpracují pouze tehdy, pokud byl balíček vytvořen tak, aby akceptoval název a adresu portu z příkazového řádku. Pokud jsou tyto parametry zapracovány do balíčku, který nemá získávat tyto informace z příkazového řádku, instalace bude pokračovat, ale tyto parametry budou ignorovány. Porty se vytvářejí na základě informací v balíčku, nikoli podle parametrů v příkazovém řádku. V příkazovém řádku se zobrazí upozornění. V tomto případě je vrácen kód 0, protože instalace byla úspěšně dokončena.


Co je to název portu?

Název portu je jedinečný název přiřazený portu v počítači, ke kterému je připojena tiskárna.


Proč není moje tiskárna v seznamu?

Zkontrolujte, zda jsou počítač i tiskárna připojeny ke stejné bezdrátové síti.

Tiskárna možná není ve stejné bezdrátové síti jako počítač. Pokud je počítač již připojen k bezdrátové síti, SSID tiskárny musí odpovídat SSID počítače.

  1. Zjistěte identifikátor SSID sítě, ke které je počítač připojen.

    1. Zadejte do pole adresy ve webovém prohlížeči adresu IP přístupového bodu (bezdrátového směrovače).

      Pokud neznáte adresu IP přístupového bodu, postupujte následovně:

      V systému Windows 8

      Do pole Hledat napište příkaz run a přejděte na:

      Seznam aplikací > Spustit > napište cmd > OK > napište ipconfig

      V systému Windows 7 nebo nižším

      1. Klepněte na tlačítko [image] nebo Start a potom na příkaz Spustit.

      2. Do pole Začít hledat nebo Spustit napište cmd.

      3. Stiskněte klávesu Enter nebo klepněte na tlačítko OK a zadejte příkaz ipconfig.

      Poznámky:

      • Obvykle je přístupovým bodem položka „Výchozí brána“, ale zkontrolujte, zda patří v informacích příkazu ipconfig do části „Připojení k bezdrátové síti“.
      • IP adresa se zobrazí jako čtyři sady čísel oddělených tečkou, například 123.123.123.123.

    2. Stiskněte klávesu Enter nebo tlačítko Zobrazit.

    3. Po zobrazení výzvy zadejte uživatelské jméno a heslo pro přístupový bod a klepněte na tlačítko OK.

    4. V sekci nastavení bezdrátové sítě se podívejte na položku SSID.

    5. Zapište si SSID.

      Poznámka: Zkontrolujte, zda jste ho zkopírovali přesně, včetně veškerých velkých písmen.

  2. Zjistěte identifikátor SSID sítě, ke které je tiskárna připojena:

    1. Pomocí tiskárny vytiskněte stránku nastavení sítě.

      Další informace naleznete v Uživatelské příručce.

    2. V části Bezdrátová síť vyhledejte položku SSID.

  3. Porovnejte identifikátory SSID počítače a tiskárny.

    Pokud jsou identifikátory SSID stejné, jsou počítač i tiskárna připojeny ke stejné bezdrátové síti.

    Pokud identifikátory SSID nejsou stejné, spusťte znovu Nástroj pro nastavení bezdrátové sítě a nastavte tiskárnu pro bezdrátovou síť používanou počítačem. Musíte vybrat identifikátor SSID použitý počítačem.

Zkontrolujte, zda počítač není připojen k síti VPN (Virtual Private Network).

Většina sítí VPN umožňuje počítačům komunikovat v dané chvíli pouze s danou sítí VPN a již s žádnou jinou sítí. Před instalováním ovladače do počítače nebo před spuštěním nástroje pro nastavení bezdrátové sítě v počítači odpojte počítač od sítě VPN.

Chcete-li zjistit, zda je počítač připojen k síti VPN, otevřete klientský software sítě VPN a zkontrolujte připojení k síti VPN. Pokud nemáte v počítači nainstalován klientský software VPN, zkontrolujte připojení ručně pomocí klienta VPN systému Windows.

Pokud chcete být současně připojeni k místní síti a k síti VPN, musí správce sítě VPN povolit rozdělené tunelování. V některých organizacích se rozdělené tunelování nepovoluje z důvodu zabezpečení nebo z technických důvodů.

Zkontrolujte, zda aplikace jiných dodavatelů neblokují tiskárnu.

Aplikace jiných dodavatelů, včetně antivirových programů, programů pro zabezpečení a bran firewall mohou blokovat rozpoznání tiskárny. Nakonfigurujte nastavení aplikací tak, aby neblokovaly tiskárnu, a proveďte aktualizaci seznamu sítí.


Výběr dalšího softwaru

Při výběru dalšího softwaru mějte na zřeteli následující body:

  • Vybraný software bude zahrnut ve vygenerovaném balíčku a během instalace bude nainstalován do zadaného adresáře v systému uživatele.

  • Při instalaci následného balíčku použijte stejnou instalační cestu, aby bylo zajištěno, že bude nainstalována pouze jedna kopie instalované aplikace a sice nejnovější verze.

  • Některé soubory mohou být nainstalovány buď do adresáře x86, nebo do 64bitového systému; závisí to na použitém operačním systému.

  • Seznam softwarových aplikací e u jednotlivých modelů tiskáren může lišit.


Spuštění vygenerovaného balíčku

Postupujte jedním z následujících způsobů:

  • Použijte přihlašovací skripty operačního systému.

  • Sdílejte balíčky a nechte uživatele, aby je vyvolali.

Poznámka: Ujistěte se, zda máte dostatečná oprávnění správce k provedení instalace.


Nápověda k programu Package Builder