Om Hjælp til Pakkeopbygger

Hvad er en Pakkeopbygger?


Hvad er en Pakkeopbygger?

Med Pakkeopbygger kan du oprette brugertilpassede installationspakker, som du kan starte uden brugerinput og integrere i din distributionsløsning. Det er et værktøj, der genererer driverinstallationspakker, der automatiserer installationen af printerdrivere med forudkonfigurerede tilslutnings- og udskrivningsmuligheder.


Konfiguration af installationspakken

Bemærkninger:

  • Filer i formaterne .cab og .exe genereres på den angivne placering.
  • Pakkens indhold afhænger af de indstillinger, du vælger.
  • Nogle af disse funktioner er kun tilgængelige i udvalgte printermodeller.

Vælg pakkens indhold

I afsnittet Pakkeindstillinger skal du vælge en eller flere af følgende:

  • Inkluder printer- og/eller faxdrivere

  • Inkluder scanningsdrivere og/eller yderligere software

  • Understøt kun et enkelt sprog

    Bemærk! Som standard inkluderes alle sprog, som produktet understøtter, i den genererede pakke. Hvis du vil reducere størrelsen på pakken, skal du vælge Understøt kun et enkelt sprog og derefter vælge det relevante sprog.

Få vist de optioner, der er ledige til installation på printeren.

I afsnittet "Installationstid for pakken", skal du gøre et af følgende:

  • Hvis du vil skjule installationsstatus, skal du vælge Uovervåget installation.

  • Hvis du vil have vist installationsstatus med licensaftalen, skal du vælge Vis installationsstatus for bruger, og vælg derefter Inkluder licensaftalen.

    Bemærk! Brugeren skal acceptere licensaftalen for at installere pakken.

  • Hvis du vil have vist installationsstatus og bede brugeren om at vælge en port, skal du vælge Vis installationsstatus for bruger, og vælg derefter Spørg bruger om portvalg.

    Bemærk! Brugeren skal vælge porten ved installationen af den genererede pakke.


Konfiguration af printerdriveren

Om printernavnet

Deling af printeren

Identificering af andre tilgængelige drivere

Om driverkonfigurationsfilen

Brug af konfigurationsindstillinger


Om printernavnet

Som standard er printernavnet printerens modelnavn. Det kaldes også det printerobjektnavn, som oprettes efter installationen. Et printerobjekt repræsenterer den aktuelle printer, som et udskrivningsjob kan blive tildelt. Dit printerobjekt skal have et entydigt navn, så du kan identificere den med netværket.

Bemærkninger:

  • For at sætte printerobjektet til standardprinter skal du vælge Benyt som standardprinter.
  • Vælg Registrer printernavn for at lade programmet registrere dit printerobjektnavn under installationen. Denne funktion er muligvis ikke tilgængelig, afhængigt af hvilken printer, du har købt.


Deling af printeren

Marker afkrydsningsfeltet Del printeren, og indtast derefter følgende oplysninger:

  • Sharenavn – Det navn, som andre brugere ser, når de peger på en delt printer.

  • Kommentarer – Yderligere bemærkninger til den delte printer. Dette er valgfrit.

  • Placering – Angiver placeringen for den delte printer. Dette er valgfrit.

Bemærk! Kontroller, at fil- og udskriftsdeling er aktiveret.


Identificering af andre tilgængelige drivere

Universalprinterdrivere (PCL 5, PCL XL, PS og XPS) kan hentes fra vores websted. Søg efter din printermodel for at få vist de kompatible drivere.


Om driverkonfigurationsfilen

En driverkonfigurationsfil (DCF) er en fil, som lagrer gemte printerindstillinger og andre data. DCF'er bruger filtypenavnet .ldc.

Når du skal bruge Pakkeopbygger skal du vælge den DCF-fil, som indeholder de konfigurationer, du vil bruge til at oprette et printerobjekt. Den individuelle konfiguration af en DCF identificeres vha. en beskrivelse.

En DCF kan indeholde én konfiguration til en række printermodeller og forskellige drivere (PostScript- eller PCL-emuleringer til Windows).

Bemærk! Hjælpeprogrammet til driverkonfiguration kræver Microsoft XML Core Services (MSXML) 6. Det kan downloades fra www.microsoft.com.


Brug af konfigurationsindstillinger

  1. Fra afsnittet Konfigurationsindstillinger skal du vælge Brug en konfiguration til at anvende indstillinger.

    1. Hvis du vil bruge en eksisterende konfigurationsfil, skal du klikke på Indlæs fil.

    2. Hvis du vil oprette en ny konfigurationsfil, skal du gøre følgende:

      1. Klik på Ny.

      2. Vælge de konfigurationsdata, du vil oprette.

      3. Klik på Afslut og gem indstillingerne.

        4. Bemærk! Hvis du ønsker at anvende den samme konfiguration til alle efterfølgende printkøoprettelser, skal du vælge Anvend på alle fremtidige installationer. Ellers vil konfigurationen kun blive anvendt på dette printerobjekt.

  2. Klik på OK.


Konfiguration af printerforbindelsen

Valg af printeren fra en registreret port

Tilslutning af printeren via et USB-kabel

Tilføje en netværksprinter

Beskrivelse af porttyper

Manuel start af Status Messenger

Angivelse af en port vha. kommandolinjen

Hvad er et portnavn?

Hvorfor vises printeren ikke på listen?


Valg af printeren fra en registreret port

  1. Hvis du vælger at etablere en printerforbindelse via en registreret port, skal du finde følgende oplysninger:

    Printeroplysninger

    Beskrivelse

    Fuldstændigt domænenavn (i TCP/IP-sektionen)

    Dette omfatter navnet på printeren og det netværk, som den er sluttet til. Dette er også navnet på printeren.

    IP-adresse (i TCP/IP-sektionen)

    Dette er et entydigt nummer, som printeren bruger til at kommunikere med og finde andre enheder på netværket.

    UAA (MAC) (i afsnittet Standardnetværkskort).

    Dette er et entydigt hardwareidentifikationsnummer, der adskiller printeren fra andre enheder på netværket.

    Konfigurationsfrit navn (i TCP/IP-sektionen)

    Dette angiver, at din printer understøtter zeroconf eller konfigurationsfrie netværk.

    Bemærk! Hvis du ikke har de nødvendige oplysninger, kan du udskrive en netværksopsætningsside. Du kan finde yderligere oplysninger i Brugervejledningen.

  2. Vælg din printer på listen, og klik derefter på Fortsæt.

  3. Hvis printeren ikke findes på listen, kan du prøve et eller flere af følgende:

    • Opdater printerlisten.

    • Klik på Rediger søgning for at tilføje din printer manuelt ved brug af avancerede netværksindstillinger.

    • Klik på Konfigurer trådløs for at tilføje en printer, der er tilsluttet et trådløst netværk.

    • Klik på Angiv port for at tilføje din printer manuelt ved brug af porte.

    • Kontroller, at printeren ikke blokeres af tredjepartsprogrammer.

    • Kontroller, at computeren ikke er tilsluttet et VPN-netværk (Virtual Private Network).

    • Kontroller, at printeren og computeren er sluttet til det samme trådløse netværk.

    • Kontrollér, at printeren er tildelt en gyldig, entydig IP-adresse.


Tilslutning af printeren via et USB-kabel

Hvis du har valgt Tilslut vha. USB-kabel, opretter operativsystemet printerobjektet som standard. Printerobjektets navn bør svare til det, der oprettes af operativsystemet.

Bemærkninger:

  • Brugeren skal isætte USB-kablet for at fuldføre installationen og oprette printerobjektet.
  • Når du har tilsluttet printeren via USB-porten, skal brugeren starte Status Messenger manuelt.


Tilføje en netværksprinter

Brug dialogboksen Tilføj printer for at søge efter printere ud fra printernavn, IP-adresse eller undernet. Find din printer og tilføj det manuelt til listen over tilgængelige netværksprintere.

Bemærk! Sørg for, at du kender navnet og IP-adressen på den printer, du vil bruge, og undernettet, det tilhører. For at hente disse oplysninger, skal du udskrive en netværksopsætningsside. Du kan finde yderligere oplysninger i brugervejledningen.

Bruge printernavn og IP-adresse

Skriv printernavnet eller IP-adressen og klik derefter på Ok.

Brug af undernetadresser

Hvis printeren og printerserveren befinder sig i et andet netværk (kaldet et undernet), skal du finde tilgængelige printere ved at specifice subnettet for den printer, du ønsker adgang til.

  • For at tilføje en subnetadresse skal du indtaste subnetadressen i det angivne felt og klikke på Tilføj > OK.

    Bemærk! Du kan også søge efter flere undernetadresser.

  • Hvis du vil fjerne en undernetadresse, skal du markere undernetadressen på listen over registrerede undernet og derefter klikke på Fjern.


Beskrivelse af porttyper

Bemærk! Visse porte er muligvis kun tilgængelig på udvalgte printermodeller.
Porttyper | Beskrivelse
Ekstern printerserver | Dette er en ekstern enhed, som tillader netværksadgang vis sine Ethernet-porte.
LPR (Line Printer Remote) | Dette er en protokol til at sende udskrivningsjob til en fjernprinter.
Printserver | Dette er en computer eller enhed, som er forbundet til en eller flere printere og til klientcomputere over et netværk. Det kan acceptere udskrivningsjob fra computere og sende job til passende printere.
Standard TCP/IP (Transmission Control Protocol/Internet Protocol) | Dette er en protokol, som definerer den regel, computerne skal følge for at kommunikere med hinanden over internettet.
UNC (Universal Naming Convention) | Dette er en standard for identifikation af servere, printere og andre ressourcer i et netværk uden at tilknytte netværksdrevet. Det udstyrer alle delte ressourcer med en entydig adresse. Dette giver mulighed for operativsystmer, som understøtter UNC for komplet specifikation på en filserver.


Manuel start af Status Messenger

Bemærk! Kontroller, at printeren og computeren er tilsluttet via et USB-kabel.

Windows 8

Fra søgesymbolet skrives statusmeddelelser, og naviger derefter til:

Apps-liste > Status Messenger

I Windows 7 eller tidligere

  1. Klik på [image] eller Start.

  2. Klik på Alle programmer eller Programmer, og vælg derefter printerprogrammappen på listen.

  3. Klik på Printerstartside > Status Messenger.

Status Messenger åbnes.

Bemærkninger:

  • Status Messenger er kun tilgængelig, hvis du har valgt at inkludere det under pakkekonfigurationen.
  • Hvis du vælger ikke at starte Status Messenger manuelt, efter at printerobjektet er oprettet, vil Status Messenger automatisk starte, når computeren genstartes.


Angivelse af en port vha. kommandolinjen

Du kan angive portnavnet og -adressen på kommandolinjen under installationen ved at vælge Angiv porten på installationstidspunktet via kommandolinjen.

Parameter | Værdi | Eksempel
/port: | Portnavn | /port:portname
/address: | Netværksnavn eller IP-adresse på printeren | /address:123.123.123.123 /address:networkname

Eksempel på kommandolinje: LexmarkPkgInstall.exe /port:portname /address:123.123.123.123

Bemærkninger:

  • LexmarkPkgInstall.exe returnerer 0 efter en gennemført installation.
  • Angiv port- og adresseparametre for at starte installationen.
  • Det portnavn og den adresse, der angives, anvendes på alle printerobjekter i pakken, der er indstillet til at blive angivet under installation. For printerobjekter, der er blevet tildelt porte under pakkeoprettelsen, benyttes den port, der blev valgt under pakketidspunktet.
  • Kommandolinjeparametrene for portnavn eller -adresse behandles kun, hvis pakken blev oprettet til at acceptere portnavnet og -adresse på kommandolinjen. Hvis disse parametre videregives til en pakke, der ikke skulle modtage disse oplysninger på kommandolinjen, fortsætter installationen, men de pågældende parametre ignoreres. Portene oprettes baseret på oplysningerne i pakken, ikke fra parametrene på kommandolinjen. Der udstedes en advarsel til kommandoprompten. I dette tilfælde er returkoden 0, da installationen blev gennemført korrekt.


Hvad er et portnavn?

Portnavnet er et entydigt navn, som gives til en port på den computer, hvor printeren er tilsluttet.


Hvorfor vises printeren ikke på listen?

Kontroller, at printeren og computeren er sluttet til det samme trådløse netværk

Printeren er muligvis ikke på det samme trådløse netværk som computeren. Printerens SSID skal stemme overens med SSID'et for computeren, hvis computeren allerede er sluttet til det trådløse netværk.

  1. Få vist oplysninger om SSID'et for det netværk, som computeren er sluttet til.

    1. Angiv IP-adressen på adgangspunktet (trådløs router) i webbrowserens adressefelt.

      Hvis du ikke allerede kender IP-adressen for adgangspunktet, skal du gøre følgende:

      Windows 8

      Fra søgesymbolet skrives Kør, og naviger derefter til:

      Apps-liste > Kør > skriv cmd > OK > skriv ipconfig

      I Windows 7 eller tidligere

      1. Klik på [image], eller klik på Start og klik derefter på Kør.

      2. Skriv cmd i feltet Start søgning eller Kør.

      3. Tryk på Enter eller klik på OK, og skriv derefter ipconfig.

      Bemærkninger:

      • Posten Standardgateway er normalt adgangspunktet, men kontroller, at det hører til afsnittet Trådløs netværksforbindelse i ipconfig-oplysningerne.
      • IP-adressen vises som fire sæt tal, adskilt af punktummer, f.eks. 123.123.123.123.

    2. Tryk på Enter eller Start.

    3. Skriv brugernavn og adgangskode til adgangspunktet, når du bliver bedt om det, og klik derefter på OK.

    4. Find SSID i sektionen Trådløse indstillinger.

    5. Skriv SSID'et ned.

      Bemærk! Kontroller, at du kopierer det præcist, herunder store bogstaver.

  2. Få vist oplysninger om SSID'et for det netværk, som printeren er sluttet til:

    1. Udskriv netværksinstallationssiden fra printeren.

      Du kan finde yderligere oplysninger i brugervejledningen'.

    2. Kig efter SSID i afsnittet om Trådløst.

  3. Sammenlign computerens SSID med printerens SSID.

    Hvis SSID'erne stemmer overens, er printeren og computeren på samme trådløse netværk.

    Hvis SSID'erne ikke stemmer overens, skal du køre det trådløse opsætningsværktøj igen for at installere printeren på det trådløse netværk, der bruges af computeren. Kontroller, at du har valgt det SSID, som computeren bruger.

Kontroller, at computeren ikke er tilsluttet et VPN-netværk (Virtual Private Network).

De fleste VPN-netværk giver kun computerne mulighed for at kommunikere med VPN-netværket og ikke med andre netværk på samme tid. Afbryd forbindelsen til VPN-netværket, inden du installerer driveren på computeren, eller inden du kører den trådløse opsætning på computeren.

Hvis du vil kontrollere, om computeren er sluttet til VPN-netværket, skal du åbne VPN-klientsoftwaren og derefter kontrollere VPN-forbindelserne. Hvis du ikke har installeret VPN-klientsoftware, skal du kontrollere forbindelserne manuelt ved hjælp af Windows VPN-klienten.

Hvis du ønsker at have mulighed for at oprette forbindelse til det lokale netværk og et VPN-netværk på samme tid, skal du bede den ansvarlige for systemsupport af VPN'en om at tillade delt tunnelføring. Bemærk, at visse virksomheder ikke tillader delt tunnelføring af sikkerhedsmæssige eller tekniske hensyn.

Kontroller, at printeren ikke blokeres af tredjepartsprogrammer

Programmer fra tredjepart, herunder antivirus-, sikkerheds- og firewallprogrammer, kan blokere, således at printeren ikke kan registreres. Konfigurer programindstillingerne til at fjerne blokering af printeren, og opdater derefter netværkslisten.


Valg af yderligere software

Bemærk følgende, når du vælger yderligere software:

  • Den valgte software vil blive inkluderet i den pakke, der genereres, og installeret på brugerens system i den angivne mappe under installationen.

  • Sørg for at benytte den samme installationssti, når du installerer en efterfølgende pakke, for at sikre, at der kun findes en udgave af det installerede program, og at det er den seneste version.

  • Nogle filer kan blive installeret i enten x86-mappen eller 64-bit-systemet, afhængigt af det benyttede operativsystem.

  • Listen over softwareprogrammer kan variere afhængigt af printermodellen.


Start af den genererede pakke

Foretag en af følgende handlinger:

  • Brug operativsystemets logonscripts.

  • Del pakkerne, og få brugerne til at aktivere dem.

Bemærk! Sørg for, at du har de fornødne administratorrettigheder for at kunne foretage installationen.


Hjælp til Pakkeopbygger