Hilfe zum Paket-Builder - Info

Was ist Paket-Builder?


Was ist Paket-Builder?

Mit dem Paket-Builder können Sie benutzerdefinierte Installationspakete erstellen, die ohne Benutzereingaben gestartet werden können, und in eine Bereitstellungslösung integrieren. Der Builder ist ein Tool, das Treiberinstallationspakete generiert, die die Installation von Druckertreibern mit vorkonfigurierten Konnektivitäts- und Druckoptionen automatisieren.


Konfigurieren des Installationspakets

Hinweise:

  • Dateien im CAB- und EXE-Format werden am angegebenen Speicherort generiert.
  • Der Paketinhalt richtet sich nach den ausgewählten Optionen.
  • Einige dieser Funktionen sind nur auf ausgewählten Druckermodellen verfügbar.

Auswählen des Paketinhalts

Wählen Sie im Abschnitt "Optionen für Paketinhalt" eine oder mehrere der folgenden Optionen:

  • Drucker- und/oder Faxtreiber einschließen

  • Scannertreiber und/oder zusätzliche Software einschließen

  • Unterstützt nur eine Sprache

    Hinweis: Standardmäßig werden alle vom Produkt unterstützten Sprachen in das generierte Paket aufgenommen. Um die Größe des Pakets zu verringern, aktivieren Sie Unterstützt nur eine Sprache und wählen dann die geeignete Sprache aus.

Auswählen der verfügbaren Paketoptionen während der Installation

Wählen Sie im Abschnitt "Optionen für die Paketinstallation" eine der folgenden Optionen:

  • Um den Installationsstatus auszublenden, wählen Sie Installation im Hintergrund.

  • Um den Installationsstatus einschließlich Lizenzvereinbarung anzuzeigen, wählen Sie Installationsstatus dem Benutzer anzeigen und anschließend Lizenzvereinbarung einfügen.

    Hinweis: Der Benutzer muss die Lizenzvereinbarung akzeptieren, um das Paket zu installieren.

  • Um den Installationsstatus anzuzeigen und den Benutzer zur Auswahl eines Anschlusses aufzufordern, wählen Sie erst Installationsstatus dem Benutzer anzeigen und dann Benutzer zur Anschlussauswahl auffordern.

    Hinweis: Der Benutzer muss den Anschluss bei der Installation des generierten Pakets auswählen.


Konfigurieren des Druckertreibers

Erläuterungen zum Druckernamen

Freigeben des Druckers

Ermitteln anderer verfügbarer Treiber

Erläuterungen zur Treiberkonfigurationsdatei

Verwenden von Konfigurationseinstellungen


Erläuterungen zum Druckernamen

Der Druckername entspricht standardmäßig dem Modellnamen des Druckers. Er wird auch als Name des Druckerobjekts bezeichnet, das nach der Installation erstellt wird. Ein Druckerobjekt entspricht dem tatsächlichen Drucker, dem ein Druckauftrag zugewiesen werden kann. Stellen Sie sicher, dass das Druckerobjekt über einen eindeutigen Namen verfügt, damit im Netzwerk der richtige Drucker identifiziert werden kann.

Hinweise:

  • Um das Druckerobjekt als Standarddrucker festzulegen, wählen Sie Als Standarddrucker festlegen.
  • Damit das Druckerobjekt während der Installation von der Anwendung erkannt wird, wählen Sie Druckernamen erkennen aus. Je nach Druckermodell ist diese Option möglicherweise nicht verfügbar.


Freigeben des Druckers

Aktivieren Sie das Kontrollkästchen Drucker freigeben und geben Sie dann die folgenden Informationen ein:

  • Freigabename: Der Name, der für andere Benutzer angezeigt wird, wenn sie auf einen freigegebenen Drucker zeigen.

  • Kommentare: Zusätzliche Hinweise zum freigegebenen Drucker. Dies ist optional.

  • Standort: Gibt den Standort des freigegebenen Druckers an. Dies ist optional.

Hinweis: Vergewissern Sie sich, dass die Datei- und Druckfreigabe aktiviert sind.


Ermitteln anderer verfügbarer Treiber

Universaldruckertreiber (PCL 5, PCL XL, PS und XPS) können von unserer Website heruntergeladen werden. Suchen Sie Ihr Druckermodell, um kompatible Treiber anzuzeigen.


Erläuterungen zur Treiberkonfigurationsdatei

Eine Treiberkonfigurationsdatei (Driver Configuration File, DCF) ist eine Datei, in der gespeicherte Druckereinstellungen und andere Daten gespeichert werden. DCFs verwenden die Dateierweiterung ".ldc".

Wählen Sie bei Verwendung des Paket-Builders die DCF-Datei mit den Konfigurationen aus, die Sie zum Erstellen eines Druckerobjekts verwenden möchten. Die individuelle Konfiguration einer DCF-Datei wird anhand einer Beschreibung identifiziert.

Eine DCF-Datei kann eine Konfiguration für eine beliebige Anzahl an Druckermodellen und eine beliebige Anzahl unterschiedlicher Treiber (PostScript- oder PCL-Emulationen für Windows) enthalten.

Hinweis: Das Dienstprogramm zur Druckertreiberkonfiguration erfordert Microsoft XML Core Services (MSXML) 6, die von www.microsoft.com heruntergeladen werden können.


Verwenden von Konfigurationseinstellungen

  1. Wählen Sie im Abschnitt "Konfigurationseinstellungen" die Option Konfiguration zum Anwenden von Einstellungen verwenden.

    1. Wenn Sie eine vorhandene Konfigurationsdatei verwenden möchten, klicken Sie auf Datei laden.

    2. Wenn Sie eine neue Konfigurationsdatei erstellen möchten, gehen Sie wie folgt vor:

      1. Klicken Sie auf Neu.

      2. Wählen Sie die zu erstellenden Konfigurationsdaten aus.

      3. Klicken Sie auf Fertig stellen und speichern Sie die Einstellungen.

        4. Hinweis: Wenn Sie dieselbe Konfiguration auf alle nachfolgend erstellten Druckwarteschlangen anwenden möchten, wählen Sie Auf alle zukünftigen Installationen anwenden aus. Andernfalls gilt die Konfiguration nur für dieses Druckerobjekt.

  2. Klicken Sie auf OK.


Konfigurieren der Druckerverbindung

Auswählen des Druckers über einen erkannten Anschluss

Anschließen des Druckers über ein USB-Kabel

Hinzufügen eines Netzwerkdruckers

Grundlagen zu Anschlusstypen

Manuelles Starten von Status Messenger

Angeben eines Anschlusses über die Befehlszeile

Was ist ein Anschlussname?

Warum wird der Drucker nicht in der Liste angezeigt?


Auswählen des Druckers über einen erkannten Anschluss

  1. Wenn Sie beabsichtigen, die Druckerverbindung über einen erkannten Anschluss herzustellen, benötigen Sie folgende Informationen:

    Druckerinformationen

    Beschreibung

    Vollständig qualifizierter Domänenname (im Abschnitt "TCP/IP")

    Schließt den Namen des Druckers und Netzwerks ein, mit dem der Drucker verbunden ist. Dies ist gleichzeitig der Druckername.

    IP-Adresse (im Abschnitt "TCP/IP")

    Dabei handelt es sich um eine eindeutige Zahl, die der Drucker verwendet, um andere Geräte in einem Netzwerk zu suchen und mit ihnen zu kommunizieren.

    UAA (MAC) (im Abschnitt "Standard-Netzwerkkarte")

    Hierbei handelt es sich um eine eindeutige Hardware-Identifizierungsnummer, die den Drucker von anderen Geräten im Netzwerk unterscheidet.

    Konfigurationsfreie Verbdg. - Name (im Abschnitt "TCP/IP")

    Gibt an, dass Ihr Drucker zeroconf oder die konfigurationsfreie Netzwerkfunktion unterstützt.

    Hinweis: Falls Sie nicht über die erforderlichen Informationen verfügen, drucken Sie eine Netzwerk-Konfigurationsseite. Weitere Informationen finden Sie im Benutzerhandbuch.

  2. Wählen Sie Ihren Drucker in der Liste aus und klicken Sie dann auf Fortfahren.

  3. Wenn Ihr Drucker nicht in der Liste enthalten ist, probieren Sie eine oder mehrere der folgenden Methoden aus:

    • Aktualisieren Sie die Druckerliste.

    • Klicken Sie auf Suche ändern, um den Drucker mithilfe erweiterter Netzwerkeinstellungen manuell hinzuzufügen.

    • Klicken Sie auf WLAN konfigurieren, um einen Drucker hinzuzufügen, der über ein WLAN verbunden ist.

    • Klicken Sie auf Anschluss angeben, um den Drucker unter Verwendung von Anschlüssen manuell hinzuzufügen.

    • Der Drucker darf nicht von Drittanbieteranwendungen blockiert werden.

    • Der Computer darf nicht an ein virtuelles privates Netzwerk (VPN) angeschlossen sein.

    • Computer und Drucker müssen mit demselben Netzwerk verbunden sein.

    • Dem Drucker wurde eine gültige, eindeutige IP-Adresse zugewiesen.


Anschließen des Druckers über ein USB-Kabel

Bei Auswahl von Mit einem USB-Kabel verbinden wird das Druckerobjekt standardmäßig vom Betriebssystem erstellt. Der Name des Druckerobjekts sollte mit dem vom Betriebssystem erstellten Namen übereinstimmen.

Hinweise:

  • Der Benutzer muss das USB-Kabel anschließen, um die Installation abzuschließen und das Druckerobjekt zu erstellen.
  • Wenn der Drucker über den USB-Anschluss angeschlossen wurde, muss Status Messenger vom Benutzer manuell gestartet werden.


Hinzufügen eines Netzwerkdruckers

Verwenden Sie das Dialogfeld "Netzwerkdrucker hinzufügen", um Drucker nach Druckernamen, IP-Adresse oder Subnetz zu suchen. Suchen Sie Ihren Drucker, und fügen Sie ihn dann manuell der Liste verfügbarer Netzwerkdrucker hinzu.

Hinweis: Vergewissern Sie sich, dass Ihnen der Name und die IP-Adresse des Druckers und das Subnetz, dem der Drucker angehört, bekannt ist. Sie finden diese Informationen, indem Sie eine Netzwerk-Konfigurationsseite ausdrucken. Weitere Informationen finden Sie im Benutzerhandbuch.

Verwenden des Druckernamens und der IP-Adresse

Geben Sie den Namen oder die IP-Adresse des Druckers ein und klicken Sie auf OK.

Verwenden der Subnetzadresse

Wenn sich Drucker und Druckserver in einem anderen Netzwerk (einem sog. Subnetz) befinden, suchen Sie die verfügbaren Drucker, indem Sie das Subnetz des Druckers angeben, auf den Sie zugreifen möchten.

  • Um eine Subnetzadresse hinzuzufügen, geben Sie die Subnetzadresse in das angegebene Feld ein und klicken dann auf Hinzufügen > OK.

    Hinweis: Sie können auch mehrere Subnetzadressen suchen.

  • Um eine Subnetzadresse zu entfernen, heben Sie die Subnetzadresse in der Liste gefundener Subnetze hervor und klicken dann auf Entfernen.


Grundlagen zu Anschlusstypen

Hinweis: Einige Anschlüsse sind möglicherweise nur auf ausgewählten Druckermodellen verfügbar.
Anschlusstypen | Beschreibung
Externer Druckserver | Hierbei handelt es sich um ein externes Gerät, das den Netzwerkzugriff über Ethernet-Anschlüsse ermöglicht.
LPR (Line Printer Remote) | Dies ist ein Protokoll, mit dem Druckaufträge an einen Remotedrucker übertragen werden können.
Druckserver | Hierbei handelt es sich um einen Computer oder ein Gerät, der bzw. das über ein Netzwerk mit einem oder mehreren Druckern und Clientcomputern verbunden ist. Der Server akzeptiert Druckaufträge von Computern und sendet die Aufträge an die geeigneten Drucker.
Standard TCP/IP (Transmission Control Protocol/Internet Protocol) | Ein Protokoll, durch das die Vorgaben definiert werden, die Computer einhalten müssen, um über das Internet miteinander zu kommunizieren.
UNC (Universal Naming Convention) | Ein Standard zum Identifizieren von Servern, Druckern und anderen Netzwerkressourcen, ohne dass das Netzlaufwerk zugeordnet wird. Jede freigegebene Ressource erhält eine eindeutige Adresse. Auf diese Weise können Betriebssysteme, die UNC unterstützen, ein vollständiges Verzeichnis auf einem Dateiserver angeben.


Manuelles Starten von Status Messenger

Hinweis: Stellen Sie sicher, dass Drucker und Computer über ein USB-Kabel verbunden sind.

Windows 8

Geben Sie im Charm "Suche" status messenger ein und navigieren Sie dann zu:

Apps-Liste > Status Messenger

Windows 7 oder frühere Version

  1. Klicken Sie auf [image] oder Start.

  2. Klicken Sie auf Alle Programme oder Programme und wählen Sie anschließend den Druckerprogrammordner aus der Liste aus.

  3. Klicken Sie auf Printer Home > Status Messenger.

Status Messenger wird geöffnet.

Hinweise:

  • Status Messenger ist nur verfügbar, wenn er während der Paketkonfiguration ausgewählt wurde.
  • Wenn Sie festgelegt haben, den Status Messenger nach der Erstellung des Druckobjekts nicht manuell zu starten, wird der Status Messenger nach dem Neustart des Computers automatisch gestartet.


Angeben eines Anschlusses über die Befehlszeile

Sie können den Anschlussnamen und die Anschlussadresse während der Installation über die Befehlszeile angeben, indem Sie Anschluss während der Installation über die Befehlszeile angeben auswählen.

Parameter | Wert | Beispiel
/port: | Anschlussname | /port:portname
/address: | Netzwerkname oder IP-Adresse des Druckers | /address:123.123.123.123 /address:networkname

Beispiel für die Befehslzeile: LexmarkPkgInstall.exe /port:portname /address:123.123.123.123

Hinweise:

  • "LexmarkPkgInstall.exe" gibt nach einer erfolgreichen Installation "0" zurück.
  • Geben Sie die Anschluss- und Adressparameter an, um die Installation erfolgreich zu starten.
  • Der angegebene Anschlussname und die Adresse werden auf alle Druckobjekte im Paket angewendet, für die festgelegt wurde, dass sie während der Installation angegeben werden müssen. Bei Druckerobjekten, denen während der Paketerstellung Anschlüsse zugewiesen werden, wird der während der Paketerstellung ausgewählte Anschluss verwendet.
  • Die Befehlszeilenparameter für den Anschlussnamen oder die Adresse werden nur verarbeitet, wenn das Paket so konfiguriert wurde, dass der Anschlussname und die Adresse in der Befehlszeile akzeptiert werden. Wenn diese Parameter an ein Paket übergeben werden, das nicht für die Übergabe dieser Informationen in der Befehlszeile konfiguriert wurde, wird die Installation ohne Berücksichtigung dieser Parameter fortgesetzt. Die Anschlüsse werden auf Grundlage der im Paket enthaltenen Informationen und nicht auf Grundlage der über die Befehlszeile übergebenen Parameter erstellt. Eine Warnung wird an die Eingabeaufforderung ausgegeben. In diesem Fall ist der Rückgabecode "0", weil die Installation erfolgreich abgeschlossen wurde.


Was ist ein Anschlussname?

Der Anschlussname ist ein eindeutiger Name, der dem Anschluss am Computer zugewiesen ist, an den der Drucker angeschlossen ist.


Warum wird der Drucker nicht in der Liste angezeigt?

Computer und Drucker müssen an dasselbe WLAN angeschlossen sein

Der Drucker befindet sich möglicherweise nicht im selben WLAN wie der Computer. Wenn der Computer bereits mit einem WLAN verbunden ist, muss die SSID des Druckers mit der SSID des Computers übereinstimmen.

  1. Erfragen Sie die SSID des Netzwerks, in das der Computer eingebunden ist.

    1. Geben Sie die IP-Adresse des Zugriffspunkts (WLAN-Routers) in das Adressfeld Ihres Webbrowsers ein.

      Wenn Sie die IP-Adresse des Zugriffspunkts nicht kennen, gehen Sie wie folgt vor:

      Windows 8

      Geben Sie im Charm "Suche" Ausführen ein und navigieren Sie dann zu:

      Apps-Liste > Ausführen > cmd eingeben > OK > ipconfig eingeben

      Windows 7 oder frühere Version

      1. Klicken Sie auf [image] oder auf Start und dann auf Ausführen.

      2. Geben Sie im Feld "Suche starten" oder "Ausführen" cmd ein.

      3. Drücken Sie die Eingabetaste oder klicken Sie auf OK und geben Sie ipconfig ein.

      Hinweise:

      • Der Eintrag "Standardgateway" entspricht normalerweise dem Zugriffspunkt, stellen Sie jedoch sicher, dass er zum Abschnitt "WLAN-Verbindung" in ipconfig gehört.
      • Die IP-Adresse wird in vier Zahlengruppen angezeigt, die durch Punkte voneinander abgetrennt sind. Beispiel: 123.123.123.123.

    2. Drücken Sie die Eingabetaste oder klicken Sie auf Los.

    3. Geben Sie bei Aufforderung den Benutzernamen und das Kennwort für den Zugriffspunkt ein und klicken Sie auf OK.

    4. Suchen Sie im Abschnitt mit den WLAN-Einstellungen den Eintrag "SSID".

    5. Notieren Sie die SSID.

      Hinweis: Stellen Sie sicher, dass Sie die Angaben exakt notieren (einschließlich der Schreibweise).

  2. Erfragen Sie die SSID des Netzwerks, in das der Drucker eingebunden ist:

    1. Drucken Sie eine Netzwerk-Konfigurationsseite auf dem Drucker.

      Weitere Informationen finden Sie im Benutzerhandbuch.

    2. Suchen Sie im Abschnitt "WLAN" nach SSID.

  3. Vergleichen Sie die SSID des Computers mit der SSID des Druckers.

    Wenn die SSIDs übereinstimmen, sind Computer und Drucker mit demselben WLAN verbunden.

    Stimmen die SSIDs nicht überein, führen Sie das Wireless Setup Utility anschließend erneut aus, um den Drucker für das vom Computer verwendete WLAN einzurichten. Die vom Computer verwendete SSID muss ausgewählt werden.

Computer darf nicht an ein virtuelles privates Netzwerk (VPN) angeschlossen sein

Die meisten virtuellen privaten Netzwerke erlauben den Benutzern nur die Kommunikation mit dem VPN und keinem anderen Netzwerk zur selben Zeit. Trennen Sie die Verbindung zum VPN, bevor Sie den Treiber auf dem Computer installieren oder bevor Sie die WLAN-Einrichtung auf dem Computer durchführen.

Prüfen Sie, ob der Computer derzeit mit einem VPN verbunden ist, indem Sie die VPN-Clientsoftware öffnen und die VPN-Verbindungen prüfen. Falls keine VPN-Clientsoftware installiert ist, prüfen Sie die Verbindungen manuell mithilfe des Windows-VPN-Clients.

Wenn gleichzeitig Verbindungen mit dem lokalen Netzwerk und einem VPN hergestellt werden sollen, dann muss der Systemadministrator das VPNs Split-Tunneling aktivieren. Einige Unternehmen erlauben das Split-Tunneling jedoch aufgrund von Sicherheits- oder technischen Überlegungen nicht.

Drucker darf nicht von Drittanbieteranwendungen blockiert werden

Durch Drittanbieteranwendungen wie Antivirusprogramme, Sicherheits- und Firewallprogramme kann die Erkennung des Druckers blockiert werden. Konfigurieren Sie Ihre Anwendungseinstellungen, um die Blockierung des Druckers aufzuheben und aktualisieren Sie die Netzwerkliste.


Auswählen zusätzlicher Software

Folgendes sollte bei der Auswahl zusätzlicher Software beachtet werden:

  • Die ausgewählte Software wird in das generierte Paket aufgenommen und während der Installation auf dem System des Benutzers im angegebenen Verzeichnis installiert.

  • Achten Sie beim Bereitstellen eines nachfolgenden Pakets darauf, denselben Installationspfad zu verwenden, um sicherzustellen, dass nur eine Kopie der installierten Anwendung vorhanden ist und der neuesten Version entspricht.

  • Je nach verwendetem Betriebssystem können einige Dateien im x86-Verzeichnis oder im 64-Bit-System installiert werden.

  • Die Liste der Softwareanwendungen kann abhängig vom Druckermodell variieren.


Starten des generierten Pakets

Führen Sie einen der folgenden Schritte aus:

  • Verwenden Sie die Anmeldeskripts des Betriebssystems.

  • Geben Sie die Pakete frei und lassen Sie sie von den Benutzern aufrufen.

Hinweis: Vergewissern Sie sich, dass Sie über ausreichende Administratorrechte verfügen, um die Installation auszuführen.


Hilfe zum Paket-Builder