Acerca de la ayuda del Generador de paquetes

¿Qué es un Generador de paquetes?


¿Qué es un Generador de paquetes?

El Generador de paquetes le permite crear paquetes de instalación personalizados que puede iniciar sin intervención del usuario, y se integran en su solución de implementación. Es una herramienta que genera paquetes de instalación de controladores que automatizan la instalación de los controladores de la impresora con conectividad preconfigurada y opciones de impresión.


Configuración del paquete de instalación

Notas:

  • Los archivos con los formatos .cab y .exe se generan en la ubicación especificada.
  • El contenido del paquete depende de las opciones que seleccione.
  • Algunas de estas funciones están disponibles únicamente en determinados modelos de impresora.

Selección de los contenidos del paquete

En la sección “Opciones de contenido de paquete”, seleccione una o más de las siguientes:

  • Incluir controladores de impresión o fax

  • Include scan drivers and/or additional software (Incluir controladores de digitalización o software adicional)

  • Support a single language only (Admitir un solo idioma)

    Nota: De forma predeterminada, en el paquete generado se incluyen todos los idiomas que admite el producto. Para reducir el tamaño del paquete, seleccione Compatible con un único idioma y, a continuación, escoja el idioma adecuado.

Selección de las opciones de paquete disponibles durante la instalación

En la sección Opciones del momento de instalación del paquete, realice una de las siguientes acciones:

  • Para ocultar el estado de la instalación, seleccione Silent Installation (Instalación silenciosa).

  • Para mostrar el estado de la instalación con el acuerdo de licencia, seleccione Display installation status to the user (Mostrar estado de la instalación al usuario) y, a continuación, Include the license agreement (Incluir el acuerdo de licencia).

    Nota: El usuario debe aceptar el acuerdo de licencia para instalar el paquete.

  • Para mostrar el estado de la instalación y solicitar al usuario que seleccione un puerto, seleccione Display installation status to the user (Mostrar estado de la instalación al usuario) y, a continuación, seleccione Prompt user for port selection (Solicitar al usuario la selección del puerto).

    Nota: El usuario debe seleccionar el puerto cuando instale el paquete generado.


Configuración del controlador de impresión

Descripción del nombre de la impresora

Uso compartido de la impresora

Identificación de otros controladores disponibles

Descripción del archivo de configuración del controlador

Uso de los valores de configuración


Descripción del nombre de la impresora

De forma predeterminada, el nombre de la impresora es el nombre del modelo de la impresora. También se conoce como el nombre de objeto de impresora creado tras la instalación. Un objeto de impresora representa la impresora real a la que se puede asignar un trabajo de impresión. Asegúrese de que el objeto de impresora disponga de un nombre único para identificar a la impresora correcta en la red.

Notas:

  • Para establecer el objeto de impresora como la impresora predeterminada, seleccione Establecer como impresora predeterminada.
  • Para permitir que la aplicación detecte el nombre de objeto de la impresora durante la instalación, seleccione Detectar nombre de la impresora. Puede que esta opción no esté disponible dependiendo del modelo de impresora que haya adquirido.


Uso compartido de la impresora

Seleccione la casilla de verificación Compartir la impresora y, a continuación, introduzca la siguiente información:

  • Share Name (Nombre compartido): El nombre que ven los demás usuarios cuando apunten a una impresora compartida.

  • Comentarios: Cualquier nota adicional para la impresora compartida. Esto es opcional.

  • Ubicación: Indica la ubicación de la impresora compartida. Esto es opcional.

Nota: Asegúrese de que el uso compartido de archivos y de la impresora están activados.


Identificación de otros controladores disponibles

Los controladores universales de impresión (PCL 5, PCL XL, PS y XPS) se pueden descargar desde nuestro sitio web. Busque el modelo de la impresora para ver los controladores compatibles.


Descripción del archivo de configuración del controlador

El archivo de configuración del controlador (DCF) es un archivo que almacena los valores de la impresora y otros datos que se hayan guardado. Los DCF utilizan la extensión de archivo .ldc.

Cuando utilice el Generador de paquetes, seleccione el DCF que contiene las configuraciones que desea utilizar al crear un objeto de impresora. La configuración individual de un DCF se identifica mediante una descripción.

Un DCF puede contener una configuración para cualquier número de modelos de impresora y de controladores diferentes (emulaciones PostScript o PCL para Windows).

Nota: La Utilidad de configuración del controlador requiere Microsoft XML Core Service (MSXML) 6. Puede descargarlo de www.microsoft.com.


Uso de los valores de configuración

  1. En la sección Ajustes de configuración, seleccione Utilice una configuración para aplicar los ajustes.

    1. Si desea utilizar un archivo de configuración existente, haga clic en Cargar archivo.

    2. Si quiere crear un archivo de configuración nuevo, realice las acciones siguientes:

      1. Haga clic en Nuevo.

      2. Seleccione los datos de configuración que desee crear.

      3. Haga clic en Terminar y, a continuación, guarde los valores.

        4. Nota: Seleccione Aplicar a todas las instalaciones futuras si desea aplicar la misma configuración a todas las creaciones de colas de impresión siguientes. De lo contrario, la configuración solo se aplicará a este objeto de impresora.

  2. Haga clic en Aceptar.


Configuración de la conexión de la impresora

Selección de la impresora desde un puerto detectado

Conexión de la impresora a través de un cable USB

Adición de una impresora en red

Descripción de los tipos de puertos

Inicio manual de la Utilidad de mensajes de estado

Especificación de un puerto mediante la línea de comandos

¿Qué es un nombre de puerto?

¿Por qué la impresora no está en la lista?


Selección de la impresora desde un puerto detectado

  1. Si elige establecer la conexión de la impresora a través de un puerto detectado, obtenga la siguiente información:

    Información de la impresora

    Descripción

    Nombre de dominio completo (en la sección TCP/IP)

    Esto incluye el nombre de la impresora y la red a la que está conectada: También es el nombre de la impresora.

    Dirección IP (en la sección TCP/IP)

    Es un número único que la impresora utiliza para localizar y comunicarse con otros dispositivos de una red.

    UAA (MAC) (en la sección Tarjeta de red estándar)

    Es un número de identificación de hardware único que distingue a la impresora de otros dispositivos de la red.

    Nombre de configuración Zero (en la sección TCP/IP)

    Esto indica que su impresora admite zeroconf o la red de configuración Zero.

    Nota: Si no dispone de la información necesaria, imprima la página de configuración de red. Para obtener más información, consulte la Guía del usuario.

  2. Seleccione la impresora en la lista y, a continuación, haga clic en Continuar.

  3. Si la impresora no se encuentra en la lista, pruebe una o varias de las acciones siguientes:

    • Actualice la lista de impresoras.

    • Haga clic en Modificar búsqueda para añadir su impresora manualmente mediante la configuración de red avanzada.

    • Haga clic en Configuración inalámbrica para añadir una impresora conectada a una red inalámbrica.

    • Haga clic en Especificar puerto para añadir su impresora manualmente mediante los puertos.

    • Asegúrese de que las aplicaciones de terceros no están bloqueando la impresora.

    • Asegúrese de que el equipo no está conectado a una VPN (Virtual Private Network o red privada virtual).

    • Asegúrese de que el equipo y la impresora están conectados a la misma red.

    • Asegúrese de que la impresora disponga de una dirección IP válida y única.


Conexión de la impresora a través de un cable USB

Si seleccionó Conectar con un cable USB, el sistema operativo crea el objeto de impresora de forma predeterminada. El nombre del objeto de impresora debe coincidir con el que genera el sistema operativo.

Notas:

  • Es necesario que el usuario inserte el cable USB para completar la instalación y crear el objeto de impresora.
  • Cuando haya conectado la impresora a través del puerto USB, es necesario que el usuario inicie manualmente la utilidad de mensajes de estado.


Adición de una impresora en red

Utilice el cuadro de diálogo Agregar una impresora de red para buscar impresoras por nombre de impresora, dirección IP o subred. Busque su impresora y, a continuación, añádala de forma manual a la lista de impresoras en red disponibles.

Nota: Asegúrese de que conoce el nombre y la dirección IP de la impresora, y la subred a la que pertenece. Para obtener esta información, imprima una página de configuración de red. Para obtener más información, consulte la Guía del usuario.

Uso del nombre de impresora y la dirección IP

Escriba el nombre o la dirección IP de la impresora y, a continuación, haga clic en Aceptar.

Uso de direcciones de subred

Si la impresora y el servidor de impresión están situados en otra red (llamada subred), busque las impresoras disponibles especificando la subred de la impresora a la que desea acceder.

  • Para añadir una dirección de subred, escriba la dirección de subred en el campo especificado y, a continuación, haga clic en Agregar > Aceptar.

    Nota: También puede buscar varias direcciones de subred.

  • Para eliminar una dirección de subred, resáltela en la lista de subredes detectadas y, a continuación, haga clic en Eliminar.


Descripción de los tipos de puertos

Nota: Es posible que algunos puertos estén disponibles únicamente en determinados modelos de impresora.
Tipos de puerto | Descripción
Servidor de impresión externo | Se trata de un dispositivo externo que permite el acceso a la red mediante sus puertos Ethernet.
LPR (Line Printer Remote) | Es un protocolo utilizado para enviar trabajos de impresión a una impresora remota.
Servidor de impresión | Es un equipo o dispositivo conectado a una o más impresoras, y a equipos cliente en una red. Puede aceptar trabajos de impresión de otros equipos y enviar trabajos de impresión a las impresoras adecuadas.
TCP/IP estándar (Protocolo de control de transmisión/Protocolo de Internet) | Es un protocolo que define la regla que deberán seguir los equipos para comunicarse entre sí a través de Internet.
UNC (Convención de nomenclatura universal) | Es un estándar para la identificación de servidores, impresoras y otros recursos de una red sin asignar la unidad de la red. Proporciona una dirección única a cada recurso compartido. Esto permite que los sistemas operativos compatibles con la UNC especifiquen completamente un directorio en un servidor de archivos.


Inicio manual de la Utilidad de mensajes de estado

Nota: Asegúrese de que la impresora y el equipo están conectados mediante un cable USB.

En Windows 8

Desde el símbolo de búsqueda, introduzca mensajería de estado, y navegue a:

Lista de aplicaciones > Mensajería de estado

En Windows 7 o versiones anteriores

  1. Haga clic en [image] o en Inicio.

  2. Haga clic en Todos los programas o en Programas y, a continuación, seleccione la carpeta del programa de la impresora en la lista.

  3. Haga clic en Inicio de la impresora > Utilidad de mensajería de estado.

Se abrirá la Utilidad de mensajes de estado.

Notas:

  • La Utilidad de mensajes de estado solo está disponible si ha seleccionado incluirla durante la configuración del paquete.
  • Si escoge no iniciar la utilidad de mensajes de estado de forma manual, después de que se cree el objeto de impresión, la utilidad de mensajes de estado se iniciará automáticamente cuando se reinicie el equipo.


Especificación de un puerto mediante la línea de comandos

Puede indicar el nombre y dirección del puerto en la línea de comandos durante la instalación si selecciona Specify the port at install time through the command line (Especificar el puerto durante la instalación mediante la línea de comandos).

Parámetro | Valor | Muestra
/port: | Nombre de puerto | /port:portname
/address: | Nombre de red o dirección IP de la impresora | /address:123.123.123.123 /address:networkname

Línea de comandos de muestra: LexmarkPkgInstall.exe /port:portname /address:123.123.123.123

Notas:

  • LexmarkPkgInstall.exe genera un valor 0 después de que la instalación se realice correctamente.
  • Especifique los parámetros y la dirección del puerto para iniciar correctamente la instalación.
  • El nombre y la dirección del puerto especificados se aplican a todos los objetos de impresión del paquete que vayan a especificarse durante la instalación. Para los objetos de impresora que sean puertos asignados durante la creación del paquete, se reconoce el puerto seleccionado en el momento del empaquetado.
  • Los parámetros de la línea de comandos para el nombre o la dirección del puerto solo se procesan si el paquete se creó para aceptar el nombre y la dirección del puerto en la línea de comandos. Si estos parámetros se transfieren a un paquete que no esté destinado a recibir esta información en la línea de comandos, la instalación se realiza, pero ignora estos parámetros. Los puertos se crean en función de la información del paquete, no de los parámetros de la línea de comandos. Se emite una advertencia al símbolo del sistema. En este caso, el código que se genera es 0, porque la instalación se ha completado con éxito.


¿Qué es un nombre de puerto?

El nombre de puerto es un nombre único asignado a un puerto del equipo al que se conecta la impresora.


¿Por qué la impresora no está en la lista?

Asegúrese de que el equipo y la impresora están conectados a la misma red inalámbrica

La impresora podría no estar en la misma red inalámbrica que el equipo. Si el equipo ya está conectado a la red inalámbrica, el SSID de la impresora debe coincidir con el SSID del equipo.

  1. Obtenga el SSID de la red a la que está conectado el equipo.

    1. Introduzca la dirección IP del punto de acceso (enrutador inalámbrico) en el campo de la dirección del explorador web.

      Si desconoce la dirección IP del punto de acceso, realice las siguientes acciones:

      En Windows 8

      Desde el símbolo de búsqueda, escriba ejecutar, y navegue a:

      Lista de aplicaciones > Ejecutar > introduzca cmd > Aceptar > introduzca ipconfig

      En Windows 7 o versiones anteriores

      1. Haga clic en [image] o en Inicio y, a continuación, en Ejecutar.

      2. En la casilla Iniciar búsqueda o Ejecutar, escriba cmd.

      3. Pulse Entrar o haga clic en Aceptary, a continuación, introduzca ipconfig.

      Notas:

      • La entrada "Puerta de enlace predeterminada" suele ser el punto de acceso, pero asegúrese de que pertenece a la sección "Conexión de red inalámbrica" de la información de ipconfig.
      • La dirección IP aparece como cuatro grupos de números separados por puntos, como 123.123.123.123.

    2. Pulse Entrar o Ir.

    3. Introduzca el nombre de usuario y la contraseña del punto de acceso cuando se le solicite y haga clic en Aceptar.

    4. Busque el SSID en la sección de configuración inalámbrica.

    5. Anote el SSID.

      Nota: Asegúrese de copiarlo exactamente, incluidas las letras mayúsculas.

  2. Obtenga el SSID de la red a la que está conectada la impresora:

    1. Desde la impresora, imprima una página de configuración de red.

      Para obtener más información, consulte la Guía'del usuario.

    2. En la sección Inalámbrico, busque SSID.

  3. Compare el SSID del equipo con el de la impresora.

    Si los SSID coinciden, querrá decir que el equipo y la impresora están conectados a la misma red inalámbrica.

    Si los SSID no coinciden, vuelva a ejecutar la Utilidad de configuración inalámbrica para configurar la impresora en la red inalámbrica utilizada por el equipo. Asegúrese de seleccionar el SSID utilizado por el equipo.

Asegúrese de que el equipo no está conectado a una VPN (Virtual Private Network o red privada virtual)

La mayoría de las VPN permiten a los equipos comunicarse exclusivamente con la VPN (con ninguna otra red al mismo tiempo). Desconéctese de la VPN antes de instalar el controlador en el equipo o antes de ejecutar la configuración inalámbrica en el equipo.

Para comprobar si el equipo se encuentra conectado actualmente a una VPN, abra el software VPN Client y, a continuación, compruebe sus conexiones de VPN. Si no tiene instalado el software VPN Client, compruebe las conexiones manualmente utilizando VPN Client de Windows.

Si desea tener la posibilidad de conectarse a la red local y a la VPN al mismo tiempo, solicite al personal de asistencia técnica de la VPN que active la división de túnel. Tenga presente que algunas empresas no permiten la división de túnel por motivos de seguridad o cuestiones técnicas.

Asegúrese de que las aplicaciones de terceros no están bloqueando la impresora

Las aplicaciones de terceros, entre las que se incluyen los programas antivirus, de seguridad y cortafuegos pueden bloquear la detección de la impresora. Configure los ajustes de la aplicación para desbloquear la impresora y actualice la lista de redes.


Selección de software adicional

Tenga en cuenta los siguientes aspectos cuando seleccione software adicional:

  • El software seleccionado se incluirá en el paquete generado y se instalará en el sistema del usuario en el directorio especificado durante la instalación.

  • Asegúrese de utilizar la misma ruta de instalación cuando implemente un paquete posterior para garantizar que existe solo una copia de la aplicación instalada, y que se trata de la última versión.

  • Algunos archivos pueden estar instalados en el directorio x86 o en el sistema de 64 bits, en función del sistema operativo utilizado.

  • La lista de aplicaciones de software puede variar en función del modelo de impresora.


Inicio del paquete generado

Realice una de las siguientes acciones:

  • Utilice las secuencias de comandos de inicio de sesión del sistema operativo.

  • Comparta los paquetes y haga que los usuarios los invoquen.

Nota: Asegúrese de que dispone de los privilegios de administrador necesarios para llevar a cabo la instalación.


Ayuda del Generador de paquetes