Tietoja Package Builder -ohjelmasta

Mikä on Package Builder?


Mikä on Package Builder?

Voit Package Builderin avulla luoda mukautettuja asennuspaketteja, jotka voit käynnistää ilman käyttäjän toimia ja integroida ne käyttöönottoratkaisuusi. Tämä väline luo ohjaimen asennuspaketteja, jotka automatisoivat tulostinohjainten asennuksen valmiiksi määritetyllä yhteydellä ja tulostusasetuksilla.


Asennuspaketin määrittäminen

Huomautuksia:

  • .cab- ja .exe-muotoiset tiedostot luodaan määritettyyn sijaintiin.
  • Paketin sisältö määräytyy valittujen asetusten mukaan.
  • Jotkin näistä ominaisuuksista ovat käytettävissä vain tietyissä tulostinmalleissa.

Valitse paketin sisältö

Valitse jonkin seuraavista Paketin sisältövalinnat -kohdassa:

  • Lisää tulostin- ja/tai faksiohjaimet

  • Lisää skannausohjaimet ja/tai muita ohjelmistoja

  • Tukee vain yhtä kieltä

    Huomautus: Kaikki tuotteita tukevat kielet sisältyvät oletusarvoisesti luotuun pakettiin. Voit pienentää paketin kokoa valitsemalla Tukee vain yhtä kieltä ja valitsemalla haluamasi kielen.

Valitse asennuksen aikana käytettävissä olevat pakkausvalinnat.

Tee jokin seuraavista ”Paketin asennuksen asetukset” -kohdassa:

  • Piilota asennuksen tila valitsemalla Valvomaton asennus.

  • Jos haluat näyttää asennuksen tilan käyttöoikeussopimuksen kanssa, valitse Näytä asennuksen tila käyttäjälle ja valitse sitten Sisällytä käyttöoikeussopimus.

    Huomautus: Käyttäjän on hyväksyttävä käyttöoikeussopimus, ennen kuin hän voi asentaa paketin.

  • Jos haluat näyttää asennuksen tilan ja kehottaa käyttäjää valitsemaan portin, valitse Näytä asennuksen tila käyttäjälle ja sitten Sisällytä käyttöoikeussopimus.

    Huomautus: Käyttäjän on valittava portti luotua pakettia asentaessaan.


Tulostinohjaimen määrittäminen

Tulostinnimi

Tulostimen jakaminen

Käytettävissä olevien muiden ohjainten määrittäminen

Ohjaimen asetustiedosto

Kokoonpanoasetusten käyttäminen


Tulostinnimi

Oletuksena tulostinnimi on tulostimen mallinimi. Sitä kutsutaan myös tulostinobjektin nimeksi, joka luodaan asennuksen jälkeen. Tulostinobjekti edustaa todellista tulostinta, jolle voidaan määrittää tulostustyö. Varmista, että tulostinobjektilla on yksilöllinen nimi, jotta oikea tulostin voidaan tunnistaa verkossa.

Huomautuksia:

  • Määritä tulostinobjekti oletustulostimeksi valitsemalla Aseta oletustulostimeksi.
  • Jos haluat, että sovellus tunnistaa tulostinobjektisi nimen asennuksen aikana, valitse Tunnista tulostimen nimi. Tämä vaihtoehto ei ehkä ole käytettävissä. Ominaisuudet riippuvat hankitusta tulostinmallista.


Tulostimen jakaminen

Valitse Jaa tulostin -valintaikkuna ja kirjoita sitten seuraavat tiedot:

  • Jakonimi—Nimi, jonka toiset käyttäjät näkevät osoittaessaan jaettua tulostinta.

  • Kommentit—Jaettua tulostinta koskevat kaikki lisähuomautukset. Tämä on valinnainen.

  • Sijainti—Ilmoittaa jaetun tulostimen sijainnin. Tämä on valinnainen.

Huomautus: Varmista, että tiedoston ja tulostuksen jakaminen on kytketty päälle.


Käytettävissä olevien muiden ohjainten määrittäminen

Yleiset tulostinohjaimet (PCL 5, PCL XL, PS ja XPS) voi ladata web-sivustostamme. Saat yhteensopivat ohjaimet näkyviin etsimällä oman tulostinmallisi.


Ohjaimen asetustiedosto

Ohjaimen asetustiedosto (Driver Configuration File (DCF)) sisältää tallennetut tulostinasetukset ja muita tietoja. DCF-tiedoston tunniste on .ldc.

Valitse Package Builderin käytön aikana DCF-tiedosto, jonka sisältämiä asetuksia käyttäen haluat luoda tulostinobjektin. DCF-tiedostojen sisältämät yksittäiset asetukset yksilöidään lyhyen kuvauksen avulla.

DCF-tiedosto voi sisältää yhden asetuksen rajoittamattomalle määrälle eri tulostinmalleja ja ohjaimia (joissa on käytössä joko PostScript- tai PCL-emulointi Windows-käyttöjärjestelmälle).

Huomautus: Tulostinohjelman määritysohjelma edellyttää Microsoft XML Core Services (MSXML) 6 -sovellusta. Voit ladata sen osoitteesta www.microsoft.com.


Kokoonpanoasetusten käyttäminen

  1. Valitse Kokoonpanoasetukset-osassa Ota asetukset käyttöön kokoonpanon avulla.

    1. Jos haluat käyttää olemassa olevaa määritystiedostoa, valitse Lataa tiedosto.

    2. Jos haluat luoda uuden määritystiedoston, toimi seuraavasti:

      1. Valitse Uusi.

      2. Valitse luotavat kokoonpanotiedot.

      3. Valitse Valmis ja tallenna sitten asetukset.

        4. Huomautus: Jos haluat käyttää samaa kokoonpanoa kaikissa myöhemmissä tulostusjonoluonneissa, valitse Käytä kaikissa tulevissa asennuksissa. Muutoin kokoonpano koskee vain tätä tulostinobjektia.

  2. Valitse OK.


Tulostinyhteyden asetusten määrittäminen

Tulostimen valinta havaitusta portista

Tulostimen yhdistäminen USB-kaapelilla

Verkkotulostimen lisääminen

Porttityypit

Tilailmoitusapuohjelman käynnistäminen manuaalisesti

Portin määrittäminen komentorivin avulla

Mikä portin nimi on?

Miksi tulostimeni ei ole luettelossa?


Tulostimen valinta havaitusta portista

  1. Jos päätät muodostaa tulostinyhteyden löydetyn portin kautta, hae seuraavat tiedot:

    Tulostimen tiedot

    Kuvaus

    Toimialueen täydellinen nimi (TCP/IP-osassa)

    Tämä sisältää tulostimen nimen ja sen verkon nimen, johon tulostin on liitetty. Tätä käytetään myös tulostimen nimenä.

    IP-osoite (TCP/IP-osassa)

    Tämä on yksilöllinen numero, jolla tulostin paikallistaa muita verkon laitteita ja on yhteydessä niihin.

    UAA (MAC) (Vakioverkkokortti-osassa)

    Tämä on yksilöllinen laitteistotunniste, jolla tulostin erotetaan muista verkossa olevista laitteista.

    Zero Configuration -nimi (TCP/IP-osassa)

    Tämä ilmaisee, että tulostin tukee zeroconf- eli zero configuration -verkkoyhteyksiä.

    Huomautus: Jos sinulla ei ole vaadittua tietoja, tulosta tulostimen asetussivu. Lisätietoja on käyttöoppaassa.

  2. Valitse tulostin luettelosta ja valitse Jatka.

  3. Jos tulostin ei ole luettelossa, kokeile jotakin seuraavista ratkaisuista:

    • Päivitä tulostinluettelo.

    • Lisää tulostimesi manuaalisesti lisäverkkoasetusten avulla valitsemalla Muokkaa hakua.

    • Jos haluat lisätä langattoman verkon tulostimen, valitse Määritä langaton yhteys.

    • Lisää tulostimesi manuaalisesti portteja käyttämällä valitsemalla Määritä portti.

    • Varmista, että mikään muun valmistajan sovellus ei estä tulostinta.

    • Varmista, että tietokonetta ei ole yhdistetty virtuaaliseen erillisverkkoon (VPN, Virtual Private Network).

    • Tarkista, että tietokone ja tulostin on yhdistetty samaan verkkoon.

    • Varmista, että tulostimelle on määritetty kelvollinen, yksilöllinen IP-osoite.


Tulostimen yhdistäminen USB-kaapelilla

Jos valitset Yhdistä USB-kaapelilla, käyttöjärjestelmä luo oletustulostinobjektin. Tulostinobjektin nimen on vastattava käyttöjärjestelmän luoman objektin nimeä.

Huomautuksia:

  • Käyttäjän on liiettävä USB-kaapeli asennuksen viimeistelemiseksi ja luotava tulostinobjekti.
  • Kun olet yhdistänyt tulostimen käyttämällä USB-porttia, sinun on käynnistettävä tilailmoitus manuaalisesti.


Verkkotulostimen lisääminen

Verkkotulostimen lisääminen -valintaikkunassa voit etsiä tulostimia tulostimen nimen IP-osoitteen tai aliverkon mukaan. Etsi tulostimesi ja lisää se sitten käytettävissä olevien verkkotulostimien luetteloon manuaalisesti.

Huomautus: Varmista, että tiedät tulostimen nimen ja IP-osoitteen sekä sen aliverkon, johon se kuuluu. Saat nämä tiedot tulostamalla verkkoasetussivun. Lisätietoja on käyttöoppaassa.

Tulostimen nimen ja IP-osoitteen käyttäminen

Kirjoita tulostimen nimi tai IP-osoite ja valitse sitten OK.

Aliverkon osoitteen käyttäminen

Jos tulostin ja tulostuspalvelin sijaitsevat toisessa verkossa (josta käytetään nimitystä aliverkko), etsi käytettävissä olevat tulostimet määrittämällä sen tulostimen aliverkko, jota haluat käyttää.

  • Voit lisätä aliverkon osoitteen kirjoittamalla aliverkon osoitteen sille tarkoitettuun kenttään ja valitsemalla sitten Lisää > OK.

    Huomautus: Voit etsiä myös useita aliverkon osoitteita.

  • Voit poistaa aliverkon osoitteen valitsemalla aliverkon osoitteen löydettyjen aliverkkojen luettelosta ja valitsemalla sitten Poista.


Porttityypit

Huomautus: Jotkin portit voivat olla käytettävissä vain tietyissä tulostinmalleissa.
Porttityypit | Kuvaus
Ulkoinen tulostuspalvelin | Tämä on ulkoinen laite, joka mahdollistaa verkon käytön Ethernet-porttien kautta.
LPR (Line Printer Remote) | Tämä on protokolla, jonka avulla tulostustyöt lähetetään etätulostimeen.
Tulostuspalvelin | Tämä on tietokone tai laite, joka on yhdistetty vähintään yhteen tulostimeen ja asiakastietokoneisiin verkossa. Se voi vastaanottaa tulostustöitä tietokoneista ja lähettää töitä soveltuviin tulostimiin.
TCP/IP-vakioportti (Transmission Control Protocol/Internet Protocol) | Tämä protokolla määrittää säännöt, joita tietokoneiden on noudatettava kommunikoidessaan toistensa kanssa Internetin kautta.
UNC (Universal Naming Convention) | Tämä on standardi, jonka avulla verkon palvelimet, tulostimet ja muut resurssit tunnistetaan ilman verkkoaseman määrittämistä. Se määrittää kullekin jaetulle resurssille yksilöllisen osoitteen. Siten UNC:tä tukevat käyttöjärjestelmät voivat määrittää tiedostopalvelimen hakemiston täydellisesti.


Tilailmoitusapuohjelman käynnistäminen manuaalisesti

Huomautus: Tarkista, että tulostin ja tietokone on liitetty USB-kaapelilla.

Windows 8

Kirjoita Etsi-riipuspalkkiin tilailmoitus ja siirry sitten kohtaan:

Sovellusluettelo > Tilailmoitus.

Windows 7:ssä tai vanhemmissa:

  1. Valitse [image] tai Käynnistä.

  2. Valitse Kaikki ohjelmat tai Ohjelmat ja valitse sitten luettelosta tulostinohjelman kansio.

  3. Valitse Tulostimen etusivu > Tilailmoitus.

Tilailmoitusapuohjelma avautuu.

Huomautuksia:

  • Tilailmoitusapuohjelma on käytettävissä ainoastaan siinä tapauksessa, että olet valinnut sen sisällyttämisen kokoonpanon määrittämisen yhteydessä.
  • Jos et käynnistä Tilailmoitusapuohjelmaa manuaalisesti tulostusobjektin luomisen jälkeen, se käynnistetään automaattisesti, kun tietokone käynnistetään uudelleen.


Portin määrittäminen komentorivin avulla

Voit ilmoittaa portin nimen ja portin osoitteen komentorivillä asennuksen aikana valitsemalla Portin määrittäminen asennuksen aikana komentorivin avulla.

Parametri | laskurin arvo | Näyte
/portti: | Portin nimi | /portti:portinnimi
/osoite: | Verkon nimi tai tulostimen IP-osoite | /osoite:123.123.123.123 /osoite:verkonnimi

Näytekomentorivi: LexmarkPkgInstall.exe /portti:portinnimi /osoite:123.123.123.123

Huomautuksia:

  • LexmarkPkgInstall.exe palauttaa 0, kun asennus onnistui.
  • Määritä portti ja osoiteparametrit asennuksen käynnistymisen varmistamiseksi.
  • Määritettyä portin nimeä ja osoitetta sovelletaan paketin kaikkiin tulostinobjekteihin, jotka määritetään asennuksen aikana. Niille tulostinobjekteille, joille kohdistetaan portit paketin luomisen aikana, määritetään asennuksen aikana valittu portti.
  • Portin nimen tai osoitteen komentorivin parametrit käsitellään vain, jos paketti luotiin siten, että se hyväksyy portin nimen ja osoitteen komentorivillä. Jos nämä parametrit lisätään pakettiin, jonka ei ole tarkoitus saada näitä tietoja komentorivillä, asennus jatkuu mutta sivuuttaa nämä parametrit. Portit luodaan paketin tietojen eikä komentorivin parametrien perusteella. Komentoriviin annetaan varoitus. Tässä tapauksessa palautuskoodi on 0, koska asennus onnistui.


Mikä portin nimi on?

Portin nimi on yksilöllinen nimi, joka annetaan sille tietokoneen portille, johon tulostin on liitetty.


Miksi tulostimeni ei ole luettelossa?

Tarkista, että tietokone ja tulostin on yhdistetty samaan langattomaan verkkoon.

Tulostin ei ehkä ole samassa langattomassa verkossa kuin tietokone. Jos tietokone on jo yhdistetty langattomaan verkkoon, tulostimen SSID-tunnuksen on oltava sama kuin tietokoneen SSID-tunnus.

  1. Hanki sen verkon SSID, johon tietokone on yhdistetty.

    1. Kirjoita tukiaseman (langattoman reitittimen) IP-osoite web-selaimen osoitekenttään.

      Jos et tiedä tukiaseman IP-osoitetta, tee seuraava toimenpide:

      Windows 8

      Kirjoita Etsi-riipuspalkkiin suorita ja siirry sitten kohtaan:

      Sovellusluettelo > Suorita > kirjoita cmd > OK > kirjoita ipconfig.

      Windows 7:ssä tai vanhemmissa:

      1. Valitse [image] tai valitse Käynnistä ja Suorita.

      2. Kirjoita Aloita haku- tai Suorita-kenttään cmd.

      3. Paina Enter-painiketta tai valitse OK ja kirjoita sitten ipconfig.

      Huomautuksia:

      • Oletusyhdyskäytävä-merkintä on tyypillisesti tukiasema, mutta tarkista, että se kuuluu ipconfig-tietojen Langaton verkkoyhteys -osaan.
      • IP-osoite on neljä pisteillä erotettua numerosarjaa, kuten 123.123.123.123.

    2. Paina Enter-painiketta tai valitse Siirry.

    3. Kirjoita pyydettäessä tukiaseman käyttäjätunnus ja salasana ja valitse sitten OK.

    4. Etsi Langattomat asetukset -osasta kohta SSID.

    5. Kirjoita SSID muistiin.

      Huomautus: Kirjoita se tarkasti oikein isot kirjaimet mukaan lukien.

  2. Hanki sen verkon SSID, johon tulostin on yhdistetty:

    1. Tulosta verkkoasetussivu tulostimesta.

      Lisätietoja on käyttöoppaassa.

    2. Etsi Langattomat-osiosta kohta SSID.

  3. Vertaa tulostimen ja tietokoneen SSID-tunnusta toisiinsa.

    Jos SSID-tunnukset ovat samat, tietokone ja tulostin on yhdistetty samaan langattomaan verkkoon.

    Jos SSID-tunnukset eivät ole samat, asenna tulostin tietokoneen käyttämään langattomaan verkkoon suorittamalla Langattomat verkkoasetukset -apuohjelma uudelleen. Tarkista, että olet valinnut tietokoneen käyttämän SSID-tunnuksen.

Varmista, että tietokonetta ei ole yhdistetty virtuaaliseen erillisverkkoon (VPN, Virtual Private Network).

Useimmat VPN-verkot sallivat tietokoneen tietoliikenteen vain VPN-verkkoon ja estävät muiden verkkojen käytön samanaikaisesti. Irrota tietokone VPN-verkosta ennen ohjaimen asentamista tietokoneeseen tai ennen langattomien asetusten tekemistä tietokoneessa.

Voit tarkistaa, onko tietokone yhdistetty VPN-verkkoon, avaamalla VPN-asiakasohjelmiston ja tarkistamalla VPN-yhteydet. Jos tietokoneeseen ei ole asennettu VPN-asiakasohjelmistoa, tarkista yhteydet manuaalisesti Windowsin VPN-asiakasohjelman avulla.

Jos haluat kyetä muodostamaan yhteyden lähiverkkoon ja VPN-verkkoon samanaikaisesti, VPN-verkon järjestelmätuen pitää sallia jaettu tunnelointi. Huomaa, että joissakin järjestöissä jaettua tunnelointia ei sallita tietoturvasyistä tai teknisistä syistä.

Varmista, että mikään muun valmistajan sovellus ei estä tulostinta.

Muiden valmistajien sovellukset, kuten virustorjunta-, tietoturva- ja palomuuriohjelmat voivat estää tulostimen löytämisen. Poista tulostimen esto määrittämällä sovelluksen asetukset ja päivitä verkkoluettelo.


Lisäohjelmiston valitseminen

Ota huomioon seuraavat seikat, kun valitset lisäohjelmistoa:

  • Valittu ohjelmisto sisältyy luotuun pakettiin ja se asennetaan käyttäjän järjestelmään asennuksen aikana määritettyyn hakemistoon.

  • Varmista, että käytät myöhemmän paketin käyttöönotossa samaa asennuspolkua, jotta asennetusta sovelluksesta on vain yksi kopio ja se on uusin versio.

  • Jotkut tiedostot voidaan asentaa joko x86-hakemistoon tai 64-bittiseen järjestelmään käytetyn käyttöjärjestelmän mukaan.

  • Ohjelmistosovellusten luettelo voi vaihdella tulostinmallin mukaan.


Luodun paketin käynnistäminen

Valitse jompikumpi seuraavista:

  • Käytä käyttöjärjestelmän kirjautumiskomentoja.

  • Jaa paketit ja anna käyttäjien avata ne.

Huomautus: Varmista, että sinulla on tarvittavat järjestelmänhallinnan oikeudet asennuksen suorittamiseksi.


Package Builderin ohje