A propos de l'Aide du Créateur de package

Qu'est-ce qu'un Créateur de package ?


Qu'est-ce qu'un Créateur de package ?

Un Créateur de package vous permet de créer des packages d'installation personnalisés que vous pouvez lancer sans intervention de l'utilisateur et intégrer dans vos solutions de développement. Cet outil crée des packages d'installation de pilote qui automatisent l'installation des pilotes d'imprimante avec connectivité et options d'impression préconfigurées.


Configuration du package d'installation

Remarques :

  • Les fichiers aux formats .cab et .exe sont créés dans l'emplacement spécifié.
  • Le contenu du package dépend des options sélectionnées.
  • Certaines de ces fonctionnalités ne sont disponibles que sur certains modèles d'imprimante.

Sélectionner le contenu du package

Dans la section « Options de contenu du package », sélectionnez une ou plusieurs des options suivantes :

  • Pilotes d'imprimante et/ou de télécopie compris

  • Pilotes de numérisation et/ou autres logiciels compris

  • Prise en charge d'une seule langue uniquement

    Remarque : Par défaut, toutes les langues prises en charge par le produit sont comprises dans le package créé. Pour réduire la taille du package, sélectionnez Prise en charge d'une seule langue uniquement, puis la langue souhaitée.

Sélectionner les options de package disponibles au cours de l'installation.

Dans la section « Options au moment de l'installation du package », exécutez une des actions suivantes :

  • Pour masquer l'état d'installation, sélectionnez Installation silencieuse.

  • Pour afficher l'état de l'installation et le contrat de licence, sélectionnez Afficher l'état d'installation pour l'utilisateur, puis sélectionnez Inclure le contrat de licence.

    Remarque : L'utilisateur doit accepter le contrat de licence pour installer le package.

  • Pour afficher l'état de l'installation et demander à l'utilisateur de sélectionner un port, sélectionnez Afficher l'état d'installation pour l'utilisateur, puis sélectionnez Demander à l'utilisateur de sélectionner le port.

    Remarque : L'utilisateur doit sélectionner le port lorsqu'il installe le package créé.


Configuration du pilote d'impression

Présentation du nom d'imprimante

Partage de l'imprimante

Identification d'autres pilotes disponibles

Présentation du fichier de configuration de pilote

Utilisation des paramètres de configuration


Présentation du nom d'imprimante

Par défaut, le nom d'imprimante est le nom de modèle de votre imprimante. Il s'agit parfois du nom d'objet d'imprimante créé après l'installation. Un objet d'imprimante représente l'imprimante à laquelle un travail d’impression peut être affecté. Vérifiez que votre objet d'imprimante possède un nom unique identifiant l'imprimante correcte sur le réseau.

Remarques :

  • Pour définir l'objet d'imprimante comme imprimante par défaut, sélectionnez Définir en tant qu'imprimante par défaut.
  • Pour laisser l'application détecter le nom d'objet de votre imprimante pendant l'installation, sélectionner Détecter le nom de l'imprimante. La disponibilité de cette option varie selon le modèle d'imprimante acheté.


Partage de l'imprimante

Activez la case à cocher Partager l'imprimante, puis entrez les informations suivantes :

  • Nom de partage : le nom qui apparaît aux autres utilisateurs lorsque ceux-ci pointent sur une imprimante partagée.

  • Commentaires : toute remarque complémentaire au sujet de l'imprimante partagée. Ceci est facultatif.

  • Emplacement : indique l'emplacement de l'imprimante partagée. Ceci est facultatif.

Remarque : Assurez-vous que le partage des fichiers et des imprimantes est activé.


Identification d'autres pilotes disponibles

Les pilotes d'impression universels (PCL 5, PCL XL, PS et XPS) peuvent être téléchargés sur notre site Web. Recherchez votre modèle d'imprimante pour afficher les pilotes compatibles.


Présentation du fichier de configuration de pilote

Un fichier de configuration du pilote (DCF) est un fichier stockant les paramètres de l'imprimante et d'autres données. Les fichiers DCF portent l'extension .ldc.

Lorsque vous utilisez le Créateur de package, sélectionnez le fichier DCF contenant les configurations à utiliser pour créer un objet d'imprimante. La configuration individuelle d'un fichier DCF est identifiée par une description.

Un fichier DCF peut contenir une configuration pour un nombre quelconque de modèles d’imprimantes et de pilotes différents (émulations PostScript ou PCL pour Windows).

Remarque : L'Utilitaire de configuration du pilote nécessite Microsoft XML Core Services (MSXML) 6. Vous pouvez le télécharger sur www.microsoft.com.


Utilisation des paramètres de configuration

  1. Dans la section Paramètres de configuration, sélectionnez Utiliser une configuration pour appliquer les paramètres.

    1. Si vous souhaitez utiliser un fichier de configuration existant, cliquez sur Charger un fichier.

    2. Si vous souhaitez créer un nouveau fichier de configuration, procédez comme suit :

      1. Cliquez sur Nouveau.

      2. Sélectionnez les données de configuration que vous souhaitez créer.

      3. Cliquez sur Terminer, puis enregistrez les paramètres.

        4. Remarque : Si vous souhaitez appliquer la même configuration à toutes les créations de file d'attente d'impression futures, sélectionnez Appliquer à toutes les installations futures. Sinon, la configuration ne s'applique qu'à cet objet d'imprimante.

  2. Cliquez sur OK.


Configuration de la connexion de l'imprimante

Sélection de l'imprimante à partir d'un port détecté

Connexion de l'imprimante à l'aide d'un câble USB

Ajout d'une imprimante réseau

Présentation des types de ports

Lancement manuel de l'Indicateur d'état

Spécification d'un port à partir de la ligne de commande

Qu'est-ce qu'un nom de port ?

Pourquoi mon imprimante ne figure pas dans la liste ?


Sélection de l'imprimante à partir d'un port détecté

  1. Si vous décidez d'établir la connexion à l'imprimante par l'intermédiaire d'un port détecté, veillez à obtenir les informations suivantes :

    Infos imprimante

    Description

    Nom de domaine complet (dans la section TCP/IP)

    Comprend le nom de l'imprimante et du réseau auquel elle est connectée. Indique également le nom de l'imprimante.

    Adresse IP (dans la section TCP/IP).

    Numéro unique utilisé par votre imprimante pour localiser d'autres périphériques sur un réseau et communiquer avec eux.

    UAA (MAC) (dans la section Carte réseau standard)

    Numéro d'identification matériel unique qui permet de distinguer l'imprimante des autres périphériques du réseau.

    Nom de configuration zéro (dans la section TCP/IP).

    Indique que votre imprimante prend en charge zeroconf ou le réseau de configuration zéro.

    Remarque : Si vous ne disposez pas des informations requises, imprimez une page de configuration réseau. Pour plus d'informations, reportez-vous au Guide de l'utilisateur.

  2. Sélectionnez l'imprimante dans la liste, puis cliquez sur Continuer.

  3. Si votre imprimante ne figure pas dans la liste, essayez une ou plusieurs des solutions suivantes :

    • Actualisez la liste des imprimantes.

    • Cliquez sur Modifier la recherche pour ajouter manuellement votre imprimante à l'aide des paramètres réseau avancés.

    • Cliquez sur Configuration de la connexion sans fil pour ajouter une imprimante connectée à un réseau sans fil.

    • Cliquez sur Spécifier un port pour ajouter manuellement votre imprimante à l'aide des ports.

    • Vérifiez que des applications tierces ne bloquent pas l'imprimante.

    • Assurez-vous que l'ordinateur n'est pas connecté à un réseau VPN (Virtual Private Network).

    • Vérifiez que votre ordinateur et votre imprimante sont connectés au même réseau.

    • Vérifiez qu'une adresse IP unique et valide est attribuée à l'imprimante.


Connexion de l'imprimante à l'aide d'un câble USB

Si vous sélectionnez Connecter à l'aide d'un câble USB, le système d'exploitation crée un objet d'imprimante par défaut. Le nom de l'objet d'imprimante doit correspondre à celui qui a été créé par le système d'exploitation.

Remarques :

  • L'utilisateur doit insérer le câble USB pour terminer l'installation et créer l'objet d'imprimante.
  • Une fois l'imprimante connectée par l'intermédiaire du port USB, l'utilisateur doit lancer manuellement l'Indicateur d'état.


Ajout d'une imprimante réseau

Utilisez la boîte de dialogue Ajout d'une imprimante réseau pour rechercher des imprimantes par leur nom, leur adresse IP ou leur sous-réseau. Recherchez votre imprimante, puis ajoutez-la manuellement à la liste des imprimantes réseau disponibles.

Remarque : Vérifiez que vous connaissez le nom et l'adresse IP de l'imprimante, ainsi que le sous-réseau auquel elle appartient. Pour obtenir ces informations, imprimez une page de configuration réseau. Pour plus d'informations, reportez-vous au Guide de l'utilisateur.

Utilisation du nom et de l'adresse IP de l'imprimante

Tapez le nom ou l'adresse IP de l'imprimante, puis cliquez sur OK.

Utilisation de l'adresse du sous-réseau

Si l’imprimante et le serveur d’impression sont situés sur un autre réseau (appelé sous-réseau), recherchez les imprimantes disponibles en spécifiant le sous-réseau de l'imprimante à laquelle vous souhaitez accéder.

  • Pour ajouter une adresse de sous-réseau, saisissez-la dans le champ spécifié, puis cliquez sur Ajouter > OK.

    Remarque : Vous pouvez également rechercher plusieurs adresses de sous-réseau.

  • Pour supprimer une adresse de sous-réseau de la liste, mettez-la en surbrillance dans la liste des sous-réseaux détectés, puis cliquez sur Supprimer.


Présentation des types de ports

Remarque : Il se peut que certains ports ne soient disponibles que sur certains modèles d'imprimante.
Types de ports | Description
Serveur d'impression externe | Il s'agit d'un périphérique externe qui permet d'accéder au réseau via ses ports Ethernet.
LPR (Line Printer Remote) | Protocole utilisé pour l'envoi de travaux d'impression à une imprimante distante.
Serveur d'impression | Ordinateur ou périphérique connecté à une ou plusieurs imprimantes, ainsi qu'à des ordinateurs clients sur un réseau. Il peut accepter les travaux d'impression provenant d'ordinateurs et envoyer des travaux aux imprimantes appropriées.
TCP/IP (Transmission Control Protocol/Internet Protocol) standard | Protocole définissant les règles que les ordinateurs doivent respecter pour communiquer entre eux sur Internet.
UNC (Universal Naming Convention) | Norme pour l'identification des serveurs, imprimantes et autres ressources sur un réseau, sans mappage au lecteur réseau. Attribue une adresse unique à chaque ressource partagée. Cela permet aux systèmes d'exploitation prenant en charge UNC de spécifier intégralement un répertoire d'un serveur de fichiers.


Lancement manuel de l'Indicateur d'état

Remarque : Vérifiez que l'imprimante est reliée à l'ordinateur à l'aide d'un câble USB.

Sous Windows 8

Sous Rechercher, tapez indicateur d'état, puis naviguez jusqu'à :

Liste des applications > Indicateur d'état

Sous Windows 7 ou une version antérieure

  1. Cliquez sur [image] ou Démarrer.

  2. Cliquez sur Tous les programmes ou sur Programmes, puis sélectionnez le dossier du programme d'imprimante dans la liste.

  3. Cliquez sur Accueil de l'imprimante > Indicateur d'état.

L'Indicateur d'état s'ouvre.

Remarques :

  • L'Indicateur d'état n'est disponible que si vous avez décidé de l'inclure au cours de la configuration du package.
  • Si vous décidez de ne pas lancer manuellement l'Indicateur d'état, il est automatiquement lancé une fois que l'ordinateur redémarre, après création de l'objet d'impression.


Spécification d'un port à partir de la ligne de commande

Vous pouvez indiquer le nom du port et son adresse à partir de la ligne de commande au cours de l'installation, en sélectionnant Spécifier le port au moment de l'installation par l'intermédiaire de la ligne de commande.

Paramètre | Valeur | Exemple
/port: | Nom de port | /port:portname
/address: | Nom réseau ou adresse IP de l'imprimante | /address:123.123.123.123 /address:networkname

Exemple de ligne de commande : LexmarkPkgInstall.exe /port:portname /address:123.123.123.123

Remarques :

  • LexmarkPkgInstall.exe retourne 0 en cas d'installation réussie.
  • Spécifiez les paramètres de port et d'adresse pour réussir le démarrage de l'installation.
  • Le nom de port et l'adresse spécifiés sont appliqués à tous les objets d'impression du package qui sont configurés pour être spécifiés au cours de l'installation. Dans le cas des objets d'imprimante auxquels des ports sont affectés au cours de la création du package, le port sélectionné au cours du temps de packaging est honoré.
  • Les paramètres de ligne de commande relatifs au nom de port et à l'adresse ne sont traités que si le package a été créé en vue d'accepter le nom de port et l'adresse à partir de la ligne de commande. Si ces paramètres sont transmis à un package qui n'est pas destiné à recevoir ces informations à partir de la ligne de commande, l'installation se poursuit en ignorant ces paramètres. Les ports sont créés à partir des informations contenues dans le package et non à partir des paramètres de la ligne de commande. Un avertissement s'affiche dans l'invite de commande. Dans ce cas, le code de retour est 0, puisque l'installation s'est déroulée correctement.


Qu'est-ce qu'un nom de port ?

Le nom de port est un nom unique attribué à un port de l'ordinateur auquel l'imprimante est connectée.


Pourquoi mon imprimante ne figure pas dans la liste ?

Vérifiez que l'ordinateur et l'imprimante sont connectés au même réseau sans fil

Il se peut que l'imprimante ne fasse pas partie du même réseau sans fil que l'ordinateur. Si l'ordinateur est déjà connecté à un réseau sans fil, le SSID de l'imprimante doit correspondre à celui de l'ordinateur.

  1. Obtenez le SSID du réseau auquel l'ordinateur est connecté.

    1. Entrez l'adresse IP de votre point d'accès (routeur sans fil) dans le champ d'adresse de votre navigateur.

      Si vous ne connaissez pas l'adresse IP du point d'accès, procédez comme suit :

      Sous Windows 8

      Sous Rechercher, tapez exécuter, puis naviguez jusqu'à :

      Liste des applications > Exécuter > tapez cmd > OK > tapez ipconfig

      Sous Windows 7 ou une version antérieure

      1. Cliquez sur [image] ou sur Démarrer, puis sur Exécuter.

      2. Dans la zone Lancer la recherche ou Exécuter, tapez cmd.

      3. Appuyez sur Entrée ou cliquez sur OK, puis tapez ipconfig.

      Remarques :

      • L'entrée "Passerelle par défaut" est généralement le point d'accès, mais vérifiez qu'elle appartient à la section "Connexion réseau sans fil" des informations ipconfig.
      • L'adresse IP apparaît sous la forme de quatre séries de chiffres séparées par des points, par exemple 123.123.123.123.

    2. Appuyez sur Entrée ou sur Aller.

    3. Tapez le nom d'utilisateur et le mot de passe du point d'accès lorsque vous y êtes invité, puis cliquez sur OK.

    4. Dans la section Paramètres sans fil, recherchez SSID.

    5. Notez le SSID.

      Remarque : veillez à bien le copier, en respectant les majuscules.

  2. Identifiez le SSID du réseau auquel l'imprimante est connectée :

    1. A partir de l'imprimante, imprimez une page de configuration réseau.

      Pour plus d'informations, reportez-vous au Guide de l'utilisateur.

    2. Dans la section Sans fil, recherchez le SSID.

  3. Comparez le SSID de l'ordinateur avec celui de l'imprimante.

    S'ils sont identiques, l'ordinateur et l'imprimante sont connectés au même réseau sans fil.

    En revanche, s'ils sont différents, exécutez l'utilitaire de configuration sans fil à nouveau pour configurer l'imprimante sur le réseau sans fil utilisé par l'ordinateur. Assurez-vous de sélectionner le SSID utilisé par l'ordinateur.

Assurez-vous que l'ordinateur n'est pas connecté à un réseau VPN (Virtual Private Network)

La plupart des réseaux VPN ne permettent pas aux ordinateurs qui s'y connectent de communiquer en même temps sur un autre réseau. Déconnectez-vous du réseau VPN avant d'installer le pilote ou d'effectuer la configuration sans fil sur l'ordinateur.

Pour vérifier si l'ordinateur est connecté à un réseau VPN, ouvrez votre logiciel client VPN, puis vérifiez vos connexions VPN. Si vous n'avez pas de logiciel client VPN sur votre ordinateur, vérifiez les connexions manuellement à l'aide du client VPN Windows.

Si vous souhaitez avoir la possibilité de vous connecter simultanément à votre réseau local et à un réseau VPN, demandez au responsable du support système d'autoriser le service à tunnels multiples. Sachez que certaines organisations n'autorisent pas ce service pour des raisons de sécurité ou techniques.

Vérifiez que des applications tierces ne bloquent pas l'imprimante

Les applications tierces, notamment les antivirus, les programmes de sécurité et les pare-feu peuvent bloquer la détection de l'imprimante. Configurez les paramètres de l'application pour ne pas bloquer l'imprimante, puis actualisez la liste des réseaux.


Sélection de logiciels supplémentaires

Tenez compte des éléments suivants lorsque vous sélectionnez des logiciels supplémentaires :

  • Le logiciel sélectionné sera compris dans le package créé et il sera installé sur le système de l'utilisateur, dans le répertoire spécifié au cours de l'installation.

  • Veillez à utiliser le même chemin d'installation lors du déploiement d'un package ultérieur afin qu'une seule copie de l'application soit installée et qu'il s'agisse bien de la version la plus récente.

  • Certains fichiers peuvent être installés dans le répertoire x86 ou sur le système 64 bits, en fonction du système d'exploitation utilisé.

  • La liste des applications peut varier selon le modèle d'imprimante.


Lancement du package créé

Effectuez l'une des opérations suivantes :

  • Utilisez les scripts de connexion du système d'exploitation.

  • Partagez les packages en veillant à ce qu'ils soient appelés par les utilisateurs.

Remarque : Veillez à disposer de droits d'administrateur suffisants pour effectuer l’installation.


Aide du Créateur de package