Informazioni sulla Guida di Package Builder

Informazioni su Package Builder


Informazioni su Package Builder

Package Builder consente di creare pacchetti di installazione personalizzati che possono essere avviati senza l´intervento dell´utente e si integrano nella soluzione di distribuzione. Questo è uno strumento che genera pacchetti di installazione di driver che automatizzano l´installazione di driver per stampante con opzioni di connettività e di stampa preconfigurate.


Configurazione del pacchetto di installazione

Note:

  • I file nei formati .cab e .exe sono generati nella posizione specificata.
  • Il contenuto del pacchetto dipende dalle opzioni selezionate.
  • Alcune di queste funzioni sono disponibili solo in modelli di stampante selezionati.

Selezionare del contenuto del pacchetto

Dalla sezione "Opzioni contenuto pacchetto", selezionare una o più delle seguenti opzioni:

  • Includi driver di stampa e/o fax

  • Includi driver scanner e/o software aggiuntivo

  • Supporta solo un'unica lingua

    Nota: per impostazione predefinita, nel pacchetto generato sono incluse tutte le lingue supportate dal prodotto. Per ridurre le dimensioni del pacchetto, selezionare Supporta solo un'unica lingua e selezionare la lingua appropriata.

Selezione delle opzioni del pacchetto disponibili durante l´installazione

Dalla sezione "Opzioni per installazione pacchetto", effettuare una delle seguenti operazioni:

  • Per nascondere lo stato di installazione, selezionare Installazione invisibile all'utente.

  • Per mostrare lo stato di installazione con il contratto di licenza, selezionare Visualizza lo stato di installazione all´utente, quindi selezionare Includi contratto di licenza.

    Nota: Per installare il pacchetto, l´utente deve accettare il contratto di licenza.

  • Per mostrare lo stato di installazione e richiedere all´utente di selezionare la porta, selezionare Visualizza lo stato di installazione all´utente, quindi selezionare Richiedi all´utente di selezionare la porta.

    Nota: Durante l´installazione del pacchetto generato, l´utente deve selezionare la porta.


Configurazione del driver di stampa

Informazioni sul nome della stampante

Condivisione della stampante

Identificazione degli altri driver disponibili

Informazioni sul file di configurazione dei driver

Usando Impostazioni di configurazione


Informazioni sul nome della stampante

Per impostazione predefinita, il nome della stampante è il nome del modello della stampante. Questo è anche definito come il nome dell´oggetto stampante creato dopo l´installazione. Un oggetto stampante rappresenta la stampante attuale a cui è possibile assengnare un processo di stampa. Assicurarsi che l´oggetto stampante sia un nome univoco che identifichi la stampante corretta in rete.

Note:

  • Per selezionare l´oggetto stampante come stampante predefinita, selezionare Imposta come stampante predefinita.
  • Per consentire il rilevamento del nome dell´oggetto stampante durante l´installazione, selezionare Rileva nome stampante. Questa opzione potrebbe non essere disponibile nel modello di stampante acquistato.


Condivisione della stampante

Selezionare la casella di controllo Condividi stampante, quindi immettere le seguenti informazioni:

  • Nome condivisione: il nome visualizzato agli altri utenti che selezionano una stampante condivisa.

  • Commenti: eventuali informazioni aggiuntive per la stampante condivisa. Questo è facoltativo.

  • Posizione: indica la posizione della stampante condivisa. Questo è facoltativo.

Nota: accertarsi che la condivisione di file e stampanti sia abilitata.


Identificazione degli altri driver disponibili

È possibile scaricare i driver di stampa universali (PCL 5, PCL XL, PS e XPS) dal nostro sito Web. Cercare il modello della stampante per visualizzare i driver compatibili.


Informazioni sul file di configurazione dei driver

Il file DCF (Driver Configuration File) contiene le impostazioni della stampante memorizzate e altri dati. DCF usa l´estensione di file .ldc.

Quando si utilizza Package Builder, selezionare il file DCF contenente le configurazioni da utilizzare per creare gli oggetti stampante. La singola configurazione del file DCF è contraddistinta da una descrizione.

Un file DCF può contenere una configurazione per qualsiasi modello di stampante e driver diversi (emulazioni PostScript o PCL per Windows).

Nota: L´utility Driver Configuration richiede Microsoft XML Core Services (MSXML) 6, disponibile all´indirizzo www.microsoft.com.


Usando Impostazioni di configurazione

  1. Nella sezione Impostazioni di configurazione, selezionare Usa una configurazione per applicare impostazioni.

    1. Se si desidera usare un file di configurazione esistente, fare clic su Carica file.

    2. Per creare un nuovo file di configurazione, effettuare le seguenti operazioni:

      1. Fare clic su Nuovo.

      2. Selezionare i dati di configurazione da creare.

      3. Fare clic su Fine, quindi salvare le impostazioni.

        4. Nota: selezionare Applica a tutte le installazioni successive se si desidera applicare la medesima configurazione alla creazione di tutte le successive code di stampa. In caso contrario la configurazione verrà applicata solo per questo oggetto stampante.

  2. Fare clic su OK.


Configurazione della connessione della stampante

Selezione della stampante da una porta rilevata

Connessione della stampante utilizzando un cavo USB

Aggiunta di una stampante di rete

Informazioni sui tipi di porta

Avvio manuale di Messenger di stato

Specifica di una porta dalla riga di comando

Che cosa è il nome della porta?

Perché la stampante non è in elenco?


Selezione della stampante da una porta rilevata

  1. Se si sceglie di stabilire la connessione della stampante tramite una porta rilevata, ottenere le seguenti informazioni:

    Informazioni sulla stampante

    Descrizione

    Dominio DNS completo (nella sezione TCP/IP)

    Questo include il nome della stampante e della rete a cui è connessa. Questo è anche il nome della stampante.

    Indirizzo IP (nella sezione TCP/IP)

    Questo è un valore univoco che la stampante usa per comunicare con altre periferiche e individuarle in una rete.

    UAA (MAC) (nella sezione Scheda di rete standard)

    Questo è il numero di identificazione hardware univoco che distingue la stampante da altre periferiche nella rete.

    Nome Zero Configuration (nella sezione TCP/IP)

    Questo indica che la stampante supporta zeroconf o la rete zero configuration.

    Nota: se non si dispone delle informazioni necessarie, stampare la pagina delle impostazioni di rete. Per ulteriori informazioni, consultare la Guida per l’utente.

  2. Selezionare la stampante dall'elenco, quindi fare clic su Continua.

  3. Se la stampante non è presente nell'elenco, provare una o più delle seguenti soluzioni:

    • Aggiornare l'elenco delle stampanti.

    • Fare clic su Modifica ricerca per aggiungere manualmente una stampante utilizzando le opzioni di rete avanzate.

    • Fare clic su Configurazione wireless per aggiungere una stampante connessa a una rete wireless.

    • Fare clic su Specifica porta per aggiungere manualmente la stampante utilizzando le porte.

    • Assicurazioni che la stampante non sia bloccata da applicazioni di terzi.

    • Accertarsi che il computer non sia connesso a una VPN (rete privata virtuale).

    • Accertarsi che il computer e la stampante siano entrambi connessi alla stessa rete.

    • Accertarsi che alla stampante sia assegnato un indirizzo IP univoco valido.


Connessione della stampante utilizzando un cavo USB

Se è stato selezionato Connetti con un cavo USB, il sistema operativo crea l´oggetto stampante per impostazione predefinita. Il nome dell´oggetto stampante corrisponde a quello creato dal sistema operativo.

Note:

  • Per completare l'installazione e creare l´oggetto stampante, è necessario inserire il cavo USB.
  • Se si connette la stampante utilizzando la porta USB, Messenger di stato deve essere avviato manualmente.


Aggiunta di una stampante di rete

Usare la finestra di dialogo Aggiungi stampante di rete per ricercare le stampanti per nome, indirizzo IP o sottorete. Individuare la stampante e aggiungerla manualmente all'elenco di stampanti di rete disponibili.

Nota: accertarsi di conoscere nome e indirizzo IP della stampante e la sottorete di appartenenza. Per ottenere queste informazioni, stampare la pagina di configurazione di rete. Per ulteriori informazioni, consultare la Guida per l’utente.

Usando il nome e l'indirizzo IP della stampante

Immettere il nome o l'indirizzo IP della stampante, quindi fare clic su OK.

Usando l´indirizzo di sottorete

Se la stampante e il server di stampa si trovano su un'altra rete (denominata sottorete), trovare le stampanti disponibili specificando la sottorete della stampante da accedere.

  • Per aggiungere un´indirizzo di sottorete, immetterlo nel campo specificato, quindi fare clic su Aggiungi > OK.

    Nota: è possibile cercare più indirizzi di sottorete.

  • Per rimuovere un indirizzo di sottorete, evidenziarlo nell´elenco di sottoreti individuate, quindi fare clic su Rimuovi.


Informazioni sui tipi di porta

Nota: alcune porte sono disponibili solo in modelli di stampante selezionati.
Tipi di porta | Descrizione
Server di stampa esterno | Questo è un dispositivo esterno che consente l´accesso di rete mediante le proprie porte Ethernet.
LPR (Line Printer Remote) | Questo è un protocollo usato per inviare i processi di stampa a una stampante remota.
Un server di stampa | Questo è un computer o una periferica collegata a una o più stampant e ai computer client in rete. Può accettare processi di stampa da computer e inviarli alle stampanti appropriate.
TCP/IP standard (Transmission Control Protocol/Internet Protocol) | Questo è un protocollo che definisce le regole che i computer devono seguire per comunicare tra loro in Internet.
UNC (Universal Naming Convention) | Questo è uno standard per identificare server, stampanti e altre risorse in una rete senza mappare l´unità di rete. Esso fornisce a ciascuna risorsa condivisa con un indirizzo univoco. Questo consente ai sistemi operativi che supportano UNC di specificare in modo completo una directory su un file server.


Avvio manuale di Messenger di stato

Nota: Accertarsi che la stampante sia collegata al computer con un cavo USB.

In Windows 8

Da Ricerca, immettere messenger di stato e selezionare:

Elenco app > Messenger di stato

In Windows 7 o versioni precedenti

  1. Fare clic su [image] o su Start.

  2. Fare clic su Tutti i programmi o Programmi, quindi selezionare la cartella dei programmi della stampante dall'elenco.

  3. Fare clic su Printer Home > Messenger di stato.

Messenger di stato si apre.

Note:

  • Messenger di stato è disponibile solo se si è selezionato di includerlo durante la configurazione del pacchetto.
  • Se si scegli di non avviare manualmente Messenger di stato dopo aver creato l´oggetto di stampa, Messenger di stato verrà avviato automaticamente al riavvio del computer.


Specifica di una porta dalla riga di comando

È possibile indicare il nome e l´indirizzo della porta dalla riga di comando durante l´installazione selezionando Specifica la porta all´installazione tramite la riga di comando.

Parametro | Valore | Esempio
/port: | Nome porta | /port:portname
/address: | Nome di rete o indirizzo IP della stampante | /address:123.123.123.123 /address:networkname

Esempio di riga di comando: LexmarkPkgInstall.exe /port:portname /address:123.123.123.123

Note:

  • LexmarkPkgInstall.exe restituisce 0 dopo un´installazione riuscita.
  • Specificare i parametri per porta e indirizzo per iniziare correttamente l´installazione.
  • Il nome e l´indirizzo della porta specificati sono applicati a tutti gli oggetti di stampa nel pacchetto che sono specificati durante l´installazione. Le porte assegnate agli oggetti stampante durante la creazione del pacchetto sono rispettate.
  • I parametri della riga di comando per nome porta o indirizzo sono elaborati solo se il pacchetto è stato creato per accettare il nome e l´indirizzo della porta dalla riga di comando. Se questi paramentri sono passati a un pacchetto che non deve ricevere queste informazioni dalla riga di comando, l´installazione continua ma ignora questi parametri. Le porte sono create in base alle informazioni nel pacchetto e non a quelle specificate dalla riga di comando. Un avviso è generato al prompt dei comandi. In tal caso, il codice restituito è o in quanto l'installazione è riuscita.


Che cosa è il nome della porta?

Il nome della porta è un nome univoco assegnato alla porta sul computer a cui è collegata la stampante.


Perché la stampante non è in elenco?

Accertarsi che il computer e la stampante siano entrambi connessi alla stessa rete wireless

La stampante potrebbe non trovarsi nella stessa rete wireless del computer. Se il computer è già connesso alla rete wireless, l'SSID della stampante e quello del computer devono corrispondere.

  1. Determinare il SSID della rete a cui è collegato il computer.

    1. Immettere l'indirizzo IP del punto di accesso wireless (router wireless) nel campo dell'indirizzo del browser Web.

      Se non si conosce l'indirizzo IP del punto di accesso, attenersi alla seguente procedura:

      In Windows 8

      Da Ricerca, immettere esegui e selezionare:

      Elenco app > Esegui > immettere cmd > OK > immettere ipconfig

      In Windows 7 o versioni precedenti

      1. Fare clic su [image] oppure su Start e quindi fare clic su Esegui.

      2. Nella casella di avvio della ricerca o di esecuzione, immettere cdm.

      3. Premere Invio o fare clic su OK, quindi immettere ipconfig.

      Note:

      • La voce "Gateway predefinito" rappresenta in genere il punto di accesso, ma accertarsi che appartenga alla sezione della connessione di rete wireless delle informazioni ipconfig.
      • L'indirizzo IP è composto da quattro serie di numeri separati da punti, ad esempio 123.123.123.123.

    2. Premere Invio o Vai.

    3. Immettere il nome utente e la password per il punto di accesso wireless quando richiesto e fare clic su OK.

    4. Nella sezione delle impostazioni wireless, cercare l'SSID.

    5. Annotare l'SSID.

      Nota: accertarsi di copiarlo esattamente, incluse le lettere maiuscole.

  2. Determinare l'SSID della rete a cui è collegata la stampante:

    1. Dalla stampante, stampare una pagina di configurazione della rete.

      Per ulteriori informazioni, consultare la Guida per l'utente.

    2. Nella sezione Wireless, cercare l'SSID.

  3. Confrontare l'SSID del computer e quello della stampante.

    Se gli SSID sono uguali, il computer e la stampante sono connessi alla stessa rete wireless.

    Se sono diversi, eseguire nuovamente l'utilità di impostazione wireless per installare la stampante nella rete wireless utilizzata dal computer. Accertarsi di selezionare l'SSID usato dal computer.

Accertarsi che il computer non sia connesso a una VPN (rete privata virtuale)

La maggior parte delle VPN consentono ai computer di comunicare solo con la VPN e non con altre reti contemporaneamente. Scollegarsi dalla VPN prima di installare il driver sul computer o prima di eseguire la configurazione wireless sul computer.

Per verificare se il computer è collegato a una VPN, aprire il software del client VPN e verificare le connessioni VPN. Se non è installato un software di un client VPN sul computer, verificare le connessioni manualmente utilizzato il client VPN di Windows.

Se si desidera effettuare una connessione alla rete locale e a una VPN contemporaneamente, è necessario chiedere al responsabile dell'assistenza del sistema di attivare lo split tunneling. È bene sapere che alcune organizzazioni non consentono lo split tunneling per motivi di sicurezza o tecnici.

Assicurazioni che la stampante non sia bloccata da applicazioni di terzi

Le applicazioni di terzi, inclusi i programmi antivirus, di protezione e i firewall potrebbero impedire il rilevamento della stampante. Configurare l'applicazione in modo da sbloccare la stampante e aggiornare l'elenco di rete.


Selezione di software aggiuntivo

Tenere in considerazione quanto segue quando si seleziona software aggiuntivo:

  • Il software selezionato verrà incluso nel pacchetto generato e installato sul computer nella directory specificata durante l´installazione.

  • Assicurarsi che il percorso di installazione sia lo stesso quando si distribuisce un pacchetto successivo per garantire che sia presente solo una copia dell´applicazione installata e che la versione sia quella più recente.

  • Alcuni file possono essere installati nella directory x86 o nel sistema a 64 bit a seconda del sistema operativo utilizzato.

  • L'elenco di applicazioni software varia a seconda del modello di stampante.


Avvio del pacchetto generato

Effettuare una delle seguenti operazioni:

  • Utilizzare gli script di accesso del sistema operativo.

  • Condividere i pacchetti e richiedere agli utenti di eseguirli.

Nota: È necessario disporre di privilegi amministrativi sufficienti per eseguire l'installazione.


Guida di Package Builder