パッケージビルダーのヘルプについて

パッケージビルダーとは


パッケージビルダーとは

パッケージビルダーを使用すると、ユーザー入力なしで起動できるインストールパッケージをカスタマイズして作成し、展開ソリューションに統合できます。 これは、構成設定済みの接続オプションおよび印刷オプションでプリンタドライバを自動インストールするためのドライバインストールパッケージを生成するツールです。


インストールパッケージを構成する

メモ：

  • 指定された場所に .cab および .exe 形式のファイルが生成されます。
  • パッケージの内容は、選択したオプションによって変わります。
  • 一部の機種でのみ使用できる機能もあります。

パッケージの内容を選択する

［パッケージの内容のオプション］セクションで、以下から 1 つ以上選択します。

  • プリンタおよび/または FAX ドライバを含める

  • スキャンドライバおよび/または追加ソフトウェアを含める

  • 1 つの言語だけをサポートする

    メモ： 標準設定では、生成されるパッケージに、製品がサポートするすべての言語が含まれます。 パッケージのサイズを縮小するには、［1 つの言語だけをサポートする］を選択してから、適切な言語を選択します。

インストール時に使用できるパッケージオプションを選択します。

［パッケージインストール時オプション］セクションで、以下のいずれかを実行します。

  • インストールの状態を非表示にするには、［サイレントインストール］を選択します。

  • インストールの状態とライセンス契約を表示するには、 ［インストールの状態をユーザーに表示する］を選択してから、［ライセンス契約を含める］を選択します。

    メモ： パッケージをインストールするには、ユーザーはライセンス契約に同意する必要があります。

  • インストールの状態を表示し、プロンプトを表示してユーザーにポートを選択させるには、［インストールの状態をユーザーに表示する］を選択してから、［プロンプトを表示してユーザーにポート選択を要求する］を選択します。

    メモ： 生成されたパッケージをインストールするとき、ユーザーはこのポートを選択する必要があります。


プリンタドライバを設定する

プリンタ名について

プリンタを共有する

使用可能な他のドライバを探す

ドライバ設定ファイルについて

構成設定を使用する


プリンタ名について

プリンタ名は、標準設定ではプリンタの機種名が使用されています。 また、インストール後に作成されるプリンタオブジェクト名にもなります。 プリンタオブジェクトは、印刷ジョブが割り当てられる実際のプリンタを表します。 ネットワーク上でプリンタを正しく識別できるように、プリンタオブジェクトに固有の名前が付けられていることを確認してください。

メモ：

  • プリンタオブジェクトを通常使うプリンタに設定するには、［通常使うプリンタに設定］を選択します。
  • インストール中にプリンタオブジェクト名を検出するには、［プリンタ名を検出する］を選択します。 購入したプリンタ機種によっては、このオプションが使用できない場合があります。


プリンタを共有する

［プリンタを共有する］チェックボックスを選択し、以下の情報を入力します。

  • 共有名―他のユーザーが共有プリンタの上にカーソルを置くと表示される名前。

  • コメント―共有プリンタについてのその他の情報。 これはオプションです。

  • 場所―共有プリンタのある場所。 これはオプションです。

メモ： ファイルとプリンタの共有が有効になっていることを確認します。


使用可能な他のドライバを探す

ユニバーサルプリントドライバ（PCL 5、PCL XL、PS、および XPS）を弊社の Web サイトからダウンロードできます。 互換性のあるドライバを表示するには、プリンタの機種を検索します。


ドライバ設定ファイルについて

ドライバ設定ファイル（DCF）は、プリンタ設定とその他のデータを保存するファイルです。 DCF ファイルの拡張子は .ldc です。

パッケージビルダーを使用するとき、プリンタオブジェクトの作成に使用する設定が含まれる DCF を選択してください。 DCF の各設定は、説明で識別されます。

1 つの DCF には、任意の数のプリンタ機種および任意の数のドライバ（Windows の場合は PostScript または PCL エミュレーション）の設定を 1 つ含めることができます。

メモ： ドライバ設定ユーティリティには、Microsoft XML Core Services（MSXML）6 が必要です。これは www.microsoft.com からダウンロードできます。


構成設定を使用する

  1. ［構成設定］セクションで、［構成を使用して設定を適用する］を選択します。

    1. 既存の設定ファイルを使用する場合は、［ファイルの読み込み］をクリックします。

    2. 新しい設定ファイルを作成する場合、以下の手順に従います。

      1. ［新規作成］をクリックします。

      2. 作成する設定データの種類を選択します。

      3. ［完了］をクリックし、設定を保存します。

        4. メモ： この後作成される印刷キューに同じ設定を適用する場合は、［今後のインストールすべてに適用］を選択します。 選択しない場合、設定はこのプリンタオブジェクトだけに適用されます。

  2. ［OK］をクリックします。


プリンタ接続を設定する

検出されたポートからプリンタを選択する

USB ケーブルを使用してプリンタを接続する

ネットワークプリンタを追加する

ポートの種類の概要

ステータスメッセンジャを手動で起動する

コマンドラインを使用してポートを指定する

ポート名とは

リストにプリンタが表示されない


検出されたポートからプリンタを選択する

  1. 検出されたポート経由でプリンタ接続を確立する場合、以下の情報が必要です。

    プリンタ情報

    説明

    完全修飾ドメイン名（「TCP/IP」セクション）

    これには、プリンタの名前と、プリンタが接続されているネットワークの名前が含まれています。 プリンタ名とも呼ばれます。

    IP アドレス（「TCP/IP」セクション）

    お使いのプリンタがネットワーク上の他のデバイスを識別し、通信を行うために使用される固有の数字です。

    UAA (MAC)（「標準ネットワークカード」セクション）

    プリンタとネットワーク上のその他のデバイスを識別するための固有のハードウェア ID 番号です。

    ゼロ構成名（「TCP/IP」セクション）

    お使いのプリンタで zeroconf またはゼロ構成ネットワークがサポートされていることを示します。

    メモ： 必要な情報を持っていない場合、［ネットワーク設定］ページを印刷します。 詳細については、『ユーザーズガイド』を参照してください。

  2. リストからプリンタを選び、［続行］をクリックします。

  3. リストにプリンタがない場合、以下のいずれかを試してみてください。

    • プリンタリストを更新します。

    • ［検索の変更］をクリックし、高度なネットワーク設定を使用して、手動でプリンタを追加します。

    • ［ワイヤレスの設定］をクリックし、ワイヤレスネットワークに接続されたプリンタを追加します。

    • ［ポートを指定］をクリックし、ポートを使用して、手動でプリンタを追加します。

    • サードパーティ製アプリケーションでプリンタがブロックされていないことを確認します。

    • コンピュータが仮想プライベートネットワーク（VPN）に接続されていないことを確認します。

    • お使いのコンピュータとプリンタが同じネットワークに接続されていることを確認します。

    • 有効かつ固有の IP アドレスがプリンタに割り当てられていることを確認します。


USB ケーブルを使用してプリンタを接続する

［USB ケーブルで接続］を選択すると、オペレーティングシステムにより標準設定でプリンタオブジェクトが作成されます。 プリンタオブジェクト名は、オペレーティングシステムによって作成された名前と一致している必要があります。

メモ：

  • インストールを完了し、プリンタオブジェクトを作成するには、USB ケーブルを差し込む必要があります。
  • USB ポートを使用してプリンタを接続した場合は、ステータスメッセンジャを手動で起動する必要があります。


ネットワークプリンタを追加する

［ネットワークプリンタを追加］ダイアログを使用して、プリンタ名、IP アドレス、またはサブネットでプリンタを検索します。 プリンタを見つけたら、使用できるネットワークプリンタの一覧に手動で追加します。

メモ： プリンタの名前、IP アドレス、および所属するサブネットの名前を確認しておきます。 これらの情報を入手するには、ネットワーク設定ページを印刷します。 詳細については、『ユーザーズガイド』を参照してください。

プリンタ名とIP アドレスを使用する場合

プリンタ名または IP アドレスを入力し、［OK］をクリックします。

サブネットアドレスを使用する場合

プリンタおよびプリントサーバーが別のネットワーク（サブネットと呼ばれます）上にある場合は、アクセスしたいプリンタのサブネットを指定して、使用できるプリンタを検索します。

  • サブネットアドレスを追加するには、指定されたフィールドにサブネットアドレスを入力し、［追加］ > ［OK］の順にクリックします。

    メモ： 複数のサブネットアドレスを検索することもできます。

  • サブネットアドレスを削除するには、検出されたサブネットの一覧で該当するサブネットアドレスをハイライト表示し、［削除］をクリックします。


ポートの種類の概要

メモ： ポートによっては、一部のプリンタ機種で使用できない場合があります。
ポートの種類 | 説明
外付けプリントサーバー | イーサネットポート経由でネットワークにアクセスできる外付けデバイス。
LPR（Line Printer Remote） | 印刷ジョブをリモートプリンタに送信するときに使用するプロトコル。
プリントサーバー | ネットワーク経由で 1 つ以上のプリンタおよびクライアントコンピュータに接続されているコンピュータまたはデバイス。 プリンタから印刷ジョブを受信し、適切なプリンタにジョブを送信します。
標準 TCP/IP（Transmission Control Protocol/Internet Protocol） | コンピュータがインターネット経由で互いに通信するために従うべき規則を定義したプロトコル。
UNC（Universal Naming Convention） | ネットワークドライブをマッピングせずに、ネットワーク内でサーバー、プリンタ、および他のリソースを識別するための標準。 共有リソースごとに固有のアドレスが提供されます。 これにより、UNC をサポートしているオペレーティングシステムでは、ファイルサーバー上のディレクトリを完全に指定することができます。


ステータスメッセンジャを手動で起動する

メモ： プリンタとコンピュータが USB ケーブルで接続されていることを確認します。

Windows 8 の場合

［検索］チャームで、「ステータスメッセンジャ」と入力し、次の順に選択します。

［アプリ］リスト > ［ステータスメッセンジャ］

Windows 7 以前の OS の場合

  1. または［スタート］をクリックします。

  2. ［すべてのプログラム］または［プログラム］をクリックし、一覧からプリンタのプログラムフォルダを選択します。

  3. ［プリンタのホーム］ >［ステータスメッセンジャ］の順にクリックします。

ステータスメッセンジャが開きます。

メモ：

  • ステータスメッセンジャを使用できるのは、パッケージ構成時にステータスメッセンジャが含まれるように選択していた場合のみです。
  • プリンタオブジェクトの作成後、ステータスメッセンジャを手動で起動しないことを選択していた場合、ステータスメッセンジャはコンピュータの再起動時に自動で起動します。


コマンドラインを使用してポートを指定する

［Specify the port at install time through the command line］（インストール時にコマンドラインでポートを指定する）を選択すると、インストール時にコマンドラインでポート名とポートアドレスを指定できます。

パラメータ | 値 | サンプル
/port: | ポート名 | /port:portname
/address: | プリンタのネットワーク名または IP アドレス | /address:123.123.123.123 /address:networkname

コマンドラインの例： LexmarkPkgInstall.exe /port:portname /address:123.123.123.123

メモ：

  • インストールが成功すると、LexmarkPkgInstall.exe は 0 を返します。
  • インストールを正常に開始するには、ポートとアドレスのパラメータを指定します。
  • 指定されるポート名とアドレスは、インストール時に指定されるように設定されたパッケージのすべてのプリンタオブジェクトに適用されます。 パッケージ作成時にポートを割り当てられたプリンタオブジェクトの場合、パッケージ作成時に選択されたポートが適用されます。
  • ポート名およびアドレスをコマンドラインで受け取るようにパッケージが作成されている場合のみ、ポート名またはアドレスのコマンドラインパラメータが処理されます。 コマンドラインでこの情報を受け取るように設定されていないパッケージにこれらのパラメータが送信されると、インストールは開始されますが、これらのパラメータは無視されます。 ポートは、コマンドラインのパラメータではなく、パッケージの情報に基づいて作成されます。 コマンドプロンプトに注意メッセージが表示されますが、 この場合、インストールが正常に完了しているため、リターンコードは 0 です。


ポート名とは

ポート名とは、プリンタが接続されているコンピュータ上のポートに割り当てられた固有の名前のことです。


リストにプリンタが表示されない

お使いのコンピュータとプリンタが同じワイヤレスネットワークに接続されていることを確認する

プリンタがコンピュータと同じワイヤレスネットワーク上にない可能性があります。 コンピュータがすでにワイヤレスネットワークへ接続されている場合は、プリンタの SSID がコンピュータの SSID と同じである必要があります。

  1. コンピュータが接続されているネットワークの SSID を確認します。

    1. お使いのアクセスポイント（無線ルーター）の IP アドレスを、ブラウザのアドレスフィールドに入力します。

      アクセスポイントの IP アドレスがわからない場合は、以下の手順に従います。

      Windows 8 の場合

      ［検索］チャームで、「ファイル名を指定して実行」と入力し、次の順に選択します。

      ［アプリ］リスト > ［ファイル名を指定して実行］ > 「cmd」と入力 > ［OK］ > 「ipconfig」と入力

      Windows 7 以前の OS の場合

      1. をクリックします。または、［スタート］、［ファイル名を指定して実行］の順にクリックします。

      2. ［検索の開始］または［ファイル名を指定して実行］ボックスで、「cmd」と入力します。

      3. Enter キーを押すか、［OK］をクリックし、「ipconfig」と入力します。

      メモ：

      • 通常、［デフォルト ゲートウェイ］のエントリがアクセスポイントを示します。念のため、このエントリが ipconfig 情報の［ワイヤレスネットワーク接続］セクションにあることを確認してください。
      • IP アドレスは、123.123.123.123 のようなピリオドで区切られた 4 つの数字の並びで表されます。

    2. Enter キーを押すか［実行］をクリックします。

    3. メッセージが表示されたら、お使いのアクセスポイントのユーザー名とパスワードを入力し、［OK］をクリックします。

    4. ［ワイヤレス］設定セクションで、SSID を探します。

    5. SSID をメモします。

      メモ： 大文字と小文字を区別して、正確にメモしてください。

  2. プリンタが接続されているネットワークの SSID を確認します。

    1. プリンタでネットワーク設定ページを印刷します。

      詳細については、『ユーザーズガイド』を参照してください。

    2. 「ワイヤレス」セクションで、「SSID」を探します。

  3. コンピュータの SSID とプリンタの SSID を比較します。

    SSID が同じであれば、コンピュータとプリンタは同じワイヤレスネットワークに接続されています。

    SSID が同じでない場合は、Wireless Setup Utility をもう一度実行して、プリンタをコンピュータが使用しているワイヤレスネットワークに接続します。 コンピュータが使用している SSID を選択していることを確認します。

コンピュータが仮想プライベートネットワーク（VPN）に接続されていないことを確認する

ほとんどの仮想プライベートネットワークでは、コンピュータは VPN とのみ通信でき、他のネットワークと同時に通信することはできません。 コンピュータにドライバをインストールする前、またはコンピュータでワイヤレスセットアップを実行する前に、VPN からの接続を解除します。

コンピュータが現在 VPN に接続されているかどうかを確認するには、VPN クライアント ソフトウェアを開き、次に VPN 接続を確認します。 VPN クライアントソフトウェアをインストールしていない場合は、Windows VPN クライアントを使って手動で接続を確かめます。

ローカルネットワークと VPN への接続を同時に行う場合は、VPN のシステムサポート担当者にスプリットトンネリングの有効化を要求してください。 セキュリティ上または技術上の理由により、一部の組織ではスプリットトンネリングが許可されないのでご注意ください。

サードパーティ製アプリケーションでプリンタがブロックされていないことを確認する

アンチウィルス、セキュリティ、ファイアウォールプログラムなどのサードパーティ製アプリケーションで、プリンタの検出がブロックされている場合があります。 プリンタをブロックしないようにアプリケーションを設定し、ネットワークリストを更新します。


追加のソフトウェアを選択する

追加のソフトウェアを選択する場合、以下に留意してください。

  • 選択されたソフトウェアは、生成されるパッケージに含まれ、インストール時に、ユーザーのシステムの指定されたディレクトリにインストールされます。

  • 最新のアプリケーションが 1 つだけインストールされるように、次にパッケージを展開するときも同じインストールパスを使用します。

  • お使いのオペレーティングシステムによっては、一部のファイルが、32 bit 対応プログラム用の（x86）ディレクトリまたは 64 bit 対応プログラム用のディレクトリのいずれかにインストールされる場合があります。

  • ソフトウェアアプリケーションのリストは、プリンタ機種によって変わります。


生成されたパッケージを起動する

以下のいずれかを実行します。

  • オペレーティングシステムのログオンスクリプトを使用する。

  • パッケージを共有して、ユーザーに起動させる。

メモ： インストールを行うために必要な管理者権限があることを確認してください。


パッケージビルダーのヘルプ