패키지 빌더 도움말 정보

패키지 빌더란?


패키지 빌더란?

패키지 빌더를 사용하면 사용자 입력 없이 실행할 수 있고 배포 솔루션에 통합되는 사용자 지정된 설치 관리자 패키지를 만들 수 있습니다. 이 도구는 미리 구성된 연결 및 인쇄 옵션을 통해 프린터 드라이버 설치를 자동화하는 드라이버 설치 패키지를 생성합니다.


설치 패키지 구성

참고:

  • .cab 및 .exe 형식의 파일은 지정된 위치에 생성됩니다.
  • 패키지 내용은 선택한 옵션에 따라 다릅니다.
  • 일부 기능은 일부 프린터 모델에서만 사용 가능합니다.

패키지 내용 선택

"패키지 내용 옵션" 섹션에서 다음 중 하나 이상을 선택합니다.

  • 인쇄 및/또는 팩스 드라이버 포함

  • 스캔 드라이버 및/또는 추가 소프트웨어 포함

  • 단일 언어만 지원

    참고: 기본적으로 제품이 지원하는 모든 언어가 생성된 패키지에 포함됩니다. 패키지 크기를 줄이려면 단일 언어만 지원을 선택한 후 적합한 언어를 선택합니다.

설치 중 사용 가능한 패키지 옵션을 선택합니다.

"패키지 설치 시간 옵션" 섹션에서 다음 중 하나를 선택합니다.

  • 설치 상태를 숨기려면 무인 설치를 선택합니다.

  • 라이센스 계약과 함께 설치 상태를 표시하려면 사용자에게 설치 상태 표시를 선택한 후 라이센스 계약 포함을 선택합니다.

    참고: 사용자가 패키지를 설치하려면 라이센스 계약을 수락해야 합니다.

  • 설치 상태를 표시하고 사용자가 포트를 선택하도록 하려면 사용자에게 설치 상태 표시를 선택한 후 포트 선택을 사용자에게 프롬프트를 선택합니다.

    참고: 생성된 패키지를 설치할 때 사용자가 포트를 선택해야 합니다.


프린터 드라이버 구성

프린터 이름 이해

프린터 공유

사용할 수 있는 다른 드라이버 식별

드라이버 구성 파일 이해

구성 설정 사용


프린터 이름 이해

기본적으로 프린터 이름은 프린터의 모델 이름입니다. 설치 후 생성되는 프린터 개체 이름이라고도 부릅니다. 프린터 개체는 인쇄 작업을 할당할 수 있는 실제 프린터를 나타냅니다. 프린터 개체의 이름이 네트워크에서 프린터를 올바르게 식별할 수 있도록 고유한지 확인하십시오.

참고:

  • 프린터 개체를 기본 프린터로 설정하려면 기본 프린터로 설정을 선택합니다.
  • 응용 프로그램이 설치 중 프린터 개체 이름을 검색할 수 있도록 하려면 프린터 이름 검색을 선택합니다. 이 옵션은 구입한 프린터 모델에 따라 제공되지 않을 수 있습니다.


프린터 공유

프린터 공유 확인란을 선택한 후 다음 정보를 입력합니다.

  • 공유 이름-다른 사용자가 공유 프린터에 연결할 때 표시되는 이름입니다.

  • 설명-공유 프린터에 대한 추가 설명입니다. 선택 사항입니다.

  • 위치-공유 프린터의 위치를 나타냅니다. 선택 사항입니다.

참고: 파일 및 인쇄 공유가 설정되어 있는지 확인합니다.


사용할 수 있는 다른 드라이버 식별

범용 인쇄 드라이버(PCL 5, PCL XL, PS 및 XPS)는 웹사이트에서 다운로드할 수 있습니다. 호환 드라이버를 보려면 프린터 모델을 찾습니다.


드라이버 구성 파일 이해

DCF(드라이버 구성 파일)는 저장된 프린터 설정 및 기타 데이터가 포함된 파일입니다. DCF에는 파일 확장명으로 .ldc가 사용됩니다.

패키지 빌더를 사용할 경우 프린터 개체를 생성하는 데 사용할 구성이 들어 있는 DCF를 선택합니다. DCF의 개별 구성은 해당 설명으로 식별됩니다.

DCF는 여러 프린터 모델 및 서로 다른 여러 드라이버(Windows용 PostScript 또는 PCL 에뮬레이션)의 구성을 포함할 수 있습니다.

참고: 드라이버 구성 유틸리티에는 MSXML(Microsoft XML Core Services) 6이 필요합니다. 이 프로그램은 www.microsoft.com에서 다운로드할 수 있습니다.


구성 설정 사용

  1. 구성 설정(Configuration Settings) 섹션에서 설정 적용을 위한 구성 사용(Use a configuration to apply settings)을 선택합니다.

    1. 기존 구성 파일을 사용하려는 경우 파일 로드(Load File)를 누릅니다.

    2. 새 구성 파일을 만들려면 다음을 수행합니다.

      1. 새로 만들기를 누릅니다.

      2. 만들려는 구성 데이터를 선택합니다.

      3. 마침을 누른 후 설정을 저장합니다.

        4. 참고: 이후의 모든 인쇄 큐 생성에 동일한 구성을 적용하려면 모든 이후 설치에 적용을 선택합니다. 그렇지 않으면 구성이 이 프린터 개체에만 적용됩니다.

  2. 확인을 누릅니다.


프린터 연결 구성

검색된 포트에서 프린터 선택

USB 케이블을 사용하여 프린터 연결

네트워크 프린터 추가

포트 유형 이해

상태 메신저 수동 실행

명령줄을 사용하여 포트 지정

포트 이름은 무엇입니까?

목록에 프린터가 없는 이유


검색된 포트에서 프린터 선택

  1. 검색된 포트를 통해 프린터 연결을 설정하도록 선택한 경우 다음 정보를 확인합니다.

    프린터 정보

    설명

    정규화된 도메인 이름(TCP/IP 섹션)

    이 정보에는 프린터 및 프린터가 연결된 네트워크 이름이 포함됩니다. 이 정보는 프린터 이름이기도 합니다.

    IP 주소(TCP/IP 섹션)

    이 정보는 네트워크에 있는 다른 장치의 위치를 찾고 통신하기 위해 사용하는 고유한 번호입니다.

    UAA(MAC)(표준 네트워크 카드 섹션)

    이 정보는 프린터를 네트워크의 다른 장치들과 구별하기 위한 고유의 하드웨어 식별 번호입니다.

    제로 구성 이름(TCP/IP 섹션)

    이 정보는 프린터가 zeroconf 또는 제로 구성 네트워킹을 지원하는지를 나타냅니다.

    참고: 필요한 정보가 없으면 네트워크 설정 페이지를 인쇄합니다. 자세한 내용은 사용 설명서를 참조하십시오.

  2. 목록에서 프린터를 선택한 다음 계속(Continue)을 누릅니다.

  3. 프린터가 목록에 표시되지 않으면 다음 중 하나 이상의 방법을 시도합니다.

    • 프린터 목록을 새로 고칩니다.

    • 검색 수정을 눌러 고급 네트워크 설정을 사용해서 프린터를 수동으로 추가합니다.

    • 무선 구성을 눌러 무선 네트워크에 연결된 프린터를 추가합니다.

    • 포트 지정을 눌러 포트를 사용해서 프린터를 수동으로 추가합니다.

    • 타사 응용프로그램이 프린터를 차단하고 있지 않은지 확인합니다.

    • 컴퓨터가 가상 사설 통신망(VPN)에 연결되어 있지 않은지 확인합니다.

    • 컴퓨터와 프린터가 동일한 네트워크에 연결되어 있는지 확인합니다.

    • 프린터에 올바르고 고유한 IP 주소가 할당되었는지 확인합니다.


USB 케이블을 사용하여 프린터 연결

USB 케이블로 연결을 선택한 경우 운영 체제가 기본적으로 프린터 개체를 만듭니다. 프린터 개체 이름은 운영 체제에서 만든 이름과 일치해야 합니다.

참고:

  • 설치를 완료하고 프린터 개체를 만들려면 사용자가 USB 케이블을 삽입해야 합니다.
  • USB 포트를 사용하여 프린터를 연결한 경우 사용자가 상태 메신저를 수동으로 실행해야 합니다.


네트워크 프린터 추가

네트워크 프린터 추가 대화 상자를 사용하여 프린터 이름, IP 주소 또는 서브넷별로 프린터를 검색할 수 있습니다. 프린터를 찾은 다음 사용 가능한 네트워크 프린터 목록에 수동으로 추가하십시오.

참고: 프린터의 이름 및 IP 주소와 프린터가 속해 있는 서브넷을 확인해야 합니다. 이러한 정보를 얻으려면 네트워크 설정 페이지를 인쇄하십시오. 자세한 내용은 사용 설명서를 참조하십시오.

프린터 이름 및 IP 주소 사용

프린터 이름 또는 IP 주소를 입력한 후 확인을 누릅니다.

서브넷 주소 사용

프린터 및 인쇄 서버가 다른 네트워크(서브넷)에 있는 경우, 액세스하려는 프린터의 서브넷을 지정하여 사용 가능한 프린터를 찾습니다.

  • 서브넷 주소를 추가하려면 지정된 필드에 서브넷 주소를 입력한 후 추가 > 확인을 누릅니다.

    참고: 또한 여러 서브넷 주소를 검색할 수도 있습니다.

  • 서브넷 주소를 제거하려면 검색된 서브넷 목록에서 서브넷 주소를 강조 표시한 후 제거를 누릅니다.


포트 유형 이해

참고: 일부 포트는 일부 프린터 모델에서만 사용 가능합니다.
포트 종류 | 설명
외부 인쇄 서버 | 이 장치는 이더넷 포트를 통해 네트워크에 액세스하도록 허용하는 외부 장치입니다.
LPR(Line Printer Remote) | 원격 프린터에 인쇄 작업을 제출하는 데 사용되는 프로토콜입니다.
프린트 서버 | 하나 이상의 프린터 및 클라이언트 컴퓨터에 네트워크를 통해 연결된 컴퓨터 또는 장치입니다. 컴퓨터에서 인쇄 작업을 허용하고 적합한 프린터로 작업을 보낼 수 있습니다.
표준 TCP/IP(전송 제어 프로토콜/인터넷 프로토콜) | 인터넷을 통해 서로 통신하기 위해 컴퓨터가 따라야 하는 규칙을 정의하는 프로토콜입니다.
UNC(Universal Naming Convention) | 네트워크 드라이브를 매핑하지 않고 네트워크에서 서버, 프린터 및 기타 리소스를 식별하기 위한 표준입니다. 이 표준은 각각의 공유 리소스에 고유한 주소를 제공합니다. 이를 통해 UNC를 지원하는 운영 체제는 파일 서버에서 디렉터리를 완전히 지정할 수 있습니다.


상태 메신저 수동 실행

참고: 프린터와 컴퓨터가 USB 케이블을 사용하여 연결되어 있는지 확인합니다.

Windows 8의 경우

검색 창에서 status messenger를 입력한 후 다음 위치로 이동합니다.

앱 목록 > Status Messenger

Windows 7 또는 이전 버전의 경우

  1. 또는 시작을 누릅니다.

  2. 모든 프로그램 또는 프로그램을 누른 후 목록에서 프린터 프로그램 폴더를 선택합니다.

  3. 프린터 홈 > 상태 메신저를 누릅니다.

상태 메신저가 열립니다.

참고:

  • 상태 메신저는 패키지 구성 중에 포함하도록 선택한 경우에만 사용할 수 있습니다.
  • 상태 메신저를 수동으로 실행하도록 선택하지 않으면 인쇄 개체가 만들어진 후 컴퓨터를 다시 시작할 때 상태 메신저가 자동으로 실행됩니다.


명령줄을 사용하여 포트 지정

설치 중 설치 시 명령줄을 통해 포트 지정을 선택하여 명령줄에서 포트 이름 및 포트 주소를 나타낼 수 있습니다.

매개변수 | 값 | 샘플
/port: | 포트 이름 | /port:portname
/address: | 프린터의 네트워크 이름 또는 IP 주소 | /address:123.123.123.123 /address:networkname

샘플 명령줄: LexmarkPkgInstall.exe /port:portname /address:123.123.123.123

참고:

  • LexmarkPkgInstall.exe는 설치 성공 후 0을 반환합니다.
  • 설치를 성공적으로 시작하려면 포트 및 주소 매개변수를 지정해야 합니다.
  • 지정된 포트 이름 및 주소는 설치 중 지정하도록 설정된 패키지의 모든 인쇄 개체에 적용됩니다. 패키지를 만드는 중 지정된 프린터 개체의 경우 패키지 시간 중 선택한 포트가 사용됩니다.
  • 포트 이름 또는 주소에 대한 명령줄 매개변수는 패키지가 명령줄에서 포트 이름 및 주소를 수락하도록 만들어진 경우에만 처리됩니다. 명령줄에서 이 정보를 수신하지 않는 패키지에 이러한 매개변수를 전달하면 설치가 진행되더라도 이러한 매개변수가 무시됩니다. 포트는 명령줄의 매개변수가 아니라 패키지의 정보를 기반으로 만들어집니다. 경고는 명령줄에 표시됩니다. 이 경우에는 설치가 성공적으로 완료되었기 때문에 반환 코드가 0입니다.


포트 이름은 무엇입니까?

포트 이름은 프린터가 연결된 컴퓨터에서 포트에 할당된 고유한 이름입니다.


목록에 프린터가 없는 이유

컴퓨터와 프린터가 동일한 무선 네트워크에 연결되어 있는지 확인

프린터가 컴퓨터와 동일한 무선 네트워크 상에 있지 않은 경우입니다. 컴퓨터가 무선 네트워크에 이미 연결된 경우 프린터의 SSID가 컴퓨터의 SSID와 일치해야 합니다.

  1. 컴퓨터가 연결된 네트워크의 SSID를 확인합니다.

    1. 웹 브라우저의 주소 필드에 액세스 포인트(무선 라우터)의 IP 주소를 입력합니다.

      액세스 포인트의 IP 주소를 모르는 경우 다음과 같이 하십시오.

      Windows 8의 경우

      검색 창에서 run을 입력한 후 다음 위치로 이동합니다.

      앱 목록 > 실행 > cmd 입력 > 확인 > ipconfig 입력

      Windows 7 또는 이전 버전의 경우

      1. 를 누르거나, 시작을 누른 다음 실행을 누릅니다.

      2. 검색 시작 또는 실행 상자에 cmd를 입력합니다.

      3. Enter 키를 누르거나 확인을 누른 후 ipconfig를 입력합니다.

      참고:

      • “기본 게이트웨이” 항목은 일반적으로 액세스 포인트이지만, ipconfig 정보의 "무선 네트워크 연결" 섹션에 속하는지 확인합니다.
      • IP 주소는 123.123.123.123과 같이 마침표로 구분된 네 개의 숫자 집합으로 표시됩니다.

    2. Enter 키를 누르거나 이동을 누릅니다.

    3. 메시지가 나타나면 액세스 포인트에 대한 사용자 이름과 암호를 입력한 다음 확인을 누릅니다.

    4. 무선 설정 섹션에서 SSID를 찾습니다.

    5. SSID를 기록합니다.

      참고: 대문자를 포함하여 정확하게 기록해야 합니다.

  2. 프린터가 연결된 네트워크의 SSID를 다음과 같이 얻습니다.

    1. 프린터에서 네트워크 설정 페이지를 인쇄합니다.

      자세한 내용은 사용자 설명서를 참조하십시오.

    2. 무선 섹션에서 SSID를 찾습니다.

  3. 컴퓨터의 SSID와 프린터의 SSID를 비교합니다.

    SSID가 동일한 경우 컴퓨터와 프린터는 동일한 무선 네트워크에 연결됩니다.

    SSID가 동일하지 않은 경우 무선 설정 유틸리티를 다시 실행하여 컴퓨터에서 사용하는 무선 네트워크상에서 프린터를 설정합니다. 컴퓨터가 사용하는 SSID를 선택했는지 확인합니다.

컴퓨터가 가상 사설 통신망(VPN)에 연결되어 있지 않은지 확인

대부분의 VPN 사용 컴퓨터는 VPN과의 통신만이 가능하며 동시에 다른 네트워크를 사용할 수 없습니다. 컴퓨터에 드라이브를 설치하거나 무선 설정을 실행하기 전에 VPN과의 연결을 해제합니다.

컴퓨터가 현재 VPN에 연결되어 있는지 확인하려면 VPN 클라이언트 소프트웨어를 열고 VPN 연결을 확인합니다. VPN 클라이언트 소프트웨어를 설치하지 않은 경우 Windows VPN 클라이언트를 사용하여 수동으로 연결을 확인합니다.

로컬 네트워크와 VPN에 동시에 연결할 수 있도록 하려면 VPN 시스템 지원 담당자에게 스플릿 터널링을 허용하도록 요청하십시오. 일부 조직에서는 보안 또는 기술적인 문제로 스플릿 터널링을 허용하지 않을 수 있습니다.

타사 응용프로그램이 프린터를 차단하고 있지 않은지 확인

안티 바이러스, 보안 및 방화벽 프로그램과 같은 타사 응용 프로그램은 사용자의 프린터 검색을 차단할 수 있습니다. 프린터를 차단 해제하도록 응용프로그램 설정을 구성한 다음 네트워크 목록을 새로 고칩니다.


추가 소프트웨어 선택

추가 소프트웨어를 선택할 때는 다음 사항에 주의하십시오.

  • 선택한 소프트웨어는 생성된 패키지에서 실행되며 사용자 시스템에서 설치 중 지정된 디렉토리에 설치됩니다.

  • 이후 패키지를 배포할 때는 설치된 응용 프로그램이 하나만 존재하고 최신 버전인지 확인하기 위해 동일한 설치 경로를 사용하십시오.

  • 일부 파일은 사용되는 운영 체제에 따라 x86 디렉터리 또는 64비트 시스템에 설치될 수 있습니다.

  • 소프트웨어 응용 프로그램 목록은 프린터 모델에 따라 다를 수 있습니다.


생성된 패키지 실행

다음 중 하나를 수행합니다.

  • 운영 체제 로그온 스크립트를 사용합니다.

  • 패키지를 공유하고 사용자가 호출하도록 합니다.

참고: 설치를 수행하는 데 충분한 관리자 권한이 있는지 확인합니다.


패키지 빌더 도움말