Om Hjelp for Pakkebygger

Hva er en Pakkebygger?


Hva er en Pakkebygger?

Med Pakkebygger kan du opprette tilpassede installasjonspakker som kan iverksettes uten brukermedvirkning, og integreres i distribusjonsløsningen din. Det er et verktøy som genererer driverinstallasjonspakker som automatiserer installasjonen av skriverdrivere med forhåndskonfigurerte alternativer for tilkobling og utskrift.


Konfigurasjon av installasjonspakken

Merk:

  • Filer med formatene .cab og .exe blir generert på den angitte plasseringen.
  • Pakkens innhold varierer avhengig av hvilke alternativer du velger.
  • Noen funksjoner er bare tilgjengelige på enkelte modeller.

Velg innholdet i pakken

I delen "Alternativer for pakkeinnhold", velger du ett eller flere av følgende alternativer:

  • Inkluder skriver- og/eller faksdrivere

  • Inkluder skannerdriver og/eller tilleggsprogramvare

  • Støtte for ett språk

    Merk: Alle språk som støttes av produktet er inkludert i den genererte pakken som standard. Hvis du vil redusere størrelsen på pakken, velger du Støtte for ett språk, og deretter det ønskede språket.

Velg pakkealternativene som er tilgjengelige under installasjonen

I delen "Alternativer for pakken under installering" gjør du ett av følgende:

  • Hvis du vil skjule installasjonsstatusen, velger du Stille installasjon.

  • For å vise installasjonsstatus sammen med lisensavtalen velger du Vis installasjonsstatus til brukeren, og deretter Inkluder lisensavtalen.

    Merk: Bruken må godta lisensavtalen for å kunne installere pakken.

  • For å vise installasjonsstatus og be brukeren om å velge en port, velger du Vis installasjonsstatus til brukeren, og deretter Be bruker om å velge port.

    Merk: Brukeren må velge porten under installasjonen av den genererte pakken.


Konfigurasjon av skriverdriveren

Forstå skrivernavnet

Dele skriveren

Identifisere andre tilgjengelige drivere

Forstå driverkonfigurasjonsfilen

Bruk av konfigurasjonsinnstillinger


Forstå skrivernavnet

Som standard brukes skriverens modellnavn som skrivernavn. Skrivernavnet kan også være skriverobjektnavnet som opprettes etter installasjonen. Et skriverobjekt representerer den faktiske skriveren som en utskriftsjobb kan være tilordnet til. Kontroller at skriverobjektet har et unikt navn slik at riktig skriver kan identifiseres i nettverket.

Merk:

  • For å angi skriverobjektet som standardskriver velger du Angi som standardskriver.
  • Du kan la programmet registrere skriverobjektnavnet under installasjonen ved å velge Registrer skrivernavn. Dette alternativet er kanskje ikke tilgjengelig, avhengig av skrivermodell.


Dele skriveren

Velg avmerkingsboksen Del skriveren, og angi deretter følgende informasjon:

  • Delingsnavn Navnet andre brukere ser når de peker til en delt skriver.

  • Kommentarer Eventuelle tilleggsnotater for den delte skriveren. Dette er valgfritt.

  • Plassering Angir plasseringen til den delte skriveren. Dette er valgfritt.

Merk: Kontroller at deling av filer og skrivere er slått på.


Identifisere andre tilgjengelige drivere

Universale skriverdrivere (PCL 5, PCL XL, PS, og XPS) kan lastes ned fra hjemmesiden vår. Søk etter skrivermodellen for å vise kompatible drivere.


Forstå driverkonfigurasjonsfilen

En driverkonfigurasjonsfil (DCF) inneholder lagrede skriverinnstillinger og andre data. Slike filer må ha etternavnet .ldc.

Når du bruker Pakkebygger, velger du DCF-filen som inneholder konfigurasjonene du ønsker å bruke til å opprette et skriverobjekt. Den individuelle konfigurasjonen i DCF-filen vises i en beskrivelse.

En DCF-fil kan inneholde én konfigurasjon for flere skrivermodeller og drivere (PostScript- eller PCL-emuleringer for Windows).

Merk: Konfigureringsverktøyet for skriverdriver krever Microsoft XML Core Services (MSXML) 6. Dette kan lastes ned fra www.microsoft.com.


Bruk av konfigurasjonsinnstillinger

  1. Velg Bruk en konfigurasjon for å ta i bruk innstillinger under Konfigurasjonsinnstillinger.

    1. Hvis du vil bruke en eksisterende konfigurasjonsfil, klikker du på Last inn fil.

    2. Hvis du vil opprette en ny konfigurasjonsfil, gjør du følgende:

      1. Klikk på Ny.

      2. Velg hva slags konfigurasjonsdata du ønsker å opprette.

      3. Klikk på Fullfør, og lagre innstillingene.

        4. Merk: Hvis du ønsker å benytte den samme konfigurasjonen for alle fremtidige utskriftskøer, velger du Bruk for alle fremtidige installasjoner. Hvis du ikke velger dette alternativet, gjelder konfigurasjonen bare for dette skriverobjektet.

  2. Klikk på OK.


Konfigurasjon av skrivertilkobling

Velge skriveren fra en oppdaget port

Koble til skriveren med en USB-kabel

Legge til en nettverksskriver

Forstå porttyper

Starte Statussenter manuelt

Angi en port ved hjelp av kommandolinjen

Hva er et portnavn?

Hvorfor vises ikke skriveren min på listen?


Velge skriveren fra en oppdaget port

  1. Hvis du velger å opprette en skrivertilkobling gjennom en oppdaget port, bør du anskaffe følgende informasjon:

    Skriverinformasjon

    Beskrivelse

    Fullstendig domenenavn (i delen TCP/IP)

    Dette navnet omfatter navnet på skriveren og nettverket som skriveren er tilkoblet. Dette er samtidig skrivernavnet.

    IP-adresse (i delen TCP/IP)

    Dette er et unikt nummer som skriveren bruker til å finne og kommunisere med andre enheter i nettverket.

    UAA (MAC) (i delen Standard nettverkskort)

    Dette er en unik maskinvare-ID som skiller skriveren fra andre enheter i nettverket.

    Nullkonfigurasjonsnavn (i delen TCP/IP)

    Det forteller at skriveren støtter nullkonfig eller nullkonfigurasjonsnettverk.

    Merk: Hvis du ikke har de nødvendige opplysningene, bør du skrive ut en nettverkskonfigurasjonsside. Du finner mer informasjon i brukerhåndboken.

  2. Velg skriveren fra listen, og klikk på Fortsett.

  3. Hvis skriveren ikke vises i listen, kan du prøve ett eller flere av disse alternativene:

    • Oppdater skriverlisten.

    • Klikk på Endre søk for å legge til skriveren manuelt med avanserte nettverksinnstillinger.

    • Klikk på Konfigurer trådløs for å legge til en skriver som er tilkoblet på et trådløst nettverk.

    • Klikk på Angi port for å legge til skriveren manuelt med porter.

    • Kontroller at tredjepartsprogrammer ikke blokkerer skriveren.

    • Kontroller at datamaskinen ikke er koblet til et virtuelt privat nettverk (VPN).

    • Kontroller at skriveren og datamaskinen er koblet til det samme trådløse nettverket.

    • Kontroller at skriveren er tilordnet en IP-adresse som er gyldig og unik.


Koble til skriveren med en USB-kabel

Hvis du valgte Koble til med USB-kabel, oppretter operativsystemet skriverobjektet som standard. Skriverobjektnavnet må samsvare med det som ble opprettet av operativsystemet.

Merk:

  • Brukeren må sette i USB-kabelen for å fullføre installeringen og opprette skriverobjektet.
  • Når du har koblet til skriveren gjennom USB-porten, må brukeren starte Statussenter manuelt.


Legge til en nettverksskriver

Bruk dialogboksen Legg til skriver for å søke etter skriveren eter skrivernavn, IP-adresse eller delnett. Finn skriveren, og legg den deretter til manuelt i listen over tilgjengelige nettverksskrivere.

Merk: Du må kjenne navnet og IP-adressen til skriveren samt hvilket delnett den tilhører. Du får tilgang til denne informasjonen ved å skrive ut en oppsettside for nettverk. Du finner mer informasjon i brukerhåndboken.

Ved hjelp av skrivernavnet og IP-adressen

Skriv inn navnet eller IP-adressen til skriveren, og klikk på OK.

Ved hjelp av delnettadressen

Hvis skriveren og utskriftsserveren befinner seg i et annet nettverk (delnett), finner du tilgjengelige skrivere ved å angi delnettet for skriveren du ønsker tilgang til.

  • Du legger inn en delnettadresse ved å skrive inn adressen i feltet som er angitt, og deretter klikke på Legg til > OK.

    Merk: Du har også muligheten til å søke etter flere delnettadresser.

  • Hvis du ønsker å fjerne en delnettadresse, velger du delnettadressen i listen over delnettene som er oppdaget, og klikker deretter på Fjern.


Forstå porttyper

Merk: Noen porter er bare tilgjengelige på enkelte skrivermodeller.
Porttyper | Beskrivelse
Ekstern utskriftsserver | Dette er en ekstern enhet som gir muligheter for nettverkstilgang gjennom Ethernet-porter.
LPR (Line Printer Remote) | Dette er en protokoll som brukes til å sende utskriftsjobber til en ekstern skriver.
Utskriftsserver | Dette er datamaskinen eller enheten som er koblet til én eller flere skrivere og til klientmaskiner gjennom et nettverk. Den kan ta imot utskriftsjobber fra datamaskiner og sende utskriftsjobber til aktuelle skrivere.
Standard TCP/IP (Transmission Control Protocol/Internet Protocol) | Dette er en protokoll som definerer regelen datamaskiner må følge når de kommuniserer med hverandre gjennom Internett.
UNC (Universal Naming Convention) | Dette er standarden for identifisering av servere, skrivere og andre ressurser i et nettverk uten kartlegging av nettverksstasjonen. Hver enkelt ressurs blir tilordnet en unik adresse. Dermed kan operativsystemer som støtter UNC, gjøre en fullstendig spesifikasjon av en katalog på en filserver.


Starte Statussenter manuelt

Merk: Kontroller at skriveren og datamaskinen er koblet sammen med en USB-kabel.

Windows 8

Fra Søk skriver du statussenter og navigerer til:

App-listen > Statussenter

Windows 7 og tidligere versjoner

  1. Klikk på [image] eller Start.

  2. Klikk på Alle programmer eller Programmer, og velg deretter mappen for skriverprogrammet i listen.

  3. Klikk på Startside > Statussenter.

Statussenter åpnes.

Merk:

  • Statussenter er bare tilgjengelig hvis du har valgt å inkludere det under konfigurasjonen av pakken.
  • Hvis du valgte å ikke starte Statussenter manuelt etter at skriverobjektet ble opprettet, vil Statussenter starte automatisk neste gang datamaskinen starter på nytt.


Angi en port ved hjelp av kommandolinjen

Du kan angi portnavnet og portadressen på kommandolinjen under installasjonen ved å velge Angi port ved installasjon gjennom kommandolinjen.

Parameter | Verdi | Eksempel
/port: | Portnavn | /port:portnavn
/adresse: | Nettverksnavnet eller IP-adressen til skriveren | /adresse:123.123.123.123 /adresse:nettverksnavn

Eksempel på kommandolinje: LexmarkPkgInstall.exe /port:portnavn /adresse:123.123.123.123

Merk:

  • LexmarkPkgInstall.exe returnerer 0 etter en vellykket installasjon.
  • Angi porten og adresseparametrene for å starte installasjonen på en vellykket måte.
  • Portnavnet og -adressen du har angitt tas i bruk på alle skriverobjektene i pakken som er konfigurert til å bli angitt under installasjonen. For skriverobjekter som blir tildelt porter når pakken opprettes, blir porten som ble valgt da pakkingen fant sted, beholdt.
  • Kommandolinjeparametrene for portnavn og -adresse behandles bare hvis pakken ble konfigurert til å godta portnavnet og -adressen på kommandolinjen. Hvis disse parametrene overføres til en pakke som ikke skal motta denne informasjonen på kommandolinjen, fortsetter installasjonen, men disse parametrene blir oversett. Portene blir opprettet på grunnlag av informasjon i pakken, og ikke fra parametrene på kommandolinjen. En advarsel utstedes til ledeteksten. I slike tilfeller er returkoden 0 fordi installasjonen var vellykket.


Hva er et portnavn?

Portnavnet er et unikt navn som er tilordnet en port på datamaskinen hvor skriveren er tilkoblet.


Hvorfor vises ikke skriveren min på listen?

Kontroller at datamaskinen og skriveren er koblet til det samme trådløse nettverket

Det kan hende at skriveren ikke er i det samme trådløse nettverket som datamaskinen. Hvis datamaskinen er koblet til det trådløse nettverket, må SSID-navnet til skriveren stemme overens med SSID-navnet til datamaskinen.

  1. Finn SSID-navnet på nettverket som datamaskinen er koblet til.

    1. Angi IP-adressen til tilgangspunktet (den trådløse ruteren) i adressefeltet i nettleseren.

      Hvis du ikke vet IP-adressen til tilgangspunktet, må du gjøre følgende:

      Windows 8

      Fra Søk skriver du Kjør og navigerer til:

      App-listen > Kjør > skriv cmd > OK > skriv ipconfig

      Windows 7 og tidligere versjoner

      1. Klikk på [image] eller Start og klikk deretter Kjør.

      2. Skriv cmd i tekstboksen Start søk eller åpne.

      3. Trykk på Enter eller klikk OK, og skriv deretter ipconfig.

      Merk:

      • Verdien for Standard gateway er som regel IP-adressen til tilgangspunktet, men kontroller at den hører inn under Trådløse nettverkstilkoblinger i ipconfig-informasjonen.
      • IP-adressen vises som fire grupper med tall adskilt av punktum, for eksempel 123.123.123.123.

    2. Trykk på Enter eller Fortsett.

    3. Angi brukernavnet og passordet for tilgangspunktet når du blir bedt om det, og klikk på OK.

    4. Se etter SSID-navnet under Trådløs.

    5. Skriv ned SSID-navnet.

      Merk: Pass på at du skriver navnet nøyaktig slik det vises og at du skiller mellom store og små bokstaver.

  2. Finn SSID-navnet til nettverket som skriveren er koblet til:

    1. Skriv ut en oppsettside for nettverk fra skriveren.

      Du finner mer informasjon i brukerhåndboken.

    2. Se etter SSID under Trådløs.

  3. Sammenlign SSID-navnet på datamaskinen med SSID-navnet på skriveren.

    Hvis SSID-navnene er identiske, er datamaskinen og skriveren koblet til det samme trådløse nettverket.

    Hvis SSID-navnene ikke er identiske, må du kjøre verktøyet for oppsett av trådløs tilkobling for å konfigurere skriveren i det trådløse nettverket som datamaskinen er koblet til. Kontroller at du velger SSID-navnet som datamaskinen bruker.

Kontroller at datamaskinen ikke er koblet til et virtuelt privat nettverk (VPN)

I de fleste virtuelle private nettverk kan datamaskiner ikke kommunisere med andre nettverk samtidig. Koble datamaskinen fra det virtuelle private nettverket før du installerer driveren, eller før du kjører verktøyet for oppsett av trådløs tilkobling.

Du kan kontrollere om datamaskinen er koblet til et virtuelt privat nettverk ved å åpne VPN-klienten og kontrollere VPN-tilkoblingene. Hvis du ikke har installert en VPN-klient, må du kontrollere tilkoblingene manuelt ved å bruke VPN-klienten i Windows.

Hvis du vil koble deg til lokalnettet og et virtuelt privat nettverk samtidig, må du be systemadministratoren for VPN om å tillate "split tunneling". Vær oppmerksom på at ikke alle organisasjoner tillater "split tunneling" av sikkerhetshensyn eller på grunn av tekniske begrensninger.

Kontroller at tredjepartsprogrammer ikke blokkerer skriveren

Det kan hende at tredjepartsprogrammer, inkludert antivirus-, sikkerhets- og brannmurprogrammer, blokkerer registreringen av skriveren. Konfigurer innstillingene for programmet slik at det ikke blokkerer skriveren, og oppdater deretter nettverkslisten.


Valg av tilleggsprogramvare

Vær oppmerksom på følgende når du velger tilleggsprogramvare:

  • Den valgte programvaren vil bli inkludert i den genererte pakken og installert på brukerens system i den angitte katalogen under installasjonen.

  • Sørg for at du bruker samme installasjonsbane når du distribuerer senere pakker for å sikre at bare én versjon av programmet er installert, og at dette er den nyeste versjonen.

  • Enkelte filer kan bli installert enten i x86-katalogen eller på 64-bitsystemet, avhengig av hvilket operativsystem som brukes.

  • Listen over programmer kan variere avhengig av skrivermodellen.


Åpne den genererte pakken

Gjør ett av følgende:

  • Bruk påloggingsskriptene i operativsystemet.

  • Del pakkene og få brukerne til å åpne dem.

Merk: Sørg for at du har administratorrettigheter for å utføre installeringen.


Hjelp for Pakkebygger