Informacje o pomocy Narzędzia do tworzenia pakietów

Co to jest Narzędzie do tworzenia pakietów?


Co to jest Narzędzie do tworzenia pakietów?

Narzędzie do tworzenia pakietów umożliwia tworzenie własnych pakietów instalacyjnych, które można uruchomić bez interwencji użytkownika i zintegrować z rozwiązaniem instalacji. Jest to narzędzie generujące pakiety instalacyjne sterownika, które automatyzują instalację sterowników drukarek za pomocą wstępnie skonfigurowanych opcji łączności i drukowania.


Konfiguracja pakietu instalacyjnego

Uwagi:

  • Pliki w formatach .cab i .exe są generowane w określonej lokalizacji.
  • Zawartość pakietu zależy od wybranych opcji.
  • Niektóre funkcje są dostępne tylko w przypadku wybranych modeli drukarek.

Wybór zawartości pakietu

Po wyświetleniu sekcji „Opcje zawartości pakietu” wybierz co najmniej jedną z następujących opcji:

  • Uwzględnij sterowniki drukarek i/lub faksów

  • Uwzględnij sterowniki skanera i/lub dodatkowe oprogramowanie

  • Obsługa tylko jednego języka

    Uwaga: Domyślnie w wygenerowanym pakiecie zawarte są wszystkie języki obsługiwane przez produkt. Aby zmniejszyć rozmiar pakietu, wybierz opcję Obsługa tylko jednego języka, a następnie wybierz odpowiedni język.

Wybierz opcje pakietu dostępne podczas instalacji

Po wyświetleniu sekcji „Opcje pakietu podczas instalacji” wykonaj jedną z następujących czynności:

  • Aby ukryć stan instalacji, wybierz opcję Silent installation (Instalacja w trybie cichym).

  • Aby wyświetlić stan instalacji oraz umowę licencyjną, wybierz opcję Display installation status to the user (Wyświetlaj stan instalacji użytkownikowi), a następnie wybierz opcję Include the license agreement (Dołącz umowę licencyjną).

    Uwaga: Użytkownik musi zaakceptować umowę licencyjną przed zainstalowaniem pakietu.

  • Aby wyświetlić stan instalacji oraz monitować użytkownika o wybór portu, wybierz opcję Display installation status to the user (Wyświetlaj stan instalacji użytkownikowi), a następnie wybierz opcję Prompt user for port selection (Monituj użytkownika o wybór portu).

    Uwaga: Użytkownik musi wybrać port podczas instalowania wygenerowanego pakietu.


Konfigurowanie sterownika drukarki

Opis nazwy drukarki

Udostępnianie drukarki

Identyfikowanie innych dostępnych sterowników

Interpretacja pliku konfiguracyjnego sterownika

Korzystanie z ustawień konfiguracyjnych


Opis nazwy drukarki

Domyślnie nazwą drukarki jest nazwa jej modelu. Jest ona również znana jako nazwa obiektu drukarki, który jest tworzony po instalacji. Obiekt drukarki reprezentuje rzeczywistą drukarkę, której można przypisać zadanie drukowania. Obiekt drukarki musi mieć unikatową nazwę umożliwiającą jej prawidłową identyfikację w sieci.

Uwagi:

  • Aby ustawić obiekt drukarki jako drukarkę domyślną, wybierz polecenie Ustaw jako drukarkę domyślną.
  • Aby umożliwić aplikacji wykrycie nazwy obiektu drukarki podczas instalacji, wybierz opcję Wykryj nazwę drukarki. Dostępność tej opcji zależy od modelu zakupionej drukarki.


Udostępnianie drukarki

Zaznacz pole wyboru Udostępnij drukarkę, a następnie wprowadź następujące informacje:

  • Nazwa udziału — nazwa widoczna dla innych użytkowników podczas wskazywania udostępnionej drukarki.

  • Komentarze — dodatkowe uwagi o udostępnionej drukarce. To pole jest opcjonalne.

  • Lokalizacja — określa lokalizację udostępnionej drukarki. To pole jest opcjonalne.

Uwaga: Upewnij się, że opcja udostępniania plików i drukarek jest włączona.


Identyfikowanie innych dostępnych sterowników

Z naszej witryny sieci Web można pobrać uniwersalne sterowniki drukarek (PCL 5, PCL XL, PS oraz XPS). Odszukaj model drukarki, aby wyświetlić zgodne z nim sterowniki.


Interpretacja pliku konfiguracyjnego sterownika

Plik konfiguracyjny sterownika (DCF) to plik, w którym zapisano ustawienia drukarki oraz inne dane. Pliki DCF mają w nazwie rozszerzenie .ldc.

Podczas korzystania z Narzędzia do tworzenia pakietów użytkownik wybiera plik DCF zawierający konfiguracje, których chce użyć do utworzenia obiektu drukarki. Poszczególne konfiguracje w pliku DCF są identyfikowane na podstawie opisu.

Plik DCF może zawierać jedną konfigurację dla dowolnej liczby modeli drukarek i dowolnej liczby różnych sterowników (emulacji PostScript lub PCL dla systemów Windows).

Uwaga: Narzędzie konfiguracji sterownika wymaga programu Microsoft XML Core Services (MSXML) 6. Możesz go pobrać z witryny www.microsoft.com.


Korzystanie z ustawień konfiguracyjnych

  1. W sekcji Ustawienia konfiguracji wybierz opcję Korzystaj z konfiguracji w celu zastosowania ustawień.

    1. Jeśli chcesz użyć istniejącego pliku konfiguracji, kliknij polecenie Załaduj plik.

    2. Jeśli chcesz utworzyć nowy plik konfiguracji, wykonaj następujące czynności:

      1. Kliknij opcję Nowy.

      2. Wybierz dane konfiguracji, którą chcesz utworzyć.

      3. Kliknij przycisk Zakończ i zapisz ustawienia.

        4. Uwaga: Jeśli chcesz zastosować tę samą konfigurację do wszystkich kolejek drukowania tworzonych od tej pory, wybierz opcję Zastosuj do wszystkich przyszłych instalacji. W przeciwnym wypadku ta konfiguracja będzie stosowana tylko dla tego obiektu drukarki.

  2. Kliknij przycisk OK.


Konfigurowanie podłączenia drukarki

Wybór drukarki z wykrytego portu

Podłączanie drukarki przy użyciu kabla USB

Dodawanie drukarki sieciowej

Informacje o typach portów

Ręczne uruchamianie programu Status Messenger (Komunikator stanu)

Określanie portu przy użyciu wiersza polecenia

Co to jest nazwa portu?

Dlaczego mojej drukarki nie ma na liście?


Wybór drukarki z wykrytego portu

  1. Jeśli wybierzesz opcję ustanowienia połączenia drukarki przez wykryty port, uzyskaj następujące informacje:

    Informacje o drukarce

    Opis

    W pełni kwalifikowana nazwa domeny (w sekcji TCP/IP)

    Obejmuje nazwę drukarki oraz sieci, do której jest podłączona drukarka. Jest to również nazwa drukarki.

    Adres IP (w sekcji TCP/IP)

    Jest to unikatowy numer, na podstawie którego drukarka komunikuje się z innymi urządzeniami w sieci i je lokalizuje.

    UAA (MAC) (w sekcji Standardowa karta sieciowa)

    Jest to unikatowy numer identyfikacyjny sprzętu, który odróżnia drukarkę od innego urządzenia w sieci.

    Nazwa konfiguracji zerowej (w sekcji TCP/IP)

    Wskazuje, że drukarka obsługuje tryb zeroconf, czyli pracę w sieci przy zerowej konfiguracji.

    Uwaga: Jeśli nie masz wymaganych informacji, wydrukuj stronę konfiguracji sieci. Więcej informacji można znaleźć w Podręczniku użytkownika.

  2. Wybierz drukarkę z listy, a następnie kliknij przycisk Kontynuuj.

  3. Jeśli drukarki nie ma na liście, spróbuj wykonać jedną lub kilka z następujących czynności:

    • Odśwież listę drukarek.

    • Kliknij opcję Modyfikuj wyszukiwanie, aby dodać drukarkę ręcznie przy użyciu zaawansowanych ustawień sieci.

    • Kliknij opcję Konfiguruj sieć bezprzewodową, aby dodać drukarkę podłączoną do sieci bezprzewodowej.

    • Kliknij opcję Określ port, aby dodać drukarkę ręcznie przy użyciu portów.

    • Upewnij się, że aplikacje innych firm nie blokują drukarki.

    • Upewnij się, że komputer nie jest podłączony do wirtualnej sieci prywatnej (VPN).

    • Upewnij się, że zarówno komputer, jak i drukarka są podłączone do tej samej sieci.

    • Upewnij się, że drukarka ma przypisany prawidłowy, unikatowy adres IP.


Podłączanie drukarki przy użyciu kabla USB

Po wybraniu opcji Podłącz przy użyciu kabla USB system operacyjny domyślnie tworzy obiekt drukarki. Nazwa obiektu drukarki powinna zgadzać się z nazwą utworzoną przez system operacyjny.

Uwagi:

  • Aby zakończyć instalację i utworzyć obiekt drukarki, użytkownik musi podłączyć kabel USB.
  • Po podłączeniu drukarki przy użyciu portu USB użytkownik musi ręcznie uruchomić program Status Messenger (Komunikator stanu).


Dodawanie drukarki sieciowej

Korzystając z okna dialogowego dodawania drukarki sieciowej, można wyszukać drukarki według ich nazwy, adresu IP lub podsieci. Po znalezieniu swojej drukarki można ją ręcznie dodać do listy dostępnych drukarek sieciowych.

Uwaga: Upewnij się, że znasz nazwę i adres IP drukarki, a także podsieć, w której się znajduje. Aby uzyskać te informacje, wydrukuj stronę konfiguracji sieci. Więcej informacji można znaleźć w Podręczniku użytkownika.

Użycie nazwy i adresu IP drukarki

Wpisz nazwę lub adres IP drukarki, a następnie kliknij przycisk OK.

Użycie adresu podsieci

Jeśli drukarka i serwer druku znajdują się w innej sieci (tzw. podsieci), dostępne drukarki można wyszukać, określając adres podsieci drukarki, z którą ma zostać nawiązane połączenie.

  • Aby dodać adres podsieci, w odpowiednim polu wpisz adres podsieci, a następnie kliknij kolejno opcje Dodaj > OK.

    Uwaga: Można również wyszukać więcej adresów podsieci.

  • Aby usunąć adres podsieci, zaznacz go na liście wykrytych podsieci, a następnie kliknij przycisk Usuń.


Informacje o typach portów

Uwaga: Niektóre porty mogą być dostępne tylko w przypadku wybranych modeli drukarek.
Typy portów | Opis
Zewnętrzny serwer druku | Jest to urządzenie zewnętrzne, które umożliwia dostęp do sieci za pośrednictwem portów Ethernet.
LPR (Line Printer Remote) | Jest to protokół stosowany do wysyłania zadań drukowania do drukarki zdalnej.
Serwer druku | Jest to komputer lub urządzenie podłączone do jednej lub kilku drukarek oraz do komputerów klienckich w sieci. Może przyjmować zadania drukowania z komputerów i wysyłać je do odpowiednich drukarek.
Standardowy protokół TCP/IP (Transmission Control Protocol/Internet Protocol) | Jest to protokół określający reguły, według których komputery komunikują się między sobą w Internecie.
UNC (Universal Naming Convention) | Jest to standard uniwersalnej konwencji nazw, służący do identyfikacji serwerów, drukarek i innych zasobów w sieci bez mapowania dysku sieciowego. Zapewnia każdemu udostępnionemu zasobowi unikatowy adres. Dzięki temu systemy operacyjne obsługujące standard UNC mogą dokładnie określić katalog na serwerze plików.


Ręczne uruchamianie programu Status Messenger (Komunikator stanu)

Uwaga: Upewnij się, że drukarka jest podłączona do komputera za pomocą kabla USB.

W systemie Windows 8

W panelu wyszukiwania wpisz komunikator stanu i przejdź kolejno do:

listy aplikacji > Komunikator stanu

W systemie Windows 7 lub starszym

  1. Kliknij przycisk [image] lub przycisk Start.

  2. Kliknij polecenie Wszystkie programy lub Programy, a następnie wybierz z listy folder programu drukarki.

  3. Kliknij kolejno opcje Strona główna drukarki > Komunikator stanu.

Zostanie otwarte okno programu Status Messenger (Komunikator stanu).

Uwagi:

  • Program Status Messenger jest dostępny tylko jeśli został wybrany podczas konfiguracji pakietu.
  • Jeśli nie wybrano opcji ręcznego uruchomienia programu Komunikator stanu po utworzeniu obiektu drukarki, jest on uruchamiany automatycznie po ponownym uruchomieniu komputera.


Określanie portu przy użyciu wiersza polecenia

Nazwę i adres portu można wskazać podczas instalacji w wierszu polecenia, wybierając opcję Specify the port at install time through the command line (Określ port podczas instalacji w wierszu polecenia).

Parametr | Wartość | Przykład
/port: | Nazwa portu | /port:nazwa_portu
/address: | Nazwa sieciowa lub adres IP drukarki | /address:123.123.123.123 /address:nazwa_sieci

Przykładowy wiersz polecenia: LexmarkPkgInstall.exe /port:nazwa_portu /address:123.123.123.123

Uwagi:

  • Po poprawnej instalacji proces LexmarkPkgInstall.exe zwraca wartość 0.
  • Określ parametry portu i adresu, aby prawidłowo rozpocząć instalację.
  • Określony adres i nazwa portu są stosowane do wszystkich obiektów drukarek w pakiecie, które są określane podczas instalacji. Dla obiektów drukarek, którym przypisywane są porty podczas tworzenia pakietu, używane są porty wybrane podczas tworzenia pakietu.
  • Parametry wiersza polecenia określające nazwę i adres portu są przetwarzane tylko w przypadku, gdy miały być akceptowane przez ten pakiet. Jeśli parametry są przekazywane do pakietu, który nie ma ich otrzymywać, instalacja przebiega nadal, ale parametry są instalowane. Porty są tworzone na podstawie informacji w pakiecie, a nie parametrów z wiersza polecenia. W wierszu polecenia zostanie wyświetlone ostrzeżenie. W takim przypadku zwracany jest kod 0, ponieważ instalacja została zakończona pomyślnie.


Co to jest nazwa portu?

Nazwa portu to unikatowa nazwa przypisana portowi w komputerze, do którego jest podłączona drukarka.


Dlaczego mojej drukarki nie ma na liście?

Upewnij się, że zarówno komputer, jak i drukarka są podłączone do tej samej sieci bezprzewodowej.

Drukarka może nie znajdować się w tej samej sieci bezprzewodowej, co komputer. Jeśli komputer jest już podłączony do sieci bezprzewodowej, identyfikator SSID drukarki musi być zgodny z identyfikatorem SSID komputera.

  1. Uzyskaj identyfikator SSID sieci, do której jest podłączony komputer.

    1. Wprowadź adres IP punktu dostępu (routera bezprzewodowego) w polu adresu strony sieci Web w przeglądarce.

      Jeśli nie znasz adresu IP punktu dostępu, wykonaj następujące czynności:

      W systemie Windows 8

      W panelu wyszukiwania wpisz uruchom i przejdź kolejno do:

      listy aplikacji > Uruchom > wpisz polecenie cmd > OK > wpisz polecenie ipconfig

      W systemie Windows 7 lub starszym

      1. Kliknij przycisk [image] lub przycisk Start, a następnie kliknij polecenie Uruchom.

      2. W polu Rozpocznij wyszukiwanie lub Uruchom wpisz polecenie cmd.

      3. Naciśnij klawisz Enter lub kliknij przycisk OK, a następnie wpisz polecenie ipconfig.

      Uwagi:

      • Wpis „Brama domyślna” dotyczy zazwyczaj punktu dostępu, ale należy się upewnić, że znajduje się on w sekcji „Połączenie sieci bezprzewodowej”.
      • Adres IP ma postać czterech liczb oddzielonych kropkami, np. 123.123.123.123.

    2. Naciśnij klawisz Enter lub opcję Przejdź.

    3. Po pojawieniu się monitu wpisz nazwę i hasło użytkownika punktu dostępu, a następnie kliknij przycisk OK.

    4. W obszarze ustawień sieci bezprzewodowej znajdź identyfikator SSID.

    5. Zanotuj identyfikator SSID.

      Uwaga: Upewnij się, że kod jest zanotowany poprawnie, z uwzględnieniem wielkości liter.

  2. Uzyskaj identyfikator SSID sieci, do której jest podłączona drukarka:

    1. Wydrukuj na drukarce stronę konfiguracji sieci.

      Więcej informacji można znaleźć w Podręczniku użytkownika.

    2. W sekcji Komunikacja bezprzewodowa odszukaj identyfikator SSID.

  3. Porównaj identyfikatory SSID komputera i drukarki.

    Jeśli identyfikatory SSID są takie same, oznacza to, że zarówno komputer, jak i drukarka są podłączone do tej samej sieci bezprzewodowej.

    Jeśli identyfikatory SSID nie są takie same, uruchom ponownie Narzędzie konfiguracji bezprzewodowej, aby skonfigurować drukarkę do pracy w sieci bezprzewodowej używanej przez komputer. Upewnij się, że wybrano identyfikator SSID używany przez komputer.

Upewnij się, że komputer nie jest podłączony do wirtualnej sieci prywatnej (VPN)

W przypadku większości sieci VPN komputer może komunikować się wyłącznie z siecią VPN; nie jest możliwa komunikacja w tym samym czasie z innymi sieciami. Przed zainstalowaniem sterownika na komputerze lub przed rozpoczęciem konfiguracji sieci bezprzewodowej odłącz się od sieci VPN.

Aby sprawdzić, czy komputer jest w danym momencie podłączony do sieci VPN, otwórz oprogramowanie klienckie VPN, a następnie sprawdź połączenia VPN. Jeśli oprogramowanie klienckie VPN nie jest zainstalowane, sprawdź połączenia ręcznie, używając klienta VPN systemu Windows.

Aby możliwe było uzyskanie połączenia w tym samym czasie z siecią lokalną i z siecią VPN, poproś osobę odpowiedzialną za obsługę techniczną sieci VPN o zezwolenie na dzielone tunelowanie. Należy pamiętać, że niektóre instytucje nie zezwalają na używanie funkcji dzielonego tunelowania ze względów technicznych lub związanych z bezpieczeństwem.

Upewnij się, że aplikacje innych firm nie blokują drukarki

Aplikacje innych firm, w tym programy antywirusowe, ochronne i zapory mogą blokować wykrywanie drukarki. Aby odblokować drukarkę, należy skonfigurować ustawienia aplikacji, a następnie odświeżyć listę sieci.


Wybór dodatkowego oprogramowania

Podczas wybierania dodatkowego oprogramowania należy zwrócić uwagę na następujące kwestie:

  • Wybrane oprogramowanie będzie zawarte w wygenerowanym pakiecie i zainstalowane w systemie użytkownika w określonym katalogu podczas instalacji.

  • Upewnij się, że podczas instalacji kolejnego pakietu używasz tej samej ścieżki instalacyjnej, aby istniała tylko jedna kopia zainstalowanej aplikacji i była to jej najnowsza wersja.

  • W zależności od używanego systemu operacyjnego niektóre pliki mogą być instalowane w katalogu x86 lub w 64-bitowym systemie operacyjnym.

  • Lista oprogramowania może się różnić w zależności od modelu drukarki.


Uruchamianie wygenerowanego pakietu

Wykonaj jedną z następujących czynności:

  • Użyj skryptów logowania systemu operacyjnego.

  • Udostępnij pakiety, aby zostały włączone przez innych użytkowników.

Uwaga: Upewnij się, że masz wystarczające uprawnienia administratora, aby przeprowadzić instalację.


Narzędzie do tworzenia pakietów — pomoc