Sobre a Ajuda do Criador de pacote

O que é um Criador de pacote?


O que é um Criador de pacote?

Use o Criador de pacote para criar pacotes de instalação que podem ser iniciados sem a intervenção do usuário e, também, podem ser integrados à sua solução de implementação. É a ferramenta que gera pacotes de instalação de drivers para automatizar a instalação de drivers de impressora com conectividade preconfigurada e opções de impressão.


Configurando o pacote de instalação

Notas:

  • São gerados arquivos nos formatos .cab e .exe no local especificado.
  • O conteúdo do pacote depende das opções selecionadas.
  • Alguns desses recursos estão disponíveis somente em modelos de impressora selecionados.

Selecionar o conteúdo do pacote

Na seção "Opções de conteúdo do pacote", selecione uma ou mais destes itens:

  • Incluir drivers de impressoras e/ou fax

  • Incluir drivers de digitalização e/ou software adicional

  • Suporte somente um único idioma

    Nota: Por padrão, todos os idiomas suportados pelo produto são incluídos no pacote gerado. Para reduzir o tamanho do pacote, selecione Suporta um único idioma apenas e escolha o idioma apropriado.

Escolha as opções de pacote disponíveis durante a instalação.

Na seção "Opções de tempo de instalação do pacote", execute uma das seguintes ações:

  • Para ocultar o status de instalação, selecione Instalação silenciosa.

  • Para exibir o status de instalação com o acordo de licença, selecione Exibir o status de instalação ao usuário e selecione Incluir o acordo de licença.

    Nota: O usuário deve aceitar o acordo de licença para instalar o pacote.

  • Para exibir o status de instalação e solicitar que o usuário selecione a porta, selecione Exibir o status de instalação ao usuário e Solicitar que o usuário selecione a porta.

    Nota: O usuário deve selecionar a porta durante a instalação do pacote gerado.


Configurando o driver de impressão

Entendendo o nome da impressora

Compartilhando a impressora

Identificando outros drivers disponíveis

Entendendo o arquivo de configuração de driver

Usando definições de configuração


Entendendo o nome da impressora

Por padrão, o nome da impressora é o nome do modelo. Ele também é conhecido como o nome de objeto da impressora que é criado após a instalação. Um objeto de impressora representa a impressora real para a qual um trabalho de impressão pode ser atribuído. Verifique se o objeto de impressora tem um nome exclusivo para identificar a impressora correta na rede.

Notas:

  • Para definir o objeto de impressora como a impressora padrão, selecione Definir como impressora padrão.
  • Para deixar o aplicativo detectar o nome de objeto da impressora durante a instalação, selecione Detectar nome da impressora. Essa opção pode não estar disponível, dependendo do modelo da impressora que você adquiriu.


Compartilhando a impressora

Selecione a caixa de seleção Compartilhar a impressora e digite as seguintes informações:

  • Nome de compartilhamento — o nome que os demais usuários vêem ao indicarem a impressora compartilhada.

  • Comentários — qualquer nota adicional sobre a impressora compartilhada. Isso é opcional.

  • Local — indica o local da impressora compartilhada. Isso é opcional.

Nota: Certifique-se de que o arquivo esteja aberto e a impressora compartilhada esteja ligada.


Identificando outros drivers disponíveis

Os drivers de impressão universal (emulação PCL 5, PCL X e PS) podem ser obtidos por download em nosso site na Internet. Procure o modelo de sua impressora para exibir os drivers compatíveis.


Entendendo o arquivo de configuração de driver

Um arquivo de configuração de driver (DCF) é um arquivo que armazena as definições salvas da impressora e outros dados. Os DCFs usam a extensão de arquivo .ldc.

Ao usar o Criador de pacote, selecione o DCF que contém as configurações que deseja usar para criar um objeto de impressora. A configuração individual de um DCF é identificada por uma descrição.

Um DCF pode conter uma configuração para qualquer número de modelos de impressora e de drivers diferentes (emulações PostScript ou PCL para Windows).

Nota: O Utilitário de configuração de driver necessita do Microsoft XML Core Services (MSXML) 6. Para fazer o download do mesmo, visite www.microsoft.com.


Usando definições de configuração

  1. Na seção Definições de configuração, selecione Usar uma configuração para aplicar definições.

    1. Para usar um arquivo de configuração existente, clique em Carregar arquivo.

    2. Para criar um novo arquivo de configuração, proceda da seguinte maneira:

      1. Clique em Novo.

      2. Selecionar os dados de configuração que deseja criar.

      3. Clique em Concluir e salve as definições.

        4. Nota: Se quiser aplicar a mesma configuração a todas as criações de fila de impressão subsequentes, selecione Aplicar a todas as futuras instalações. Caso contrário, a configuração será aplicada somente a este objeto de impressora.

  2. Clique em OK.


Configurando a conexão da impressora

Selecionando a impressora a partir de uma porta detectada.

Conectando a impressora com um cabo USB

Adicionando uma impressora de rede

Aprendendo sobre os tipos de portas

Iniciando o Mensageiro de status manualmente

Especificando uma porta usando uma linha de comando

O que é um nome de porta?

Por que minha impressora não está na lista?


Selecionando a impressora a partir de uma porta detectada.

  1. Se optar por estabelecer a conexão de impressora por uma porta detectada, obtenha as seguintes informações:

    Informações da impressora

    Descrição

    Nome de domínio totalmente qualificado (na seção TCP/IP)

    Isto inclui o nome da impressora e a rede à qual ela está conectada. Este também é o nome da impressora.

    Endereço IP (na seção TCP/IP)

    Este é um número exclusivo usado pela impressora para se comunicar e localizar outros dispositivos em uma rede.

    UAA (MAC) (na seção Placa de rede padrão)

    Este é o número de identificação de hardware exclusivo que distingue a impressora de outro dispositivo na rede.

    Nome da configuração zero (na seção TCP/IP)

    Isto indica se sua impressora oferece suporte à zeroconf ou à rede de configuração zero.

    Nota: Se você não tiver as informações necessárias, imprima uma página de configuração de rede. Para obter mais informações, consulte o Guia do usuário.

  2. Selecione sua impressora na lista e clique em Continuar.

  3. Se a impressora não estiver na lista, tente um ou mais dos seguintes procedimentos:

    • Atualize a lista de impressoras.

    • Clique em Modificar pesquisa para adicionar a impressora manualmente usando as definições avançadas de rede.

    • Clique em Configurar rede sem fio para adicionar uma impressora conectada a uma rede sem fio.

    • Clique em Especificar porta para adicionar a impressora manualmente usando as portas.

    • Verifique se os aplicativos de terceiros não estão bloqueando a impressora.

    • Verifique se o computador não está conectado a uma Rede Privativa Virtual (VPN).

    • Verifique se o computador e a impressora estão conectados a mesma rede.

    • Verifique se um endereço IP válido e único foi atribuído à impressora.


Conectando a impressora com um cabo USB

Se você tiver selecionado Conectar com um cabo USB, o sistema operacional cria o objeto de impressora por padrão. O objeto de impressora deve corresponder àquele criado pelo sistema operacional.

Notas:

  • O usuário deve inserir o cabo USB para concluir a instalação e criar o objeto de impressora.
  • Depois de conectar a impressora usando a porta USB, o usuário deve iniciar manualmente o Mensageiro de status.


Adicionando uma impressora de rede

Use a caixa de diálogo Adicionar impressora de rede para pesquisar as impressoras por nome da impressora, endereço IP ou sub-rede. Encontre a impressora e adicione-a manualmente à lista de impressoras de rede disponíveis.

Nota: Verifique se sabe o nome e endereço IP da impressora e a sub-rede à qual ela pertence. Para obter essas informações, imprima uma página de configuração de rede. Para obter mais informações, consulte o Guia do usuário.

Usando o nome da impressora e o endereço IP

Digite o nome ou endereço IP da impressora e clique em OK.

Usando o endereço de sub-rede

Se a impressora e o servidor de impressão estiverem localizados em outra rede (chamada de sub-rede), encontre as impressoras disponíveis especificando a sub-rede da impressora que deseja acessar.

  • Para adicionar um endereço de sub-rede, digite o endereço de sub-rede no campo especificado e, em seguida, clique em Adicionar > OK.

    Nota: Também é possível procurar vários endereços de sub-rede.

  • Para remover um endereço de sub-rede, destaque o endereço de sub-rede da lista de sub-redes descobertas e, em seguida, clique Remover.


Aprendendo sobre os tipos de portas

Nota: Algumas portas podem estar disponíveis somente em modelos de impressoras selecionados.
Tipos de porta | Descrição
Servidor de impressão externo | Este é um dispositivo externo que permite acesso à rede através de suas portas Ethernet.
LPR (Line Printer Remote) | Este é um protocolo usado para enviar trabalhos de impressão para uma impressora remota.
Servidor de impressão | Este é um computador ou dispositivo conectado a uma ou mais impressoras e a computadores cliente em rede. Ele pode aceitar trabalhos de impressão de computadores e enviar trabalhos para as impressoras apropriadas.
TCP/IP padrão (Transmission Control Protocol/Internet Protocol) | Este é um protocolo que define a regra que os computadores devem seguir para se comunicar entre si pela Internet.
UNC (Convenção de nomenclatura universal) | Este é um padrão para identificar servidores, impressoras e outros recursos em uma rede sem mapeamento da unidade de rede. Ele fornece um endereço exclusivo para cada recurso compartilhado. Isto permite que os sistemas operacionais que suportam o UNC especifiquem completamente um diretório em um servidor de arquivos.


Iniciando o Mensageiro de status manualmente

Nota: Certifique-se de que a impressora e o computador estejam conectados por um cabo USB.

No Windows 8

Na charm Pesquisas, digite mensageiro de status e, em seguida, navegue para:

Lista de aplicativos > Mensageiro de status

No Windows 7 ou anterior

  1. Clique em [image] ou em Iniciar.

  2. Clique em Todos os programas ou Programas e selecione a pasta de programas da impressora na lista.

  3. Clique em Página inicial da impressora > Mensageiro de status.

O Mensageiro de status será iniciado.

Notas:

  • O Mensageiro de status estará disponível somente se você tiver optado por incluí-lo durante a configuração do pacote.
  • Se optar por não iniciar o Mensageiro de status manualmente, depois que o objeto de impressão for criado, o Mensageiro de status será aberto automaticamente quando o computador for reiniciado.


Especificando uma porta usando uma linha de comando

Você pode indicar o nome e o endereço da porta na linha de comando durante a instalação ao selecionar Especifique a porta na hora da instalação na linha de comando.

Parâmetro | Valor | Exemplo
/port: | Nome da porta | /port:nome_da_porta
/address: | Nome da rede ou endereço IP da impressora | /address:123.123.123.123 /address:nome_da_rede

Exemplo de linha de comando: LexmarkPkgInstall.exe /port:nome_da_porta /address:123.123.123.123

Notas:

  • LexmarkPkgInstall.exe retornará 0 se a instalação for bem-sucedida.
  • Especifique os parâmetros de endereço e porta para iniciar a instalação de forma bem-sucedida.
  • O nome de porta e o endereço especificados são aplicados a todos os objetos de impressão do pacote especificados durante a instalação. Os objetos de impressora utilizam as portas que lhes são atribuídas durante a criação do pacote.
  • Os parâmetros de linha de comando para o nome ou endereço da porta são processados somente se o pacote tiver sido criado para aceitar o nome e o endereço da porta na linha de comando. Se esses parâmetros forem transmitidos ao pacote errado na linha de comando, a instalação continuará mas os parâmetros serão ignorados. As porta são criadas com base nas informações do pacote, e não dos parâmetros na linha de comando. Um aviso será exibido na linha de comando. Nesse caso, o código de retorno será 0 porque a instalação foi concluída com sucesso.


O que é um nome de porta?

O nome de porta é um nome exclusivo atribuído a uma porta no computador onde a impressora está conectada.


Por que minha impressora não está na lista?

Verifique se o computador e a impressora estão conectados à mesma rede sem fio

A impressora não deverá estar ligada na mesma rede sem fio que o computador. Se o computador já estiver conectado a uma rede sem fio, então o SSID da impressora deve corresponder ao SSID do computador.

  1. Obtenha o SSID da rede à qual o computador está conectado.

    1. Digite o endereço IP do ponto de acesso (roteador sem fio) no campo de endereço do navegador da Web.

      Se você não souber o endereço IP do ponto de acesso, faça o seguinte:

      No Windows 8

      Na charm Pesquisas, digite executar e, em seguida, navegue para:

      Lista de aplicativos > Executar > digite cmd > OK > digite ipconfig

      No Windows 7 ou anterior

      1. Clique em [image], ou clique em Iniciar e depois clique em Executar.

      2. Na caixa Iniciar pesquisa ou Executar, digite cmd.

      3. Pressione Enter ou clique em OK e digite ipconfig.

      Notas:

      • A entrada “Gateway padrão” é geralmente o ponto de acesso, mas verifique se ela pertence à seção “Conexão de rede sem fio” da informação ipconfig.
      • O endereço IP é exibido como quatro conjuntos de números separados por pontos, por exemplo 123.123.123.123.

    2. Pressione Enter ou Ir.

    3. Digite o nome de usuário e a senha para o ponto de acesso quando for solicitado e clique em OK.

    4. Na seção Definições sem fio, procure o SSID.

    5. Anote o SSID.

      Nota: copie o SSID corretamente, incluindo todas as letras maiúsculas.

  2. Obtenha o SSID da rede à qual a impressora está conectada:

    1. Na impressora, imprima uma página de configuração de rede.

      Para obter mais informações, consulte o Guia do Usuário'.

    2. Na seção Sem fio, procure o SSID.

  3. Compare o SSID do computador e o da impressora.

    Se os SSIDs forem os mesmos, o computador e a impressora estarão conectados à mesma rede sem fio.

    Se os SSIDs forem diferentes, execute o Utilitário de configuração sem fio novamente para configurar a impressora na rede sem fio usada pelo computador. Verifique se o SSID usado pelo computador está selecionado.

Verifique se o computador não está conectado a uma Rede Privativa Virtual (VPN)

A maior parte das VPNs não permite que os computadores se comuniquem com nenhuma outra rede ao mesmo tempo, apenas com a VPN. Desconecte da VPN antes de instalar o driver no computador ou antes de executar a configuração de rede sem fio no computador.

Para verificar se o computador está conectado atualmente à VPN, abra o software do cliente VPN e verifique suas conexões. Caso não tenha um software cliente do VPN instalado, verifique as conexões manualmente usando o cliente do VPN do Windows.

Para se conectar à rede local e a uma VPN ao mesmo tempo, solicite ao funcionário do suporte ao sistema da VPN que permita a divisão de túnel. Esteja ciente de que algumas organizações podem não permitir a divisão de túnel devido a preocupações técnicas ou com a segurança.

Verifique se os aplicativos de terceiros não estão bloqueando a impressora

Os aplicativos de terceiros, incluindo programas antivírus, de segurança e firewall, podem bloquear a descoberta da impressora. Configure as definições do aplicativo para desbloquear a impressora e atualize a lista de redes.


Selecionando software adicional

Ao selecionar o software adicional, observe o seguinte:

  • O software selecionado será incluído no pacote gerado e instalado no sistema do usuário, no diretório especificado durante a instalação.

  • Certifique-se de usar o mesmo caminho de instalação quando estiver instalando um próximo pacote, para assegurar que somente uma cópia do aplicativo esteja instalada e que ela será a versão mais atualizada.

  • O sistema operacional deve estar instalado no diretório x86 ou no sistema de 64 bits, dependendo do sistema operacional utilizado.

  • A lista de aplicativos de software varia de acordo com o modelo da impressora.


Iniciando o pacote gerado

Execute um dos seguintes procedimentos:

  • Use os scripts de login do sistema operacional.

  • Compartilhe os pacotes para que outros usuários possam usá-los.

Nota: Certifique-se de ter privilégios administrativos suficientes para fazer a instalação.


Ajuda do Criador de pacote