Despre ajutorul pentru Package Builder (Generator de pachete)

Ce este un Package Builder (Generator de pachete)?


Ce este un Package Builder (Generator de pachete)?

Package Builder (Generatorul de pachete) vă permite să creaţi pachete personalizate pentru programul de instalare, pe care le puteţi lansa fără a fi necesară intervenţia utilizatorului şi integra în soluţia dvs. de implementare. Este un instrument care generează pachete de instalare a driverelor, care automatizează instalarea driverelor de imprimantă cu opţiuni preconfigurate pentru conectivitate şi imprimare.


Configurarea pachetului de instalare

Note:

  • Fişierele în format .cab şi .exe sunt generate în locaţia specificată.
  • Conţinutul pachetului depinde de opţiunile selectate.
  • Unele dintre aceste caracteristici sunt disponibile numai pe anumite modele de imprimantă.

Selectarea conţinutului pachetului

Din secţiunea „Package content options” (Opţiuni pentru conţinutul pachetului), selectaţi una sau mai multe dintre următoarele:

  • Include print and/or fax drivers (Se includ drivere de imprimare şi/sau fax)

  • Include scan drivers and/or additional software (Se includ drivere de scanare şi/sau software suplimentar)

  • Support a single language only (Se acceptă numai o singură limbă)

    Notă: Implicit, toate limbile acceptate de produs sunt incluse în pachetul generat. Pentru a reduce dimensiunea pachetului, selectaţi Support a single language only (Se acceptă numai o singură limbă), apoi selectaţi limba dorită.

Selectarea opţiunilor pentru pachet disponibile în timpul instalării

Din secţiunea „Package install-time options” (Opţiuni pentru momentul de instalare a pachetului), efectuaţi una dintre următoarele acţiuni:

  • Pentru a ascunde starea de instalare, selectaţi Silent installation (Instalare în fundal).

  • Pentru a afişa starea instalării împreună cu acordul de licenţă, selectaţi Display installation status to the user (Se afişează utilizatorului starea de instalare), apoi selectaţi Include the license agreement (Se include acordul de licenţă).

    Notă: Utilizatorul trebuie să accepte acordul de licenţă pentru a instala pachetul.

  • Pentru a afişa starea instalării şi a solicita utilizatorului să aleagă un port, selectaţi Display installation status to the user (Se afişează utilizatorului starea de instalare), apoi selectaţi Prompt user for port selection (Se solicită utilizatorului să aleagă portul).

    Notă: Utilizatorul trebuie să aleagă portul la instalarea pachetului generat.


Configurarea driverului de imprimantă

Despre numele imprimantei

Partajarea imprimantei

Identificarea altor drivere disponibile

Despre Fişierul de configurare pentru drivere

Utilizarea setărilor de configuraţie


Despre numele imprimantei

În mod implicit, numele de imprimantă este numele modelului de imprimantă. Mai este cunoscut şi ca numele obiectului de tip imprimantă creat după instalare. Un obiect de tip imprimantă reprezintă imprimanta efectivă căreia îi poate fi atribuită o lucrare de imprimare. Asiguraţi-vă că obiectul de tip imprimantă are un nume unic pentru a identifica imprimanta corectă din reţea.

Note:

  • Pentru a seta obiectul de tip imprimantă ca imprimantă implicită, selectaţi Set as Default Printer (Setare ca imprimantă implicită).
  • Pentru a-i permite aplicaţiei să determine numele obiectului de tip imprimantă în timpul instalării, selectaţi Detect printer name (Detectare nume imprimantă). Este posibil ca această opţiune să nu fie disponibilă, în funcţie de modelul imprimantei achiziţionate.


Partajarea imprimantei

Bifaţi caseta de selectare Share the printer (Partajare imprimantă), apoi introduceţi următoarele informaţii:

  • Share Name (Nume folosit pentru partajare) - Numele pe care îl văd ceilalţi utilizatori când indică spre o imprimantă partajată.

  • Comments (Comentarii) - Orice observaţie suplimentară despre imprimanta partajată. Aceste informaţii sunt opţionale.

  • Location (Locaţie) - Indică locaţia imprimantei partajate. Aceste informaţii sunt opţionale.

Notă: Asiguraţi-vă că partajarea fişierelor şi a imprimantelor este activată.


Identificarea altor drivere disponibile

Driverele universale de imprimare (PCL 5, PCL XL, PS şi XPS) pot fi descărcate de pe site-ul nostru Web. Căutaţi modelul imprimantei pentru a vizualiza driverele compatibile.


Despre Fişierul de configurare pentru drivere

Un Fişier de configurare pentru drivere (Driver Configuration File, DCF) este un fişier care stochează setările de imprimantă salvate şi alte date. Fişierele DCF au extensia .ldc.

La utilizarea Package Builder (Generatorului de pachete), selectaţi fişierul DCF care conţine configuraţiile pe care doriţi să le utilizaţi pentru crearea obiectului de tip imprimantă. Configuraţia individuală a unui DCF este identificată printr-o descriere.

Un DCF poate conţine o configuraţie pentru un număr nelimitat de modele de imprimantă şi un număr nelimitat de drivere diferite (emulare PostScript sau PCL pentru Windows).

Notă: Driver Configuration Utility (Utilitarul de configurare a driverelor) necesită Microsoft XML Core Services (MSXML) 6. Îl puteţi descărca de la www.microsoft.com.


Utilizarea setărilor de configuraţie

  1. Din secţiunea Configuration Settings (Setări de configuraţie), selectaţi Use a configuration to apply settings (Se utilizează o configuraţie pentru aplicarea setărilor).

    1. Dacă doriţi să utilizaţi un fişier de configuraţie existent, faceţi clic pe Load File (Încărcare fişier).

    2. Dacă doriţi să creaţi un fişier de configuraţie nou, urmaţi aceste instrucţiuni:

      1. Faceţi clic pe New (Nou).

      2. Selectaţi datele de configuraţie pe care doriţi să le creaţi.

      3. Faceţi clic pe Finish (Terminare), apoi salvaţi setările.

        4. Notă: Dacă doriţi să aplicaţi aceeaşi configuraţie tuturor cozilor de imprimare create ulterior, selectaţi Apply to all future installations (Se aplică tuturor instalărilor ulterioare). În caz contrar, configuraţia se va aplica numai pentru acest obiect de tip imprimantă.

  2. Faceţi clic pe OK.


Configurarea conexiunii la imprimantă

Selectarea imprimantei dintr-un port descoperit

Conectarea imprimantei printr-un cablu USB

Adăugarea unei imprimante de reţea

Despre tipurile de porturi

Lansarea manuală a Status Messenger (Mesageria de stare)

Specificarea unui port utilizând linia de comandă

Ce este un nume de port?

De ce imprimanta nu se află în listă?


Selectarea imprimantei dintr-un port descoperit

  1. Dacă optaţi pentru stabilirea conexiunii la imprimantă prin intermediul unui port descoperit, obţineţi următoarele informaţii:

    Informaţii despre imprimantă

    Descriere

    Fully Qualified Domain Name (Nume de domeniu complet) (în secţiunea TCP/IP)

    Aceasta include numele imprimantei şi al reţelei la care este conectată. De asemenea, acesta este numele imprimantei.

    IP Address (Adresă IP) (în secţiunea TCP/IP)

    Acesta este un număr unic pe care imprimanta îl utilizează pentru a găsi şi a comunica cu alte dispozitive dintr-o reţea.

    UAA (MAC) (în secţiunea Standard Network Card - Placă de reţea standard)

    Acesta este un număr de identificare pentru hardware unic, care distinge imprimanta de alte dispozitive din reţea.

    Zero Configuration Name (Nume configuraţie zero) (în secţiunea TCP/IP)

    Aceasta indică faptul că imprimanta acceptă zeroconf sau reţea cu configurare zero.

    Notă: Dacă nu deţineţi informaţiile necesare, atunci imprimaţi o pagină de configurare a reţelei. Pentru informaţii suplimentare, consultaţi Ghidul utilizatorului.

  2. Selectaţi din listă imprimanta dvs., apoi faceţi clic pe Continue (Continuare).

  3. Dacă imprimanta dvs. nu este în listă, încercaţi una sau mai multe dintre următoarele variante:

    • Reîmprospătaţi lista de imprimante.

    • Faceţi clic pe Modify Search (Modificare căutare) pentru a adăuga manual imprimanta utilizând setările de reţea avansate.

    • Faceţi clic pe Configure Wireless (Configurare caracteristici fără fir) pentru a adăuga o imprimantă conectată la o reţea fără fir.

    • Faceţi clic pe Specify Port (Specificare port) pentru a adăuga manual imprimanta utilizând porturile.

    • Asiguraţi-vă că aplicaţiile terţe nu blochează imprimanta.

    • Asiguraţi-vă că computerul nu este conectat la o Reţea privată virtuală (VPN).

    • Asiguraţi-vă că atât computerul, cât şi imprimanta sunt conectate la aceeaşi reţea.

    • Asiguraţi-vă că imprimantei îi este atribuită o adresă IP validă, unică.


Conectarea imprimantei printr-un cablu USB

Dacă aţi selectat opţiunea Connect with a USB cable (Conectare utilizând un cablu USB), atunci sistemul de operare creează în mod implicit obiectul de tip imprimantă. Numele obiectului de tip imprimantă trebuie să corespundă cu cel creat de sistemul de operare.

Note:

  • Utilizatorul trebuie să conecteze cablul USB pentru a finaliza instalarea şi a crea obiectul de tip imprimantă.
  • Dacă aţi conectat imprimanta utilizând portul USB, utilizatorul trebuie să lanseze manual Status Messenger (Mesageria de stare).


Adăugarea unei imprimante de reţea

Utilizaţi dialogul Add Network Printer (Adăugare imprimantă de reţea) pentru a căuta imprimante după nume, adresă IP sau subreţea. Găsiţi imprimanta, apoi adăugaţi-o manual la lista de imprimante de reţea disponibile.

Notă: Asiguraţi-vă că ştiţi numele şi adresa IP a imprimantei, precum şi subreţeaua din care face parte. Pentru a obţine aceste informaţii, imprimaţi o pagină de configurare pentru reţea. Pentru informaţii suplimentare, consultaţi Ghidul utilizatorului.

Utilizarea numelui imprimantei şi a adresei IP

Tastaţi numele imprimantei sau adresa IP, apoi faceţi clic pe OK.

Utilizarea adresei de subreţea

Dacă imprimanta şi serverul de imprimare sunt situate în altă reţea (denumită subreţea), găsiţi imprimantele disponibile specificând subreţeaua imprimantei pe care doriţi să o accesaţi.

  • Pentru a adăuga o adresă de subreţea în câmpul specificat, faceţi clic pe Add (Adăugare) > OK.

    Notă: De asemenea, puteţi să căutaţi mai multe adrese de subreţea.

  • Pentru a şterge o adresă de subreţea, selectaţi adresa de subreţea din lista de subreţele descoperite, apoi faceţi clic pe Remove (Eliminare).


Despre tipurile de porturi

Notă: Unele porturi pot fi disponibile numai pe anumite modele de imprimantă.
Tipuri de porturi | Descriere
Server de imprimare extern | Acesta este un dispozitiv extern care permite accesul la reţea prin intermediul porturilor sale Ethernet.
LPR (Line Printer Remote) | Acesta este un protocol utilizat pentru a remite lucrări de imprimare unei imprimante la distanţă.
Server de imprimare | Acesta este un computer sau un dispozitiv conectat la una sau mai multe imprimante şi la computere client printr-o reţea. Poate accepta lucrări de imprimare de la computere şi poate trimite lucrări la imprimantele adecvate.
TCP/IP (Transmission Control Protocol/Internet Protocol) standard | Acesta este un protocol care defineşte regula pe care trebuie să o respecte computerele pentru a comunica între ele prin Internet.
UNC (Universal Naming Convention) | Acesta este un standard pentru identificarea serverelor, a imprimantelor şi a altor resurse dintr-o reţea fără mapare pe placa de reţea. Acesta furnizează o adresă unică pentru fiecare resursă partajată. Aceasta permite sistemelor de operare care acceptă UNC să specifice complet un director de pe un server de fişiere.


Lansarea manuală a Status Messenger (Mesageria de stare)

Notă: Asiguraţi-vă că imprimanta şi computerul sunt conectate printr-un cablu USB.

În Windows 8

Utilizând butonul Search (Căutare), introduceţi textul status messenger (mesagerie de stare) şi navigaţi la:

Lista de aplicaţii > Status Messenger (Mesagerie de stare)

În Windows 7 şi versiunile anterioare

  1. Faceţi clic pe [image] sau pe Start.

  2. Faceţi clic pe All Programs (Toate programele) sau pe Programs (Programe), apoi selectaţi din listă folderul cu programul de imprimantă.

  3. Faceţi clic pe Printer Home (Pagina de pornire pentru imprimante) > Status Messenger (Mesagerie de stare).

Se deschide Status Messenger (Mesageria de stare).

Note:

  • Status Messenger (Mesageria de stare) este disponibilă numai dacă aţi selectat includerea sa la configurarea pachetului.
  • Dacă aţi ales să nu lansaţi manual Status Messenger (Mesageria de stare), după crearea obiectului de tip imprimantă, Status Messenger (Mesageria de stare) se va lansa automat la repornirea computerului.


Specificarea unui port utilizând linia de comandă

Puteţi indica numele şi adresa portului în linia de comandă în timpul instalării selectând Specify the port at install time through the command line (Se specifică portul la instalare în linia de comandă).

Parametru | Valoare | Eşantion
/port: | Nume port | /port:numeport
/address: | Numele reţelei sau adresa IP a imprimantei | /address:123.123.123.123 /address:numereţea

Exemplu din linia de comandă: LexmarkPkgInstall.exe /port:numeport /address:123.123.123.123

Note:

  • LexmarkPkgInstall.exe returnează 0 după o instalare fără erori.
  • Pentru a începe instalarea, specificaţi parametrii pentru port şi adresă.
  • Numele de port şi adresa specificată se aplică pentru toate obiectele de tip imprimantă din pachet care sunt configurate pentru a fi specificate în timpul instalării. Pentru obiectele de tip imprimantă cărora li se atribuie porturi la crearea pachetului, se respectă portul specificat la crearea pachetului.
  • Parametrii din linia de comandă pentru numele sau adresa portului sunt procesaţi numai dacă pachetul a fost creat pentru a accepta numele de port şi adresa în linia de comandă. Dacă aceşti parametri sunt transferaţi unui pachet care nu a fost creat pentru a primi aceste informaţii în linia de comandă, atunci instalarea continuă, dar se ignoră parametrii. Porturile sunt create în funcţie de informaţiile din pachet, şi nu din parametrii din linia de comandă. Apare un avertisment în linia de comandă. În acest caz, codul returnat este 0, deoarece instalarea s-a finalizat fără erori.


Ce este un nume de port?

Numele de port este un nume unic atribuit unui port de pe computerul la care este ataşată imprimanta.


De ce imprimanta nu se află în listă?

Asiguraţi-vă că atât computerul, cât şi imprimanta, sunt conectate la aceeaşi reţea fără fir

Este posibil ca imprimanta să nu fie în aceeaşi reţea fără fir ca şi computerul. SSID-ul imprimantei trebuie să se potrivească cu SSID-ul computerului, dacă acesta este conectat deja la reţeaua fără fir.

  1. Obţineţi SSID-ul reţelei la care este conectat computerul.

    1. Tastaţi adresa IP a punctului de acces (routerului fără fir) în câmpul de adresă din browserul dvs. Web.

      Dacă nu cunoaşteţi adresa IP a punctului de acces, procedaţi astfel:

      În Windows 8

      Utilizând butonul Search (Căutare), introduceţi textul run (executare) şi navigaţi la:

      Lista de aplicaţii > Run (Executare) > introduceţi textul cmd > OK > introduceţi textul ipconfig

      În Windows 7 şi versiunile anterioare

      1. Faceţi clic pe [image] sau pe Start, apoi faceţi clic pe Run (Executare).

      2. În caseta Start Search (Pornire căutare) sau Run (Executare), tastaţi cmd.

      3. Apăsaţi pe Enter sau faceţi clic pe OK, apoi introduceţi textul ipconfig.

      Note:

      • Intrarea „Gateway implicit” este în mod obişnuit punctul de acces, însă trebuie să vă asiguraţi că aceasta aparţine secţiunii „Conexiuni de reţea fără fir” din informaţiile ipconfig.
      • Adresa IP apare ca patru seturi de numere separate prin puncte, de exemplu, 123.123.123.123.

    2. Apăsaţi pe Enter sau pe Go (Accesare).

    3. Când vi se solicită, tastaţi numele de utilizator şi parola pentru punctul de acces, apoi faceţi clic pe OK.

    4. În secţiunea Setări pentru caracteristici fără fir, căutaţi SSID.

    5. Notaţi SSID-ul.

      Notă: Asiguraţi-vă că l-aţi copiat exact, inclusiv literele mari şi mici.

  2. Obţineţi SSID-ul reţelei la care este conectată imprimanta:

    1. Imprimaţi o pagină de configurare în reţea a imprimantei.

      Pentru informaţii suplimentare, consultaţi Ghidul utilizatorului.

    2. În secţiunea Wireless (Fără fir), căutaţi SSID.

  3. Comparaţi SSID-ul computerului cu SSID-ul imprimantei.

    Dacă SSID-urile sunt aceleaşi, atunci computerul şi imprimanta sunt conectate la aceeaşi reţea fără fir.

    Dacă SSID-urile nu sunt aceleaşi, executaţi din nou Wireless Setup Utility (Utilitar de configurare fără fir) pentru a configura imprimanta în reţeaua fără fir utilizată de computer. Aveţi grijă să selectaţi SSID-ul utilizat de computer.

Asiguraţi-vă că computerul nu este conectat la o Reţea privată virtuală (VPN)

Majoritatea Reţelelor private virtuale permit utilizatorilor să comunice numai cu reţeaua VPN respectivă şi nu cu o altă reţea în acelaşi timp. Deconectaţi de la VPN înainte de a instala driverul pe computer sau înainte de a executa configurarea reţelei fără fir pe computer.

Pentru a verifica dacă momentan computerul este conectat o reţea VPN, deschideţi software-ul de client VPN şi verificaţi conexiunile VPN. Dacă nu aveţi un software de client VPN instalat, verificaţi manual conexiunile, utilizând clientul VPN din Windows.

Dacă doriţi să aveţi posibilitatea de a vă conecta la reţeaua locală şi în acelaşi timp la o reţea VPN, solicitaţi-i persoanei care asigură asistenţa sistemului pentru VPN să permită împărţirea tunelelor. Reţineţi că unele organizaţii nu permit împărţirea tunelelor din cauza problemelor tehnice şi de securitate.

Asiguraţi-vă că aplicaţiile terţe nu blochează imprimanta

Aplicaţiile terţe, inclusiv programele antivirus, programele de securitate şi paravanele de protecţie, pot bloca descoperirea imprimantei. Configuraţi setările aplicaţiei pentru deblocarea imprimantei, apoi reîmprospătaţi lista de reţele.


Selectarea programelor software suplimentare

Când selectaţi programe software suplimentare, luaţi în considerare următoarele:

  • Programele software selectate vor fi incluse în pachetul generat şi vor fi instalate în sistemul utilizatorului în directorul specificat în timpul instalării.

  • Utilizaţi aceeaşi cale de instalare la implementarea unui pachet ulterior, pentru a vă asigura că există o singură copie a aplicaţiei instalate şi că aceasta are cea mai recentă versiune.

  • Unele fişiere pot fi instalate fie în directorul x86, fie în sistemul pe 64 de biţi, în funcţie de sistemul de operare utilizat.

  • Lista de aplicaţii software diferă în funcţie de modelul imprimantei.


Lansarea pachetului generat

Efectuaţi oricare dintre următoarele operaţii:

  • Utilizaţi scripturile de conectare ale sistemului de operare.

  • Partajaţi pachetele şi indicaţi utilizatorilor să le invoce.

Notă: Asiguraţi-vă că aveţi suficiente privilegii administrative pentru a realiza instalarea.


Ajutor pentru Package Builder (Generator de pachete)