О справке Конструктора пакетов

Что такое Конструктор пакетов?


Что такое Конструктор пакетов?

Конструктор пакетов позволяет создавать пользовательские пакеты установки, которые можно запускать без участия пользователя и интегрировать в развернутое решение. Этот инструмент создает пакеты установки драйвера, которые автоматизируют установку драйверов принтера с предварительно настроенными параметрами подключения и печати.


Настройка пакета установки

Примечания.

  • Файлы форматов .cab и .exe созданы в указанном месте.
  • Содержимое пакета зависит от выбранных параметров.
  • Некоторые из этих функций доступны только на некоторых моделях принтеров.

Выберите содержимое пакета

В разделе «Параметры содержимого пакета» выберите один из указанных ниже параметров.

  • Включить драйверы печати и/или факса

  • Включить драйверы сканирования и/или дополнительное программное обеспечение

  • Поддержка только одного языка

    Примечание. По умолчанию в созданный пакет включены все языки, которые поддерживает данный продукт. Для уменьшения размера пакета выберите параметр Поддержка только одного языка и выберите соответствующий язык.

Выберите параметры пакета, доступные во время установки

В разделе «Параметры времени установки пакета» выполните одно из указанных ниже действий.

  • Чтобы скрыть состояние установки, выберите Тихая установка.

  • Чтобы отобразить состояние установки с лицензионным соглашением, выберите Показать пользователю состояние установки, а затем выберите Включить лицензионное соглашение.

    Примечание. Для установки пакета пользователь должен принять лицензионное соглашение.

  • Чтобы показать состояние установки и посоветовать пользователю выбрать порт, выберите Показать пользователю состояние установки, а затем выберите Посоветовать пользователю выбрать порт.

    Примечание. При установке созданного пакета пользователь должен выбрать порт.


Настройка драйвера принтера

Знакомство с именем принтера

Коллективный доступ к принтеру

Определение доступных драйверов

Общие сведения о файле конфигурации драйвера

Использование параметров настройки


Знакомство с именем принтера

По умолчанию имя принтера – это название модели принтера. Его также называют объектным именем принтера, которое создается после установки. Объект принтера представляет собой фактический принтер, для которого можно назначать задания печати. Убедитесь в том, объект принтера имеет уникальное имя, которое идентифицирует нужный принтер в сети.

Примечания.

  • Чтобы установить объект принтера как использующийся по умолчанию, выберите Установить как принтер по умолчанию.
  • Чтобы разрешить приложению распознать имя объекта принтера во время установки, выберите Распознавание имени принтера. Этот параметр может отсутствовать в зависимости от приобретенной модели принтера.


Коллективный доступ к принтеру

Установите флажок Совместное использование принтера, а затем введите следующую информацию.

  • Сетевое имя. Имя, которое видят другие пользователи при указании совместного принтера.

  • Комментарии. Дополнительные заметки для сетевого принтера. Его указывать не обязательно.

  • Местоположение. Обозначает физическое местоположение сетевого принтера. Его указывать не обязательно.

Примечание. Убедитесь в том, что включена функция совместного использования файлов и принтера.


Определение доступных драйверов

С нашего веб-сайта можно загрузить универсальные драйверы печати (PCL 5, PCL XL, PS и XPS). Для просмотра совместимых драйверов необходимо знать модель принтера.


Общие сведения о файле конфигурации драйвера

Файл конфигурации драйвера (DCF) это файл, в котором хранятся параметры принтера и другие данные. Имя файла DCF должно иметь расширение .ldc.

При использовании Конструктора пакетов выберите файл конфигурации драйверов, содержащий конфигурации, которые требуется использовать для создания объекта принтера. Отдельная конфигурация внутри файла DCF идентифицируется по описанию.

Файл DCF может содержать одну конфигурацию для любого количества моделей принтеров, а также любого количества различных драйверов (эмуляции PostScript или PCL для Windows).

Примечание. Для программы настройки драйверов необходимо наличие Microsoft XML Core Services (MSXML) 6. Загрузить пакет можно с сайта www.microsoft.com.


Использование параметров настройки

  1. В разделе «Параметры конфигурации» выберите Использовать конфигурацию для применения настроек.

    1. Если требуется использовать существующий файл конфигурации, нажмите Загрузить файл.

    2. Если вы хотите создать новый файл конфигурации, выполните следующие действия:

      1. Нажмите кнопку Создать.

      2. Выберите тип файла конфигурации, который необходимо создать.

      3. Нажмите Готово и сохраните параметры.

        4. Примечание. Если для всех создаваемых в будущем очередей печати вы хотите применить ту же конфигурацию, выберите Применить ко всем будущим установкам. В противном случае, конфигурация будет применена только к этому объекту принтера.

  2. Нажмите ОК.


Настройка подключения принтера

Выбор принтера из найденного порта

Подключение принтера с использованием кабеля USB

Добавление сетевого принтера

Информация о типах портов

Запуск Программы вывода сообщений вручную

Указание порта с помощью командной строки

Что такое имя порта?

Почему мой принтер отсутствует в списке?


Выбор принтера из найденного порта

  1. Если принтер подключен через найденный порт, получите следующие сведения.

    Сведения о принтере

    Описание

    Полностью определенное имя домена (в разделе TCP/IP)

    К нему относится имя принтера и сеть, к которой он подключен. Также называется именем принтера.

    IP-адрес (в разделе TCP/IP)

    Уникальный номер, который использует принтер для поиска других устройств в сети и связи с ними.

    UAA (MAC) (в разделе «Стандартная сетевая плата»)

    Уникальный идентификационный номер аппаратного устройства, который позволяет отличать принтер от другого устройства в сети.

    Имя начальной конфигурации (в разделе TCP/IP)

    Указывает, поддерживает ли принтер zeroconf или технологию начальной конфигурации.

    Примечание. Если у вас нет необходимых данных, распечатайте страницу настроек сети. Для получения дополнительных сведений см. Руководство пользователя.

  2. Выберите принтер в списке, а затем нажмите кнопку Продолжить.

  3. Если ваш принтер не указан в списке, попробуйте выполнить одно или несколько из следующих действий.

    • Обновите список принтеров.

    • Нажмите Изменить поиск, чтобы добавить принтер вручную, используя расширенные настройки сети.

    • Нажмите Настройка беспроводной связи, чтобы добавить принтер, подключенный к беспроводной сети.

    • Нажмите Указать порт, чтобы добавить принтер вручную с помощью портов.

    • Убедитесь в том, что приложения других производителей не блокирую принтер.

    • Убедитесь, что компьютер не подключен к виртуальной частной сети (VPN).

    • Убедитесь, что компьютер и принтер подключены к одной и той же сети.

    • Убедитесь, что для принтера назначен действительный и уникальный IP-адрес.


Подключение принтера с использованием кабеля USB

При выборе параметра Подключение с помощью кабеля USB операционная система по умолчанию создаст объект принтера. Имя объекта принтера должно соответствовать имени, созданному операционной системой.

Примечания.

  • Для выполнения установки и создание объекта принтера пользователь должен вставить кабель USB.
  • Подключив принтер через порт USB, пользователь должен вручную запустить Программу вывода сообщений.


Добавление сетевого принтера

Используйте диалоговое окно «Добавление сетевого принтера» для поиска принтеров по их имени, IP-адресу или подсети. Найдите принтер, а затем вручную добавьте его в список доступных сетевых принтеров.

Примечание. Убедитесь в том, что вам известно имя, IP-адрес принтера и подсеть, которой он принадлежит. Для получения этих сведений распечатайте страницу настройки сети. Для получения дополнительных сведений см. Руководство пользователя.

Использование имени и IP-адреса принтера

Введите имя или IP-адрес принтера, а затем нажмите OK.

Использование адреса подсети

Если принтер и сервер печати находятся в другой сети (называемой подсетью), найдите доступные принтеры, указав подсеть принтера, к которой вы хотите получить доступ.

  • Для добавления адреса подсети введите его в указанное поле, а затем нажмите Добавить > OK.

    Примечание. Возможен поиск нескольких адресов подсети.

  • Для удаления адреса подсети выделите его в списке обнаруженных подсетей, а затем нажмите Удалить.


Информация о типах портов

Примечание. Некоторые порты могут быть доступны только на некоторых моделях принтеров.
Типы портов | Описание
Внешний сервер печати | Внешнее устройство, позволяющее получить доступ по сети через порты Ethernet.
LPR (Line Printer Remote) | Протокол, использующийся для передачи заданий печати на удаленный принтер.
Сервер печати | Компьютер или устройство, подключенное к одному или нескольким принтерам и клиентским компьютерам по сети. Оно может принимать задания печати с компьютеров или отправлять задания печати на соответствующие принтеры.
Стандартный TCP/IP (протокол управления передачей/протокол Интернет) | Протокол, определяющий правила, которые должны соблюдать компьютеры для связи друг с другом через Интернет.
UNC (Универсальное соглашение об именах) | Стандарт идентификации серверов, принтеров и других ресурсов в сети без отображения сетевого диска. Он обеспечивает уникальный адрес каждого общего ресурса. Благодаря этому операционные системы, поддерживающие стандарт UNC, могут полностью указывать каталог на файловом сервере.


Запуск Программы вывода сообщений вручную

Примечание. Убедитесь в том, что принтер подсоединен к компьютеру с помощью кабеля USB.

В системе Windows 8

В окне поиска введите Программа вывода сообщений о состоянии принтера, а затем выполните команду:

Список приложений > Программа вывода сообщений о состоянии принтера

В системе Windows 7 или более ранних версий

  1. Нажмите кнопку [image] или Пуск.

  2. Нажмите Все программы или Программы, а затем выберите в списке папку программ принтера.

  3. Выберите Начальный экран принтера > Программа вывода сообщений о состоянии принтера.

Откроется окно Программы вывода сообщений о состоянии принтера.

Примечания.

  • Программа вывода сообщений о состоянии принтера доступна только в случае ее включения в процессе конфигурации пакета.
  • Если вы не хотите запускать программу вывода сообщений о состоянии принтера вручную, после создания объекта печати эта программа автоматически запустится после перезапуска компьютера.


Указание порта с помощью командной строки

Во время установки можно указать имя и адрес порта в командной строке, выбрав параметр Указать порт при установке в командной строке.

Параметр | Значение | Образец
/port: | Имя порта | /port:portname
/address: | Имя или IP-адрес сети, к которой подключен принтер | /address:123.123.123.123 /address:networkname

Образец командной строки: LexmarkPkgInstall.exe /port:portname /address:123.123.123.123

Примечания.

  • После успешной установки файл LexmarkPkgInstall.exe возвращает 0.
  • Чтобы успешного начала установки укажите параметры порта и адреса.
  • Указанное имя и адрес порта применяются ко всем объектам печати в пакете, указанным в время установки. Если в процессе создания пакета для объектов печати были назначены порты, то предпочтение отдается порту, выбранному во время создания пакета.
  • Параметры командной строки для имени или адреса порта обрабатываются только если пакет был создан для принятия имени и адреса порта в командной строке. Если эти параметры переданы в пакет, не предназначенный для получения этих данных в командной строке, то процесс установки продолжится, но эти параметры будут проигнорированы. Порты созданы на основе информации в пакете, а не на основе параметров командной строки. В окне командной строки появляется предупреждение. В этом случае возвращается код 0, поскольку установка завершена успешна.


Что такое имя порта?

Имя порта – это уникальное имя, назначаемое для порта на компьютере, к которому подключен принтер.


Почему мой принтер отсутствует в списке?

Убедитесь, что компьютер и принтер подключены к одной и той же беспроводной сети

Возможно, принтер и компьютер находятся в разных беспроводных сетях. Если компьютер уже подключен к беспроводной сети, то имя сети SSID, к которой подключен принтер, должно совпадать с именем SSID компьютера.

  1. Узнайте имя SSID сети, к которой подключен компьютер.

    1. Введите IP-адрес точки доступа (беспроводного маршрутизатора) в поле адреса в обозревателе.

      Если IP-адрес точки доступа неизвестен, выполните следующие действия:

      В системе Windows 8

      В окне поиска введите run, а затем выполните команду:

      Список приложений > Run > type cmd > ОК > type ipconfig

      В системе Windows 7 или более ранних версий

      1. Щелкните [image] или нажмите кнопку Пуск и выберите пункт Выполнить.

      2. В поле «Начать поиск» или в окне «Выполнить» введите cmd.

      3. Нажмите Enter или кнопку ОК, а затем введите ipconfig.

      Примечания.

      • В разделе «Шлюз по умолчанию» обычно отображается точка доступа, однако следует убедиться в том, что она отображается в разделе «Беспроводное сетевое соединение» данных настройки ipconfig.
      • IP-адрес отображается в виде четырех наборов цифр, разделенных точками, например 123.123.123.123.

    2. Нажмите клавишу Enter или Go.

    3. При появлении запроса введите имя пользователя и пароль для точки доступа, а затем нажмите кнопку ОК.

    4. В разделе «Параметры беспроводной сети» найдите имя SSID.

    5. Запишите имя SSID.

      Примечание. Скопируйте его точно, обращая внимание на строчные и прописные буквы.

  2. Узнайте имя SSID сети, к которой подключен принтер:

    1. Распечатайте страницу настроек сети с принтера.

      Для получения дополнительных сведений см. Руководство' пользователя.

    2. В разделе «Беспроводная сеть» найдите имя SSID.

  3. Сравните имя SSID принтера и компьютера.

    Если имена SSID совпадают, то компьютер и принтер подключены к одной и той же беспроводной сети.

    Если имена SSID отличаются, запустите программу настройки беспроводной сети еще раз для настройки подключения принтера к беспроводной сети, которая используется компьютером. Убедитесь в том, что выбрано имя SSID, используемое компьютером.

Убедитесь, что компьютер не подключен к виртуальной частной сети

Большинство сетей VPN разрешают для компьютеров обмен данными только с VPN, а одновременная связь с другими сетями не поддерживается. Перед установкой драйвера на компьютере или запуском программы настройки беспроводной связи на компьютере отключите сеть VPN.

Чтобы проверить, подключен ли компьютер к сети VPN, откройте программу клиента VPN, а потом проверьте подключения VPN. Если клиентская программа VPN не установлена, проверьте подключения вручную, используя клиент VPN Windows.

Если требуется возможность одновременного подключения к локальной сети и к сети VPN, попросите специалиста по поддержке VPN разрешить раздельное туннелирование. Следует иметь в виду, что в некоторых организациях запрещено раздельное туннелирование вследствие технических ограничений или соображений безопасности.

Убедитесь в том, что приложения других производителей не блокирую принтер.

Приложения сторонних компаний, включая антивирусные программы, программы для обеспечения безопасности и брандмауэр, могут блокировать бнаружение принтера. Настройте параметры приложения для разблокировки принтера, а затем обновите список сети.


Выбор дополнительного программного обеспечения

При выборе дополнительного программного обеспечения примите во внимание следующее.

  • Выбранное программное обеспечение будет включено в созданный пакет и установлено в системе пользователя в каталог, указанный в процессе установки.

  • Убедитесь, что при развертывании следующего пакета используется тот же путь, чтобы гарантировать наличие только одной копии установленного приложения, причем ее последней версии.

  • В зависимости от использующейся операционной системы некоторые файлы могут быть установлены в каталоге x86 или 64-разрядной системе.

  • Список программных приложений может варьироваться в зависимости от модели принтера.


Запуск созданного пакета

Выполните одно из следующий действий.

  • Использование сценариев входа в операционную систему.

  • Предоставьте пакеты в коллективный доступ и дайте пользователям возможность к ним обращаться.

Примечание. Для выполнения установки необходимы достаточные привилегии администратора.


Справка Конструктора пакетов