Om hjälp för paketbyggare

Vad är en paketbyggare?


Vad är en paketbyggare?

Med paketbyggaren kan du skapa anpassade installationspaket som du kan starta utan indata från användaren och integrera i din distribueringslösning. Det är ett verktyg som skapar installationspaket med drivrutiner som automatiserar installationen av skrivardrivrutiner med förkonfigurerade inställningar för anslutning och utskrift.


Konfigurera installationspaketet

Anmärkningar:

  • Filer i .cab- och .exe-format skapas på den angivna platsen.
  • Paketets innehåll beror på vilka alternativ du väljer.
  • Vissa av funktionerna är endast tillgängliga på utvalda skrivarmodeller.

Välj paketets innehåll

I avsnittet "Alternativ för paketinnehåll" väljer du ett eller flera av följande:

  • Inkludera skrivar- och/eller faxdrivrutiner

  • Inkludera skanningsdrivrutiner och/eller ytterligare programvara

  • Har stöd för endast ett språk

    Obs! Som standard ingår alla språk som produkten har stöd för i paketet som skapas. Om du vill minska storleken på paketet väljer du Har stöd för endast ett språk och väljer ett språk.

Välj tillgängliga paketalternativ vid installation

I avsnittet Alternativ för paketinstallation gör du något av följande:

  • Om du vill att installationsstatus ska vara dold väljer du Tyst installation.

  • Om du vill att installationsstatus ska visas med licensavtalet väljer du Visa installationsstatus för användaren och väljer Inkludera licensavtalet.

    Obs! Användaren måste godkänna licensavtalet för att kunna installera paketet.

  • Om du vill att installationsstatus ska visas och att användaren ska uppmanas att välja en port väljer du Visa installationsstatus för användaren och väljer Uppmana användaren att välja port.

    Obs! Användaren måste välja en port när det skapade paketet installeras.


Konfigurera skrivardrivrutinen

Förstå skrivarnamnet

Dela skrivaren

Identifiera andra tillgängliga drivrutiner

Förstå drivrutinkonfigurationsfilen

Använda konfigurationsinställningar


Förstå skrivarnamnet

Som standard används skrivarmodellen som skrivarnamn. Detta är detsamma som namnet på skrivarobjektet som skapas efter installationen. Ett skrivarobjekt representerar den skrivare som ett utskriftsjobb kan tilldelas. Se till att skrivarobjektet har ett unikt namn så att du kan identifiera rätt skrivare i nätverket.

Anmärkningar:

  • Om du vill att skrivarobjektet ska användas som standardskrivare väljer du Ange som standardskrivare.
  • För att låta programmet känna av skrivarobjektets namn under installationen väljer du Upptäck skrivarnamn. Det här alternativet kanske inte är tillgängligt, beroende på vilken skrivare du har köpt.


Dela skrivaren

Markera kryssrutan Dela skrivaren och ange följande information:

  • Dela namn – Det namn som andra användare ser när de pekar till en delad skrivare.

  • Kommentarer – Ytterligare information för den delade skrivaren. Detta är valfritt.

  • Plats – Anger platsen för den delade skrivaren. Detta är valfritt.

Obs! Kontrollera att fil- och skrivardelning är aktiverat.


Identifiera andra tillgängliga drivrutiner

Universella skrivardrivrutiner (PCL 5, PCL XL, PS och XPS) kan hämtas från vår webbplats. Sök efter din skrivarmodell för att se kompatibla drivrutiner.


Förstå drivrutinkonfigurationsfilen

En drivrutinkonfigurationsfil (DCF) är en fil med sparade skrivarinställningar och annan information. DCF-filer har filändelsen .ldc.

När du använder paketbyggaren väljer du den DCF-fil som innehåller de konfigurationer du vill använda när du skapar ett skrivarobjekt. Den enskilda konfigurationen i en DCF-fil anges med en beskrivning.

En DCF-fil kan innehålla en konfiguration för ett obegränsat antal skrivarmodeller och drivrutiner (PostScript eller PCL-emulering för Windows).

Obs! Verktyget för drivrutinskonfiguration kräver Microsoft XML Core Services (MSXML) 6. Du kan hämta det på www.microsoft.com.


Använda konfigurationsinställningar

  1. Under Konfigurationsinställningar väljer du Använd en konfiguration för att tillämpa inställningarna.

    1. Om du vill använda en befintlig konfigurationsfil klickar du på Ladda fil.

    2. Om du vill skapa en ny konfigurationsfil gör du på följande sätt:

      1. Klicka på Nytt.

      2. Välj vilken konfigurationsdata du vill skapa.

      3. Klicka på Slutför och spara sedan inställningarna.

        4. Obs! Om du vill att samma konfiguration ska tillämpas på alla efterföljande utskriftsköer väljer du Tillämpa på alla framtida installationer. I annat fall gäller konfigurationen bara det här skrivarobjektet.

  2. Klicka på OK.


Konfigurera skrivarens anslutning

Välja skrivare från en identifierad port

Ansluta skrivaren med en USB-kabel

Lägga till en nätverksskrivare

Förstå porttyper

Starta Status Messenger manuellt

Specificera en port med kommandoraden

Vad är ett portnamn?

Varför finns inte min skrivare med på listan?


Välja skrivare från en identifierad port

  1. Om du väljer att upprätta skrivaranslutningen genom en identifierad port behöver du följande information:

    Skrivarinformation

    Beskrivning

    Kvalificerat domännamn (i avsnittet TCP/IP)

    Detta består av namnet på skrivaren och nätverket som den är ansluten till. Detta är även skrivarnamnet.

    IP-adress (i avsnittet TCP/IP)

    Detta är ett unikt nummer som din skrivare använder för att kommunicera med och lokalisera andra enheter i nätverket.

    UAA (MAC) (i avsnittet om standardnätverkskort)

    Detta är ett unikt identifieringsnummer för maskinvaran som skiljer skrivaren från andra enheter i nätverket.

    Nollkonfigurationsnamn (i avsnittet TCP/IP)

    Detta visar att din skrivare stöder zeroconf eller nollkonfiguration av nätverk.

    Obs! Om du inte har den information som krävs kan du skriva ut en sida med nätverksinställningar. Mer information finns i användarhandboken.

  2. Välj skrivaren i listan och klicka sedan på Fortsätt.

  3. Om skrivaren inte finns med i listan provar du med något eller några av följande alternativ:

    • Uppdatera skrivarlistan.

    • Klicka på Ändra sökning för att hitta önskad skrivare manuellt med avancerade nätverksinställningar.

    • Klicka på Konfigurera trådlös anslutning om du vill lägga till en skrivare som är ansluten via trådlöst nätverk.

    • Klicka på Ange port för att lägga till önskad skrivare manuellt med hjälp av portar.

    • Se till att program från tredje part inte blockerar skrivaren.

    • Kontrollera att datorn inte är ansluten till ett virtuellt privat nätverk (VPN).

    • Se till att datorn och skrivaren är anslutna till samma nätverk.

    • Se till att en giltig, unik IP-adress har tilldelats skrivaren.


Ansluta skrivaren med en USB-kabel

Om du valde Anslut med USB-kabel skapas skrivarobjektet i operativsystemet som standard. Namnet på skrivarobjektet bör stämma överens med det som operativsystemet skapade.

Anmärkningar:

  • Användaren måste sätta in USB-kabeln för att slutföra installationen och skapa skrivarobjektet.
  • När du har anslutit skrivaren genom USB-porten måste användaren öppna Status Messenger manuellt.


Lägga till en nätverksskrivare

Använd dialogrutan Lägg till nätverksskrivare för att leta upp en skrivare med hjälp av skrivarnamnet, IP-adressen eller subnätet. När du har hittat skrivaren lägger du till den manuellt i listan över tillgängliga nätverksskrivare.

Obs! Du måste veta namnet och IP-adressen för skrivaren samt vilket subnät den tillhör. För att få den informationen kan du skriva ut en nätverksinstallationssida. Om du vill ha mer information kan du se Användarhandboken.

Använda skrivarnamnet och IP-adressen

Skriv in skrivarnamnet eller IP-adressen och klicka sedan på OK.

Använda subnätadressen

Om skrivaren och skrivarservern finns i ett annat nätverk (som kallas subnät) letar du upp tillgängliga skrivare genom att ange subnätet för skrivaren som du vill komma åt.

  • Du lägger till en subnätadress genom att skriva in subnätadressen i det angivna fältet och sedan klicka på Lägg till > OK.

    Obs! Du kan också söka efter flera subnätadresser.

  • Om du vill ta bort en subnätadress markerar du den i listan över identifierade subnät och klickar på Ta bort.


Förstå porttyper

Obs! Vissa portar är kanske endast tillgängliga i utvalda skrivarmodeller.
Porttyper | Beskrivning
Extern skrivarserver | Detta är en extern enhet som tillåter nätverksåtkomst via dess Ethernet-portar.
LPR (Line Printer Remote) | Detta är ett protokoll för att skicka utskriftsjobb till en fjärrskrivare.
Skrivarserver | Detta är en dator eller en enhet som är ansluten till en eller flera skrivare och till klientdatorer i ett nätverk. Den kan ta emot utskriftsjobb från datorer och skicka jobb till lämpliga skrivare.
Standard TCP/IP (Transmission Control Protocol/Internet Protocol) | Detta är ett protokoll som definierar den regel som datorer måste följa för att kommunicera med varandra över Internet.
UNC (Universal Naming Convention) | Detta är en standard för att identifiera servrar, skrivare och andra resurser i ett nätverk utan att mappa nätverksdrivrutinen. Den förser varje delad resurs med en unik adress. Detta gör att operativsystem som stöder UNC kan ange en exakt katalog på en filserver.


Starta Status Messenger manuellt

Obs! Kontrollera att skrivaren och datorn är anslutna med en USB-kabel.

I Windows 8

I sökrutan skriver du Status Messenger och navigerar sedan till:

Programlista > Status Messenger

I Windows 7 eller äldre versioner

  1. Klicka på [image] eller Start.

  2. Klicka på Alla program eller Program och välj sedan mappen med skrivarprogram i listan.

  3. Klicka på hemsidan för skrivare > Status Messenger.

Status Messenger öppnas.

Anmärkningar:

  • Status Messenger är endast tillgängligt om du valde att ta med det vid paketkonfigureringen.
  • Om du väljer att inte starta Status Messenger manuellt när skrivarobjektet har skapats så startar Status Messenger automatiskt när datorn startas om.


Specificera en port med kommandoraden

Du kan ange portens namn och adress i kommandoraden under installationen genom att välja Ange porten vid installation genom kommandoraden.

Parameter | Värde | Exempel
/port: | Portnamn | /port:portname
/address: | Nätverkets namn eller IP-adressen för skrivaren | /address:123.123.123.123 /address:networkname

Exempel på kommandorad: LexmarkPkgInstall.exe /port:portname /address:123.123.123.123

Anmärkningar:

  • LexmarkPkgInstall.exe returnerar 0 när installationen är slutförd.
  • Ange parametrarna för port och adress för att påbörja installationen.
  • Portnamnet och adressen tillämpas på alla utskriftsobjekt i paketet som är inställda på att anges under installationen. För skrivarobjekt som blir tilldelade en port när paketet skapas är det den porten som gäller.
  • Kommandoradens parametrar för portens namn och adress behandlas endast om paketet skapades för att godkänna portens namn och adress i kommandoraden. Om de här parametrarna läggs in i ett paket som inte ska ta emot den informationen i kommandoraden fortsätter installationen, men parametrarna ignoreras. Portarna skapas utifrån informationen i paketet, inte parametrarna i kommandoraden. En varning visas i kommandoraden. I det här fallet är returkoden 0 eftersom installationen är slutförd.


Vad är ett portnamn?

Portnamnet är ett unikt namn som är tilldelat en port på datorn där skrivaren är ansluten.


Varför finns inte min skrivare med på listan?

Se till att datorn och skrivaren är anslutna till samma trådlösa nätverk

Det kan hända att skrivaren inte finns på samma trådlösa nätverk som datorn. Om datorn redan är ansluten till det trådlösa nätverket måste skrivarens SSID stämma överens med datorns SSID.

  1. Erhåll SSID-namnet för det nätverk som datorn är ansluten till.

    1. Ange IP-adressen för åtkomstpunkten (trådlös router) i adressfältet i webbläsaren.

      Om du inte känner till IP-adressen för åtkomstpunkten gör du följande:

      I Windows 8

      I sökrutan skriver du Kör och navigerar sedan till:

      Programlista > Kör > skriv cmd > OK > skriv ipconfig

      I Windows 7 eller äldre versioner

      1. Klicka på [image] eller klicka på Start och klicka sedan på Kör.

      2. I rutan Påbörja sökning eller Kör skriver du cmd.

      3. Tryck på Enter eller klicka på OK och skriv sedan ipconfig.

      Anmärkningar:

      • Posten ”Standardgateway” är vanligtvis åtkomstpunkten, men se till att den finns i avsnittet "Trådlös nätverksanslutning" i ipconfig-informationen.
      • IP-adressen visas som fyra uppsättningar siffror som skiljs åt med punkter, t.ex. 123.123.123.123.

    2. Tryck på Enter eller Gå.

    3. Ange användarnamnet och lösenordet för åtkomstpunkten när du uppmanas att göra det, och klicka sedan på OK.

    4. Sök efter SSID i avsnittet om trådlösa inställningar.

    5. Skriv ned SSID-namnet.

      Obs! Kontrollera att du kopierar det exakt, inklusive eventuella versaler.

  2. Få fram SSID-namnet för det nätverk som skrivaren är ansluten till:

    1. Skriv ut en nätverksinstallationssida från skrivaren.

      Om du vill ha mer information kan du se Användarhandboken.

    2. I avsnittet Trådlös tittar du efter SSID.

  3. Jämför datorns SSID-namn med skrivarens SSID-namn.

    Om det är samma SSID är datorn och skrivaren anslutna till samma trådlösa nätverk.

    Om det inte är samma SSID kör du verktyget för trådlös installation igen för att installera skrivaren på det trådlösa nätverk som används av datorn. Se till att välja det SSID som datorn använder.

Kontrollera att datorn inte är ansluten till ett virtuellt privat nätverk (VPN)

De flesta virtuella privata nätverk tillåter datorn att endast kommunicera med VPN och inga andra nätverk samtidigt. Koppla från VPN-anslutningen innan du installerar drivrutinen på datorn eller innan du kör den trådlösa installationen på datorn.

Om du vill kontrollera om datorn är ansluten till ett VPN öppnar du VPN-klientprogrammet och kontrollerar sedan VPN-anslutningarna. Om du inte har något VPN-klientprogram installerat kontrollerar du anslutningarna manuellt med Windows VPN-klient.

Om du vill ha möjlighet att ansluta till det lokala nätverket och till ett VPN samtidigt ber du systemadministratören att låta VPN tillåta s.k. split tunneling. Tänk på att vissa företag inte tillåter split tunneling på grund av säkerhets- eller teknikproblem.

Se till att program från tredje part inte blockerar skrivaren

Tredjepartsprogram, inklusive antivirus-, säkerhets- och brandväggsprogram, kan hindra din skrivare från att upptäckas. Konfigurera programinställningarna så att skrivaren inte blockeras och uppdatera sedan nätverkslistan.


Välja ytterligare programvara

Observera följande när du väljer ytterligare programvara:

  • Den valda programvaran omfattas i det skapade paketet och installeras på användarens system i den angivna katalogen vid installationen.

  • Se till att använda samma installationssökväg när du distribuerar nästa paket för att säkerställa att det bara finns en kopia av det installerade programmet och att det är den senaste versionen.

  • Vissa filer kan installeras antingen i x86-katalogen eller på 64-bitarssystemet beroende på vilket operativsystem som används.

  • Listan med programvara kan variera beroende på skrivarmodell.


Öppna det skapade paketet

Gör något av följande:

  • Använd operativsystemets inloggningsskript.

  • Dela paketen och låt användarna aktivera dem.

Obs! Du måste ha tillräcklig administratörsbehörighet för att kunna genomföra installationen.


Hjälp för paketbyggare