Paket Oluşturucu Yardım Hakkında

Paket Oluşturucu nedir?


Paket Oluşturucu nedir?

Paket Oluşturucu, kullanıcı girişi olmadan başlatabileceğiniz ve dağıtım çözümünüze ekleyebileceğiniz özel yükleme paketleri oluşturmanızı sağlar. Yazıcı sürücülerinin yüklenmesini önceden yapılandırılmış bağlantı ve yazdırma seçenekleri ile otomatikleştiren sürücü yükleme paketleri oluşturan bir araçtır.


Yükleme paketini yapılandırma

Notlar:

  • .cab ve .exe biçimli dosyalar belirli konumlarda oluşturulur.
  • Paket içeriği belirlediğiniz seçeneklere göre değişiklik gösterir.
  • Bu özelliklerden bazıları yalnızca belirli yazıcı modellerinde bulunur.

Paket içeriklerini belirleme

"Paket içeriği seçenekleri" bölümünden, aşağıdakilerden bir veya daha fazlasını seçin:

  • Yazıcı ve/veya faks sürücülerini ekle

  • Tarama sürücüleri ve/veya ek yazılım ekle

  • Yalnızca tek dil destekle

    Not: Varsayılan olarak, ürünün desteklediği tüm diller oluşturulan pakete dahildir. Paket boyutunu azaltmak için, Yalnızca tek dil destekle seçeneğini belirleyin ve uygun dili seçin.

Kullanılabilir paket seçeneklerini yükleme sırasında belirleyin.

"Paket yükleme zamanı seçenekleri" bölümünde, aşağıdakilerden birini yapın:

  • Yükleme durumunu gizlemek için, Sessiz yüklemeseçeneğini belirleyin.

  • Yükleme durumunu lisan sözleşmesi ile birlikte görüntülemek için, Yükleme durumunu kullanıcıya göster seçeneğini ve ardından Lisans sözleşmesini ekle seçeneğini belirleyin.

    Not: Paketi yüklemek için kullanıcının lisans sözleşmesini kabul etmesi gerekir.

  • Yükleme durumunu görüntülemek ve kullanıcıdan bir bağlantı noktası seçmesini istemek için, Yükleme durumunu kullanıcıya göster seçeneğini ve ardından Kullanıcıdan bağlantı noktası seçmesini iste seçeneğini belirleyin.

    Not: Kullanıcının bağlantı noktasını oluşturulan paketi yüklerken seçmesi gerekir.


Yazıcı sürücüsünü yapılandırma

Yazıcı adını anlama

Yazıcıyı paylaşma

Mevcut diğer sürücüleri tanımlama

Yazıcı Yapılandırma Dosyasını Anlama

Yapılandırma Ayarlarını Kullanma


Yazıcı adını anlama

Varsayılan olarak yazıcı adı yazıcınızın model adıdır. Yükleme sonrasında oluşturulan yazıcı nesne adı ile de anılır Yazıcı nesnesi, yazdırma işinin atandığı yazıcıyı temsil eder. Yazıcı nesnenizin, ağ üzerinde doğru yolu gösteren bir benzersiz ada sahip olduğundan emin olun.

Notlar:

  • Yazıcı nesnesini varsayılan yazıcı olarak seçmek için, Varsayılan Yazıcı Olarak Ayarla öğesini seçin.
  • Yükleme sırasında uygulamanın yazıcı nesne adını doğru algılayabilmesi için, Yazıcı adını algıla öğesini seçin. Bu seçenek, satın aldığınız yazıcının modeline bağlı olarak kullanılamayabilir.


Yazıcıyı paylaşma

Yazıcıyı paylaş onay kutusunu işaretleyin ve aşağıdaki bilgileri girin:

  • paylaşım Adı—Paylaşılan bir yazıcıya ulaştıklarında diğer kullanıcıların gördükleri ad.

  • Yorumlar—Paylaşılan yazıcı ile ilgili tüm ek notlar. Bu isteğe bağlıdır.

  • Konum—Paylaşılan yazıcının konumunu belirtir. Bu isteğe bağlıdır.

Not: Dosya ve yazıcı paylaşımının açık olduğundan emin olun.


Mevcut diğer sürücüleri tanımlama

Evrensel Yazdırma Sürücüleri (PCL 5, PCL XL, PS, ve XPS) Web sitemizden indirilebilir. Uyumlu sürücüleri görüntülemek için yazıcı modelinizi arayın.


Yazıcı Yapılandırma Dosyasını Anlama

Bir Sürücü Yapılandırma Dosyası (DCF), kaydedilen yazıcı ayarlarını ve diğer verileri depolayan bir dosyadır. DCF'ler .ldc dosya uzantısını kullanır.

Paket Oluşturucu'yu kullanırken, bir yazıcı nesnesi oluşturmak için kullanmak istediğiniz yapılandırmaları içeren DCF'yi seçin. Bir DCF'nin tek tek yapılandırması açıklama ile tanımlanır.

Bir DCF istenildiği kadar sayıda yazıcı modeli ve farklı sürücü (Windows için PostScript ya da PCL emülasyonları) için tek yapılandırma içerebilir.

Not: Sürücü yapılandırma Yardımcı Programı, Microsoft XML Core Services (MSXML) 6 gerektirir. Bu uygulamayı www.microsoft.com adresinden indirebilirsiniz.


Yapılandırma Ayarlarını Kullanma

  1. Yapılandırma Ayarları bölümünden, Ayarları uygulamak için bir yapılandırma kullanın öğesini seçin.

    1. Varolan bir yapılandırma dosyası kullanmak istiyorsanız, Dosya Yükle öğesini tıklatın.

    2. Yeni bir yapılandırma dosyası oluşturmak istiyorsanız, şunu yapın:

      1. Yeni düğmesini tıklatın.

      2. Oluşturmak istediğiniz yapılandırma verisini seçin.

      3. Bitir'i tıklatın ve sonra ayarları kaydedin.

        4. Not: Aynı yapılandırmayı izleyen tüm yazdırma kuyruğu oluşumlarına uygulamak istiyorsanız, Tüm özellik yüklemelerine uygula öğesini seçin. Aksi halde, yapılandırma yalnızca bu yazıcı nesnesi için uygulanacaktır.

  2. Tamam düğmesini tıklatın.


Yazıcı bağlantısını yapılandırma

Algılanan bağlantı noktasındaki yazıcıyı seçme

Bir USB kablosu kullanarak yazıcıyı bağlama

Ağ yazıcısı ekleme

Port türlerini anlama

Durum Habercisi'ni elle başlatma

Bağlantı noktasını komut satırını kullanarak belirtme

Bağlantı noktası adı nedir?

Yazıcım neden listede değil?


Algılanan bağlantı noktasındaki yazıcıyı seçme

  1. Yazıcı bağlantısını algılanan bağlantı noktasından yapmayı seçerseniz, aşağıdaki bilgileri göz önünde bulundurun:

    Yazıcı bilgileri

    Açıklama

    Tam Yetkili Etki Alanı Adı (TCP/IP kısmında)

    Bu, yazıcının ve bağlı olunan ağın adını içerir. Bu, ayrıca yazıcı adıdır.

    IP Adresi (TCP/IP kısmında)

    Bu, yazıcınızın iletişim kurmak ve ağdaki diğer aygıtları bulmak için kullandığı benzersiz bir sayıdır.

    UAA (MAC) (Standart Ağ Kartı kısmında)

    Bu, yazıcıyı ağdaki diğer aygıtlardan ayıran benzersiz bir donanım kimlik numarasıdır.

    Sıfır Yapılandırma Adı (TCP/IP kısmında)

    Bu, yazıcınızın zeroconf veya sıfır yapılandırma ağını desteklediğini gösterir.

    Not: İstediğiniz bilgiler elinizde bulunmuyorsa, ağ kurulum sayfasını yazdırın. Daha fazla bilgi için, Kullanıcı Kılavuzu'na bakın.

  2. Listeden yazıcınızı seçin ve sonra Devam düğmesini tıklatın.

  3. Yazıcınız listede yoksa aşağıdakilerden birini veya birkaçını deneyin:

    • Yazıcı listesini yenileyin.

    • Gelişmiş ağ ayarlarını kullanarak yazıcınızı manuel olarak eklemek için Aramayı Değiştir'i tıklatın.

    • Kablosuz ağa bağlı bir yazıcıyı eklemek için Kablosuz Yapılandırma'yı tıklatın.

    • Bağlantı noktalarını kullanarak yazıcınızı manuel olarak eklemek için Bağlantı Noktası Belirt'i tıklatın.

    • Üçüncü taraf uygulamaların yazıcınızı engellemediğinden emin olun.

    • Bilgisayarınızın Sanal Özel Ağ'a (VPN) bağlı olmadığından emin olun.

    • Bilgisayarınızın ve yazıcınızın aynı ağa bağlı olduğundan emin olun.

    • Geçerli, benzersiz bir IP adresinin yazıcıya atandığından emin olun.


Bir USB kablosu kullanarak yazıcıyı bağlama

USB kablosu ile bağla seçeneğini belirlediyseniz, işletim sistemi varsayılan olarak yazıcı nesnesi oluşturur. Yazıcı nesne adı, işletim sistemi tarafından oluşturulan ile aynı olmalıdır.

Notlar:

  • Kullanıcının yükleme işlemini tamamlamak ve yazıcı nesnesi oluşturmak için USB kablosunu takması gerekir.
  • Yazıcıyı USB bağlantı noktasını kullanarak bağladığınızda, kullanıcının Durum Habercisi'ni elle başlatması gerekir.


Ağ yazıcısı ekleme

Yazıcı adına, IP adresine ve altağa göre yazıcı aramak için Ağ Yazıcısı Ekleme iletişim kutusunu kullanın. Yazıcınızı bulun ve sonra kullanılabilir ağ yazıcıları listesine el ile ekleyin.

Not: Yazıcının adını ve IP adresini ve ait olduğu alt ağı bildiğinizden emin olun. Bu bilgileri elde etmek için bir ağ kurulum sayfası yazdırın. Daha fazla bilgi için, Kullanıcı Kılavuzu'na bakın.

Yazıcının adını ve IP adresini kullanma

Yazıcının adını veya IP adresini girin ve sonra Tamam'ı tıklatın.

Alt ağ adresini kullanma

Yazıcı veya yazıcı sunucusu başka bir ağda (alt ağ adı verilir) yer alıyorsa, erişmek istediğiniz yazıcının alt ağını belirterek kullanılabilir yazıcıları bulun.

  • Alt ağ adresi eklemek için, alt ağ adresini belirlenen alana girin ve ardından Ekle > Tamam'ı tıklatın.

    Not: Birden fazla alt ağ adresi arayabilirsiniz.

  • Bir alt ağ adresini kaldırmak için, bulunan alt ağlar arasından alt ağ adresini seçin ve Kaldır düğmesini tıklatın.


Port türlerini anlama

Not: Bazı bağlantı noktaları yalnızca belirli yazıcı modellerinde bulunabilir.
Bağlantı noktası türleri | Açıklama
Harici yazdırma sunucusu | Bu, Ethernet bağlantı noktaları aracılığıyla ağ erişimi sağlayan bir harici aygıttır.
LPR (Line Printer Remote) | Bu, yazdırma işlerini uzaktaki yazıcıya göndermek için kullanılan protokoldür.
Yazdırma sunucusu | Bu, ağ üzerinde bir veya daha fazla yazıcıya ve istemci bilgisayarlarına bağlanan bir bilgisayar veya aygıttır. Bilgisayarlardan yazdırma işleri alır ve işleri uygun yazıcılara gönderir.
Standart TCP/IP (Transmission Control Protocol/Internet Protocol) | Bu, bilgisayarların Internmet üzerinden birbirleriyle iletişim kurabilmek için izlenmesi gereken kuralları tanımlar.
UNC (Evrensel Adlandırma Kuralı) | Bu, ağ üzerindeki sunucuları, yazıcıları ve diğer kaynakları ağ sürücüsü ile eşleştirmeden belirlemeye yarayan bir standarttır. Her paylaşılan kaynağa bir benzersiz ad sağlar. Bu, UNC'yi destekleyen işletim sistemlerinin bir dosya sunucusunda tamamen bir dizin belirtmelerine izin verir.


Durum Habercisi'ni elle başlatma

Not: Yazıcı ve bilgisayarın bir USB kablosu kullanılarak bağlandığından emin olun.

Windows 8 işletim sisteminde

Arama kısmından, durum habercisi yazın ve şuraya gidin:

Uygulama listesi > Durum Habercisi

Windows 7 veya daha önceki sürümlerde

  1. veya Başlat düğmesini tıklatın.

  2. Tüm Programlar veya Programlar'ı tıklatın ve ardından listeden yazıcı program klasörünü seçin.

  3. Yazıcı Ana Sayfası > Durum Habercisi öğelerini tıklatın.

Durum Habercisi açılır.

Notlar:

  • Durum Habercisi yalnızca paket yapılandırması sırasında eklemeyi seçmeniz durumunda kullanılabilir.
  • Yazıcı nesnesinin oluşturulmasının ardından Durum Habercisi'ni elle başlatmayı tercih etmiyorsanız, bilgisayar yeniden başlatıldığında Durum Habercisi otomatik olarak başlar.


Bağlantı noktasını komut satırını kullanarak belirtme

Yükleme sırasında Bağlantı noktasını yükleme sırasında komut satırı aracılığıyla belirt seçeneğini belirleyerek bağlantı noktası adını ve adresini komut satırında belirtebilirsiniz.

Parametre | Değer | Örnek
/port: | Bağlantı noktası adı | /bağlantı noktası:bağlantınoktasıadı
/adres: | Yazıcının ağ adı ve IP adresi | /adres:123.123.123.123 /adres:ağadı

Örnek komut satırı: LexmarkPkgInstall.exe /bağlantı noktası:bağlantınoktasıadı /adres:123.123.123.123

Notlar:

  • LexmarkPkgInstall.exe, başarılı yüklemeyi takiben 0'a dönüşür.
  • Yüklemeyi başarılı bir şekilde başlatmak için bağlantı noktasını ve adres parametrelerini belirtin.
  • Belirtilen bağlantı noktası ve adres parametreleri, yükleme sırasında belirtilecek paket kapsamındaki tüm yazıcı nesnelerine uygulanır. Paket oluşturma sırasında bağlantı noktaları atanan yazıcı nesneleri için, paket oluşturma işlemi sırasında seçilen bağlantı noktası kabul edilir.
  • Bağlantı noktası adı veya adresi için komut satırı parametreleri yalnızca paketin komut satırındaki bağlantı noktası ve adresini kabul etmek için oluşturulması durumunda işleme alınır. Bu parametrelerin komut satırındaki bu bilgileri alması gerekmeyen bir pakete geçirilmesi durumunda, yükleme işlemi başlar ancak bu parametreleri yok sayar. Bağlantı noktaları, komut satırındaki parametrelere değil paket kapsamındaki bilgilere göre oluşturulur. Komut istemi için bir uyarı oluşur. Bu durumda, yükleme başarıyla tamamlandığından dolayı geri dönüş kodu 0 olur.


Bağlantı noktası adı nedir?

Bağlantı noktası adı, yazıcının takılı olduğu yerde bilgisayardaki bir bağlantı noktasına atanan benzersiz bir addır.


Yazıcım neden listede değil?

Bilgisayarınızın ve yazıcınızın aynı kablosuz ağa bağlı olduğundan emin olun

Yazıcı bilgisayarla aynı kablosuz ağ üzerinde olmayabilir. Bilgisayar zaten bir kablosuz ağa bağlıysa, yazıcının SSID'sinin bilgisayarın SSID'si ile eşleşmesi gerekir.

  1. Bilgisayarın bağlı olduğu ağın SSID'sini öğrenin.

    1. Web tarayıcınızın adres alanına erişim noktanızın (kablosuz yönlendirici) IP adresini girin.

      Erişim noktasının IP adresini bilmiyorsanız, şunları yapın:

      Windows 8 işletim sisteminde

      Arama kısmında, çalıştır yazın ve şuraya gidin:

      Uygulama listesi > Çalıştır > cmd > yazın Tamam > ipconfig yazın

      Windows 7 veya daha önceki sürümlerde

      1. düğmesini tıklatın veya Başlat ve ardından Çalıştır  düğmesini tıklatın.

      2. Arama Başlat veya Çalıştır kutusuna cmd yazın.

      3. Enter tuşuna basın veya Tamam düğmesini tıklatın, ve ardından ipconfig yazın.

      Notlar:

      • "Varsayılan Ağ Geçidi" girişi normalde erişim noktasıdır, ancak ipconfig bilgilerinin "Kablosuz Ağ Bağlantısı" bölümüne ait olduğundan emin olun.
      • IP adresleri, 123.123.123.123 gibi nokta işareti ile ayrılan dört rakam dizisinden oluşur.

    2. Enter tuşuna basın veya Git düğmesine basın.

    3. İstendiğinde, erişim noktası için kullanıcı adı ile parolayı girin ve sonra TAMAM düğmesini tıklatın.

    4. Kablosuz ayarlar bölümünde, SSID'yi bulun.

    5. SSID'yi not alın.

      Not: Büyük harfler de dahil olmak üzere, güvenlik kodunu olduğu gibi not aldığınızdan emin olun.

  2. Yazıcının bağlı olduğu ağın SSID'sini öğrenin:

    1. Yazıcıdan ağ ayarları sayfasını yazdırın.

      Daha fazla bilgi için, Kullanıcı Kılavuzu''na bakın.

    2. Kablosuz bölümünde, SSID'ye bakın.

  3. Bilgisayarın SSID'si ile yazıcının SSID'sini karşılaştırın.

    SSID'ler aynı ise, yazıcı ve bilgisayar aynı kablosuz ağa bağlı demektir.

    SSID'ler aynı değilse, Kablosuz Kurulum Programı'nı yeniden çalıştırarak, yazıcıyı bilgisayar tarafından kullanılan kablosuz ağ üzerine kurun. Bilgisayar tarafından kullanılan SSID'yi seçtiğinizden emin olun.

Bilgisayarın Sanal Özel Ağ'a (VPN) bağlı olmadığından emin olun.

Çoğu VPN, bilgisayarların yalnızca Sanal Özel Ağlar ile iletişim kurmasına izin verir; diğer ağlarla aynı anda iletişim kurmasına izin vermez. Sürücüyü bilgisayara yüklemeden veya kablosuz kurulumunu bilgisayarınızda çalıştırmadan önce VPN bağlantısını kesin.

Bilgisayarın bir VPN'ye bağlı olup olmadığını anlamak için VPN İstemci yazılımınızı açın ve sonra VPN bağlantılarınızı denetleyin. VPN İstemci yazılımı yüklü değilse, Windows VPN İstemci'yi kullanarak bağlantıları el ile denetleyin.

Yerel ağınıza ve VPN'ye aynı anda bağlanabiliyorsanız, VPN sistem destek sorumlusundan bölünmüş tünellemeye izin vermesini isteyin. Bazı kuruluşların güvenlik veya teknik kaygılar dolayısıyla bölünmüş tünellemeye izin vermediğini unutmayın.

Üçüncü taraf uygulamaların yazıcınızı engellemediğinden emin olun

Diğer şahıslara ait uygulamalar, antivirüs yazılımları, güvenlik ve güvenlik duvarı programları yazıcınızın bulunmasını engelleyebilir. Yazıcının engelini kaldırmak için uygulama ayarlarınızı yapılandırın ve sonra ağ listesini yenileyin.


Ek yazılım seçme

Ek yazılım seçerken şunu unutmayın:

  • Yükleme sırasında istenilen yazılım oluşturulan pakete eklenir ve belirtilen dizindeki kullanıcı sistemine yüklenir.

  • Yüklenen uygulamanın yalnızca tek bir kopyası bulunmasını ve bu kopyanın en son sürüm olmasını sağlamak için sonraki paket dağıtımında aynı yükleme yolunu kullandığınızdan emin olun.

  • Bazı dosyalar, kullanılan işletim sistemine bağlı olarak x86 dizinine veya 64-bit sistemine yüklenebilir.

  • Yazılım uygulamaları listesi yazıcı modeline göre değişiklik gösterebilir.


Oluşturulan paketi başlatma

Aşağıdakilerden birini yapın:

  • İşletim sistemi oturum açma komut dosyalarını kullanın.

  • Paketleri paylaşın ve kullanıcıların istemesini sağlayın.

Not: Yüklemeyi gerçekleştirmek için yeterli yönetici ayrıcalıklarına sahip olduğunuzdan emin olun.


Paket Oluşturucu Yardım