关于软件包生成器帮助

什么是“软件包生成器”？


什么是“软件包生成器”？

“软件包生成器”让您创建定制的安装程序软件包，无需用户输入您就能够启动它，并且将它集成到您的部署解决方案中。此工具生成驱动程序安装软件包，这些软件包自动安装打印驱动程序并使用预配置的连接和打印选项。


配置安装软件包

注意：

  • .cab 和 .exe 格式的文件在指定位置生成。
  • 软件包的内容取决于您选择的选项。
  • 其中一些特性仅在精选的打印机型号中可用。

选择软件包的内容

从“软件包内容选项”部分，选择下列项目中的一个或多个：

  • 包括打印和/或传真驱动程序

  • 包括扫描驱动程序和/或其他软件

  • 仅支持单一语言

    注意： 默认情况下，产品支持的所有语言都包括在生成的软件包中。要缩小软件包大小，请选择仅支持单一语言，然后选择适当的语言。

选择在安装期间可用的软件包选项

从“软件包安装时选项”部分，执行下面的操作之一：

  • 要隐藏安装状态，请选择无声安装。

  • 要显示安装状态和许可协议，请选择向用户显示安装状态，然后选择包括许可协议。

    注意： 用户必须接受许可协议才能安装软件包。

  • 要显示安装状态并提示用户选择端口，请选择向用户显示安装状态，然后选择提示用户选择端口。

    注意： 用户必须在安装生成的软件包时选择端口。


配置打印驱动程序

理解打印机名称

共享打印机

识别其他可用的驱动程序

理解驱动程序配置文件

使用配置设置


理解打印机名称

默认情况下，打印机名称是打印机的型号名称。它也被认为是安装后创建的打印机对象名称。打印机对象代表打印作业能够分配到的实际打印机。确认您的打印机对象有唯一的名称，以便在网络上识别正确的打印机。

注意：

  • 要将打印机对象设置为默认打印机，请选择设为默认打印机。
  • 要让应用程序在安装期间检测您的打印机对象名称，请选择检测打印机名称。根据购买的打印机型号，此选项可能不可用。


共享打印机

选择共享打印机复选框，然后输入下列信息：

  • 共享名-当指向共享打印机时，其他用户看到的名称。

  • 备注-共享打印机的任何其他说明。这是可选项。

  • 位置-指出共享打印机的位置。这是可选项。

注意： 确认文件和打印共享打开。


识别其他可用的驱动程序

通用打印驱动程序（PCL 5、PCL XL、PS 和 XPS）可以从我们的 Web 站点下载。搜索您的打印机型号以查看兼容的驱动程序。


理解驱动程序配置文件

驱动程序配置文件（DCF）是存储已保存的打印机设置和其他数据的文件。DCF 使用 .ldc 文件扩展名。

当使用“软件包生成器”时，选择包含您要使用的配置的 DCF 来创建打印机对象。DCF 的单独配置根据描述识别。

DCF 可以包含一个配置，用于任意数量的打印机型号和任意数量不同的驱动程序（用于 Windows 的 PostScript 或 PCL 仿真）。

注意： “驱动程序配置实用程序”要求 Microsoft XML Core Services (MSXML) 6。您可以从 www.microsoft.com 上下载它。


使用配置设置

  1. 从“配置设置”部分，选择使用配置来应用设置。

    1. 如果您要使用现有的配置文件，请单击加载文件。

    2. 如果您要创建新的配置文件，请执行下列操作：

      1. 单击新建。

      2. 选择您要创建的配置数据。

      3. 单击完成，然后保存设置。

        4. 注意： 如果您要将相同的配置应用于所有后续打印队列的创建，请选择应用于今后所有安装。否则，配置将只应用于此打印机对象。

  2. 单击确定。


配置打印机连接

从已找到的端口选择打印机

使用 USB 电缆连接打印机

添加网络打印机

了解端口类型

手动启动“状态信使”

使用命令行指定端口

什么是端口名称？

为什么我的打印机不在列表中？


从已找到的端口选择打印机

  1. 如果您选择通过已找到的端口建立打印机连接，请获取下列信息：

    打印机信息

    描述

    完全合格域名（在 TCP/IP 部分中）

    这包括打印机的名称和它连接的网络。这也是打印机名称。

    IP 地址（在 TCP/IP 部分中）

    这是您的打印机用于与网络上其他设备通信并定位的唯一号码。

    UAA（MAC）（在“标准网卡”部分中）

    这是在网络上区分打印机和另一台设备的唯一硬件识别号。

    零配置名称（在 TCP/IP 部分中）

    这指出打印机支持 zeroconf 或零配置网络。

    注意： 如果您没有必需的信息，请打印网络设置页。如需更多信息，请参阅用户指南。

  2. 从列表中选择打印机，然后单击继续。

  3. 如果您的打印机不在列表中，请尝试下列办法中的一个或多个：

    • 刷新打印机列表。

    • 单击修改搜索来使用高级网络设置手动添加打印机。

    • 单击配置无线来添加在无线网络上连接的打印机。

    • 单击指定端口来使用端口手动添加打印机。

    • 请确认第三方应用程序没有阻碍打印机。

    • 请确认您的计算机没有连接到“虚拟私有网络”（VPN）。

    • 确认您的计算机和打印机都被连接到相同的网络上。

    • 确认有效、唯一的 IP 地址已分配给打印机。


使用 USB 电缆连接打印机

如果您选择了使用 USB 电缆连接，那么操作系统会默认创建打印机对象。打印机对象名称应该与操作系统创建的名称相匹配。

注意：

  • 用户需要插入 USB 电缆来完成安装并创建打印机对象。
  • 当您已经使用 USB 端口连接打印机时，用户需要手动启动“状态信使”。


添加网络打印机

使用“添加网络打印机”对话框按打印机名称、IP地址或子网搜索打印机。查找您的打印机，然后手动将其添加到可用网络打印机列表。

注意： 请确保您知道打印机的名称和IP地址以及其所属的子网。如要获取这些信息，请打印网络设置页。如要获取更多信息，请参阅用户手册。

使用打印机名称和IP地址

输入打印机名称或IP地址，然后单击确定。

使用子网地址

如果打印机和打印服务器位于其他网络（称为子网），请通过指定您要访问的打印机的子网来查找可用打印机。

  • 如要添加子网地址，请在指定字段输入子网地址，然后单击添加 > 确定。

    注意： 您也可以搜索多个子网地址。

  • 如要删除子网地址，请在已发现子网的列表中高亮显示该子网地址，然后单击删除。


了解端口类型

注意： 某些端口只有精选打印机型号上才有。
端口类型 | 描述
外置式打印服务器 | 这是一种外置式设备，允许通过其以太网端口进行网络访问。
LPR（远程行式打印机） | 这是一个协议，用于向远程打印机提交打印作业。
打印服务器 | 这是一台计算机或设备，用来通过网络连接到一个或更多打印机和客户端计算机。可以从计算机接收或向相应的打印机发送打印作业。
标准TCP/IP（传输控制协议/网络协议） | 这是一个协议，用于定义计算机之间通过英特网彼此通信所必须遵循的规则。
UNC（通用命名标准） | 这是在网络中识别服务器、打印机和其它资源的标准，而无需映射网络驱动器。通过唯一的地址提供各个共享资源。这允许支持UNC的操作系统完全在文件服务器上指定路径。


手动启动“状态信使”

注意： 确认打印机和计算机使用 USB 电缆连接。

在 Windows 8 中

从“搜索”Charm 菜单，键入状态信使，然后导览至：

应用程序列表 > 状态信使

在 Windows 7 或更早的版本中

  1. 单击 [image] 或开始。

  2. 单击所有程序或程序，然后从列表中选择打印机程序文件夹。

  3. 单击打印机主页 > 状态信使。

打开“状态信使”。

注意：

  • “状态信使”仅当您已经在软件包配置期间选择包括它时可用。
  • 如果您选择在创建打印对象之后不手动启动“状态信使”，“状态信使”将在计算机重新启动时自动启动。


使用命令行指定端口

您可以通过选择通过命令行在安装时指定端口来在安装期间在命令行上指出端口名和端口地址。

参数 | 值 | 示例
/port: | 端口名 | /port:portname
/address: | 打印机的网络名称或 IP 地址 | /address:123.123.123.123 /address:networkname

命令行示例： LexmarkPkgInstall.exe /port:portname /address:123.123.123.123

注意：

  • LexmarkPkgInstall.exe 在成功安装后返回 0。
  • 指定端口和地址参数以成功开始安装。
  • 指定的端口名称和地址应用于软件包中被设置为在安装期间指定的所有打印对象。对于在软件包创建期间分配端口的打印机对象，使用在打包时选定的端口。
  • 用于端口名称或地址的命令行参数仅在软件包被创建为接受命令行上的端口名称和地址时才被处理。如果这些参数传递给不接收命令行上的此信息的软件包，那么安装过程处理，但忽略这些参数。端口基于软件包中的信息创建，而不是根据命令行上的参数。命令提示符处发布一个警告。这种情况下，由于安装成功完成，因此返回代码为 0。


什么是端口名称？

端口名称是为打印机所连接到的计算机上的端口指定的唯一名称。


为什么我的打印机不在列表中？

确认您的计算机和打印机被连接到同一个无线网络

打印机和计算机可能不在同一个无线网络中。如果计算机已经连接到无线网络，那么打印机的 SSID 必须与计算机的 SSID 相匹配。

  1. 获取计算机所连接的网络的 SSID。

    1. 将您的访问点（无线路由器）的 IP 地址键入到您的 Web 浏览器的地址字段中。

      如果您不知道访问点的 IP 地址，请执行下列操作：

      在 Windows 8 中

      从“搜索”Charm 菜单，键入运行，然后导览至：

      应用程序列表 > 运行 >键入 cmd > 确定 >键入 ipconfig

      在 Windows 7 或更早的版本中

      1. 单击 [image] ，或单击开始，然后单击运行。

      2. 在“开始搜索”或“运行”框中，键入 cmd。

      3. 按 Enter（回车键），或单击确定，然后键入 ipconfig。

      注意：

      • “Default Gateway（默认网关）”项目通常即为访问点，但是请确认它属于 ipconfig 信息的“Wireless Network Connection（无线网络连接）”部分。
      • IP 地址显示为用小数点分隔的四组数字，例如 123.123.123.123。

    2. 按 Enter（回车键）或转到。

    3. 当出现提示时，键入访问点的用户名和密码，然后单击确定。

    4. 在Wireless（无线）设置部分中，查找 SSID。

    5. 记下 SSID。

      注意： 请确认您准确地记录了它，包括任何大写字母。

  2. 获取打印机所连接的网络的 SSID：

    1. 从打印机打印网络设置页。

      如需更多信息，请参阅用户指南。

    2. 在 Wireless（无线）部分中，查找 SSID。

  3. 比较计算机的 SSID 和打印机的 SSID。

    如果两个 SSID 相同，说明计算机和打印机被连接在同一个无线网络上。

    如果两个 SSID 不同，请再次运行 Wireless Setup Utility 来在计算机使用的无线网络上设置打印机。请确认您选择了计算机所使用的 SSID。

请确认计算机没有连接到“虚拟私有网络”（VPN）

大多数“虚拟私有网络”只允许计算机与 VPN 通信，而不能同时与其他网络通信。在计算机上安装驱动程序之前或在计算机上运行无线设置之前，请从 VPN 上断开。

要检查计算机当前是否连接到 VPN，请打开您的 VPN 客户端软件，然后检查您的 VPN 连接。如果您没有安装 VPN 客户端软件，请使用 Windows VPN 客户端手动检查连接。

如果您希望能够同时连接到您的本地网络和 VPN，请请求系统支持人员使 VPN 允许分割隧道。请注意一些组织出于安全或技术考虑将不允许分割隧道。

确认第三方应用程序没有阻碍打印机

包括杀毒软件、安全程序和防火墙程序在内的第三方应用程序可能阻碍您的打印机搜索。将您的应用程序设置配置为解锁打印机，然后刷新网络列表。


选择其他软件

当选择其他软件时，请注意下列事项：

  • 选定的软件将被包括在生成的软件包中，并在安装期间被安装到用户系统上的指定目录中。

  • 确认您在部署后续软件包时使用相同的安装路径，以确保只有一份已安装应用程序的副本，并且是最新的版本。

  • 根据使用的操作系统，一些文件可能被安装在 x86 目录或 64 位系统中。

  • 根据打印机型号的不同，软件应用程序列表可能有所变化。


启动已生成的软件包

请执行下面的任一操作：

  • 使用操作系统登录脚本。

  • 共享软件包，并让用户调用它们。

注意： 确认您拥有足够的管理权限来执行安装。


软件包生成器帮助