關於套裝軟體建置器說明

什麼是套裝軟體建置器？


什麼是套裝軟體建置器？

「套裝軟體建置器」可讓您建立自訂的安裝程序套裝軟體，之後您無須使用者輸入即可啟動該軟體，並將它整合至您的部署解決方案。它是一種用於產生驅動程式安裝套裝軟體的工具，利用預先配置的連線和列印選項，將印表機驅動程式的安裝予以自動化。


配置安裝套裝軟體

請注意：

  • .cab 和 .exe 格式的檔案將在指定的位置產生。
  • 套裝軟體的內容依您所選取的選項而定。
  • 某些功能只適用於選定的印表機型號。

選取套裝軟體的內容

從「套裝軟體內容選項」區段，選取下列其中一個或多個項目：

  • 併入列印及/或傳真驅動程式

  • 併入掃描驅動程式及/或其他軟體

  • 僅支援一種語言

    請注意： 依預設，該產品支援的所有語言會全部納入所產生的套裝軟體。若要減小套裝軟體的大小，請選取僅支援一種語言，然後選取適用的語言。

在安裝期間選取可用的套裝軟體選項

從「套裝軟體安裝時間選項：」區段，執行下列其中一項：

  • 若要隱藏安裝狀態，請選取無聲安裝。

  • 若要顯示具授權合約的安裝狀態，請選取向使用者顯示安裝狀態，然後選取納入授權合約。

    請注意： 使用者必須接受授權合約，才能安裝套裝軟體。

  • 若要顯示安裝狀態並提示使用者選取連接埠，請選取向使用者顯示安裝狀態，然後選取提示使用者連接埠選項。

    請注意： 使用者必須在安裝所產生的套裝軟體時選取連接埠。


配置列印驅動程式

瞭解印表機名稱

共用印表機

識別其他可用的驅動程式

瞭解驅動程式配置檔

使用配置設定


瞭解印表機名稱

依預設，印表機名稱是指您印表機的型號名稱。它也是安裝程序後所建立的印表機物件名稱。印表機物件代表可接受指定列印工作的實際印表機。確認您的印表機物件具有唯一的名稱，方便您在網路上識別正確的印表機。

請注意：

  • 若要將印表機物件設定為預設的印表機，請選取設為預設印表機。
  • 若要讓應用程式在安裝期間偵測到您的印表機物件名稱，請選取偵測印表機名稱。視您購買的印表機型號而定，某些型號可能無法使用此選項。


共用印表機

選取分享印表機勾選框，然後輸入下列資訊：

  • 共用名稱—每當指向共用印表機時，讓其他使用者看到的名稱。

  • 註解—共用印表機的任何額外附註。這是選擇性項目。

  • 裝置位置—指示共用印表機的位置。這是選擇性項目。

請注意： 確認已啟用檔案及印表機共用。


識別其他可用的驅動程式

您可以從本公司網站下載「通用列印驅動程式」（PCL 5、PCL XL、PS 及 XPS）。搜尋您的印表機型號，以檢視相容的驅動程式。


瞭解驅動程式配置檔

驅動程式配置檔 (Driver Configuration File, DCF) 是一種檔案，用於儲存已保存的印表機設定及其他資料。DCF 使用 .ldc 作為延伸檔名。

使用「套裝軟體建置器」時，您選取的 DCF 須內含您要用於建立印表機物件的配置。DCF 的個別配置是以說明作為識別。

DCF 可以包含一種配置，適用於任意數目的印表機機型和任意數目的不同驅動程式（PostScript 或 PCL 模擬模式適用於 Windows）。

請注意： 「驅動程式配置公用程式」須搭配使用 Microsoft XML Core Services (MSXML) 6。您可從以下網站下載該程式：www.microsoft.com。


使用配置設定

  1. 從「配置設定」區段，選取使用配置套用預設值。

    1. 若您要使用現存的配置檔，請按一下載入檔案。

    2. 若您要建立新的配置檔，請執行下列各項：

      1. 按一下新建。

      2. 選取您要建立的配置資料。

      3. 按一下完成，然後儲存設定。

        4. 請注意： 若您要將相同的配置套用至後續建立的所有列印佇列，請選取套用至以後所有安裝。否則，該配置只會套用至此印表機物件。

  2. 按一下確定。


配置印表機連線

從找到的連接埠選取印表機

使用 USB 電纜連接印表機

新增網路印表機

瞭解連接埠類型

手動啟動狀態訊息管理程式

使用指令行指定連接埠

什麼是連接埠名稱？

為何清單中沒有列出我的印表機？


從找到的連接埠選取印表機

  1. 若您選擇透過找到的連接埠建立印表機連線，請取得下列資訊：

    印表機資訊

    說明

    完整網域名稱（在 TCP/IP 區段中）

    此設定包含印表機名稱及印表機所連接的網路。這也是印表機名稱。

    IP 位址（在 TCP/IP 區段中）

    這是一組獨一無二的數字，您的印表機使用它來與網路上的其他裝置互通並尋找這類裝置。

    UAA (MAC)（在「標準網路卡」區段中）

    這是一組唯一的硬體識別碼，可用來區別印表機與網路上的其他裝置。

    零配置名稱（在 TCP/IP 區段中）

    這表示您的印表機支援 zeroconf 或零配置網路功能。

    請注意： 若您沒有必要的資訊，請列印網路設定頁。如需其他資訊，請參閱用戶手冊。

  2. 從清單中選取您的印表機，然後按一下繼續。

  3. 如果您的印表機沒有列在清單中，請嘗試下列其中一或多項：

    • 重新整理印表機清單。

    • 按一下修改搜尋，以使用進階網路設定，手動新增您的印表機。

    • 按一下配置無線網路，以新增連接至無線網路的印表機。

    • 按一下指定連接埠，以使用連接埠手動新增印表機。

    • 確認其他廠商應用程式不會封鎖您的印表機。

    • 確認電腦不是連接到「虛擬私人網路」(Virtual Private Network, VPN)。

    • 確認電腦與印表機均連接至同一個網路。

    • 確認已將有效且唯一的 IP 位址指定給印表機。


使用 USB 電纜連接印表機

若您選取了利用 USB 纜線連接，則依預設，作業系統會建立印表機物件。印表機物件名稱必須與作業系統建立的名稱相符。

請注意：

  • 使用者必須插入 USB 電纜以完成安裝程序，並建立印表機物件。
  • 當您使用 USB 連接埠連接印表機時，使用者必須手動啟動「狀態訊息管理程式」。


新增網路印表機

「新增網路印表機」對話方塊可讓您按照印表機名稱、IP 位址或子網路來搜尋印表機。尋找您的印表機，然後將它手動新增到可用網路印表機清單。

請注意： 請確定您知道該印表機的名稱和 IP 位址，以及它所屬的子網路。若要取得這些資訊，請列印網路設定頁。如需其他資訊，請參閱用戶手冊。

使用印表機名稱和 IP 位址

輸入印表機名稱，然後按一下確定。

使用子網路位址

若印表機和列印伺服器位於另一個網路（稱為子網路），請指定您要存取的印表機的子網路，來尋找可用的印表機。

  • 若要新增子網路位址，請在指定欄位上輸入子網路位址，然後按一下新增 > 確定。

    請注意： 您也可以搜尋多個子網路位址。

  • 若要移除子網路位址，請從找到的子網路清單中高亮度顯示該子網路位址，然後按一下移除。


瞭解連接埠類型

請注意： 某些連接埠可能只適用於特定印表機型號。
連接埠類型 | 說明
外接式列印伺服器 | 一種外接式裝置，可讓您藉由它的乙太網路連接埠來進行網路存取。
LPR (Line Printer Remote) | 一種通訊協定，可讓您將列印工作送交遠端印表機。
列印伺服器 | 一種電腦或裝置，可讓您透過網路將它連接到一或多台印表機，或連接到用戶端電腦。它可以從電腦接受列印工作，然後將工作傳送到適當的印表機。
標準 TCP/IP（傳輸控制通訊協定/網際網路通訊協定） | 一種通訊協定，用以制定各部電腦透過網際網路互相通訊時必須遵循的規則。
UNC（通用命名規則） | 一種標準，在不對映網路磁碟的情形下，用以識別網路中的伺服器、印表機及其他資源。它為每一項共用資源分別提供一個獨一無二的位址。此作法可讓支援 UNC 的作業系統在檔案伺服器上完整指定目錄。


手動啟動狀態訊息管理程式

請注意： 確認已利用 USB 電纜連接印表機和電腦。

在 Windows 8 中

從「搜尋」圖標，輸入 status messenger，然後導覽至：

應用程式清單 > 狀態訊息管理程式

在 Windows 7 或較舊版本中

  1. 按一下 [image] 或開始。

  2. 按一下所有程式或程式集，然後從清單中選取印表機程式資料夾。

  3. 按一下印表機主畫面 > 狀態訊息管理程式。

隨即開啟「狀態訊息管理程式」。

請注意：

  • 您必須在套裝軟體配置期間選擇併入「狀態訊息管理程式」，才能使用「狀態訊息管理程式」。
  • 若您選擇不要手動啟動「狀態訊息管理程式」，則在建立列印物件後，會在電腦重新啟動時自動啟動「狀態訊息管理程式」。


使用指令行指定連接埠

您可以經由選取透過指令行指定安裝時的連接埠，在安裝期間於指令行指示連接埠名稱及連接埠位址。

參數 | 值 | 範例
/port: | 連接埠名稱 | /port:portname
/address: | 印表機的網路名稱或 IP 位址 | /address:123.123.123.123 /address:networkname

指令行範例：LexmarkPkgInstall.exe /port:portname /address:123.123.123.123

請注意：

  • LexmarkPkgInstall.exe 在成功安裝後傳回 0。
  • 指定連接埠及位址參數，以順利起始安裝程序。
  • 指定的連接埠名稱及位址會在安裝期間套用至套裝軟體中指定的所有列印物件。對於在套裝軟體建立期間由程式指定了連接埠的印表機物件，此時會啟用套裝軟體建置期間所選取的連接埠。
  • 只有在所建立的套裝軟體要用於接受指令行上的連接埠名稱或位址時，才會處理連接埠名稱或位址的指令行參數。若這些參數被傳送至某套裝軟體，但該套裝軟體不適用於接收指令行上的此資訊，則安裝程序會繼續作業，但會忽略這些參數。連接埠的建立是根據套裝軟體中的資訊，並非來自指令行上的參數。此時會將警告發出至指令行提示。在此情況下，由於安裝順利完成，所以回傳碼為 0。


什麼是連接埠名稱？

連接埠名稱就是指定給連接印表機之電腦上的連接埠的獨一無二名稱。


為何清單中沒有列出我的印表機？

確認電腦與印表機連線到同一個無線網路

印表機和電腦可能沒有位在同一個無線網路上。若電腦已連接到無線網路，印表機的 SSID 必須與電腦的 SSID 相符。

  1. 取得電腦所連接網路的 SSID。

    1. 在 Web 瀏覽器的位址欄位中，輸入存取點（無線路由器）的 IP 位址。

      若您不知道存取點的 IP 位址，請執行下列各項：

      在 Windows 8 中

      從「搜尋」圖標，輸入 run，然後導覽至：

      應用程式清單 > 執行 > 輸入 cmd > 確定 > 輸入 ipconfig

      在 Windows 7 或較舊版本中

      1. 按一下 [image] ，或按一下開始，然後按一下執行。

      2. 在「開始搜尋」或「執行」方框中，輸入 cmd。

      3. 按下 Enter，或按一下確定，然後輸入 ipconfig。

      請注意：

      • 「預設的閘道」項目通常就是存取點，不過，最好還是確定它是否屬於 ipconfig 資訊的「無線網路連線」區段。
      • IP 位址會以四組以英文句點隔開的號碼呈現，例如：123.123.123.123。

    2. 按下 Enter 或執行。

    3. 當您看到提示時，請輸入存取點的使用者名稱及密碼，然後按一下確定。

    4. 在「無線設定」區段中，尋找 SSID。

    5. 請記下 SSID。

      請注意： 請確認抄寫正確，包括任何字母大小寫在內。

  2. 取得印表機所連接網路的 SSID：

    1. 從印表機列印網路設定頁。

      如需其他資訊，請參閱用戶手冊。

    2. 在「無線」區段中，尋找 SSID。

  3. 比較電腦的 SSID 與印表機的 SSID。

    如果兩個 SSID 相同，表示電腦和印表機已連線到同一個無線網路。

    若 SSID 不同，請重新執行「無線設定公用程式」，在電腦所使用的無線網路上設定印表機。確認您已選取電腦所使用的 SSID。

確認電腦不是連接到「虛擬私人網路」(VPN)

大部分的「虛擬私人網路」都只能讓電腦與 VPN 互通，而無法同時與其他網路互通。請先中斷 VPN 的連線，然後將驅動程式安裝在電腦上，或是在電腦上執行無線設定。

若要檢查電腦目前是否連接到 VPN，請開啟「VPN 用戶端」軟體，然後檢查 VPN 連線。若尚未安裝「VPN 用戶端」軟體，請利用「Windows VPN 用戶端」，以手動方式檢查連線。

若您希望具備同時連接到本端網路和 VPN 的功能，請要求系統支援人員允許 VPN 進行分域 (split tunneling)。請注意，有些組織會基於安全或技術上的考量，不允許採用分域。

確認協力廠商應用程式不會封鎖您的印表機

第三方應用程式，包括防毒程式、安全程式及防火牆程式，有可能阻斷對您的印表機所進行的搜尋。請將應用程式設定配置為解除阻斷您的印表機，然後重新整理網路清單。


選取其他軟體

選取其他軟體時，請記錄以下資料：

  • 選定的軟體會納入所產生的套裝軟體，而且會在安裝期間安裝在使用者系統的指定目錄下。

  • 確認您在部署後續套裝軟體時須使用同一路徑，以確保只有安裝一個版本的應用程式，而且是最新版的應用程式。

  • 某些檔案可以安裝在 x86 目錄或 64 位元系統下，視您所用的作業系統而定。

  • 軟體應用程式清單可能因印表機型號而有所差異。


啟動產生的套裝軟體

請執行下列其中一項：

  • 使用作業系統登入 Script。

  • 共用套裝軟體並讓使用者呼叫這些套裝軟體。

請注意： 確認您擁有足夠的管理權限，以執行安裝作業。


套裝軟體建置器說明